x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error windows SDK v8.1 must be installed in order to build this target

I have windows 7 trying to make basic C++ coding file in Unreal engine version 4.14.1 but it says I need windows 8.1, I don't want windows 8 or 10 so I guess I have to download a previous version of Unreal engine, does anyone know which version will work with windows 7?

Product Version: UE 4.14
Tags:
more ▼

asked Dec 19 '16 at 12:53 PM in Using UE4

avatar image

lsent
26 2 3 5

avatar image Adam USW Feb 15 '17 at 03:47 PM

Seems to be related to third-party plugins...

If I create a new 'blank' project with all 3rd party plugins turned off it compiles fine. Then turn on something like substance or low-entry (relaunch editor) and the build fails with the 'Windows SDK v8.1 must be installed' error.

This was with a standard 4.14.3 Blueprint-based project

avatar image Karol Jenny Nov 14 '18 at 02:29 AM

Thank you. Installing the SDK helped me use Window 8 faster. There are many parameters on the image, which are improved on the pc.

(comments are locked)
10|2000 characters needed characters left

7 answers: sort voted first

Hi Isent,

The SDK installation doesn't mean you have to have Windows 8.1 or 10 installed. You just need the SDK installation so that you can properly build for these.

You can download and install them from here:

-Tim

more ▼

answered Dec 19 '16 at 01:10 PM

avatar image

Tim Hobson ♦♦ STAFF
49.2k 885 96 870

avatar image lsent Dec 19 '16 at 01:44 PM

Cheers Tim I thought for a minute I'd have to get windows 8 :(

avatar image Tim Hobson ♦♦ STAFF Dec 19 '16 at 02:04 PM

No problem. I remember running into similar issues with Windows 7 when I was deploying to an Xbox One and it needs the SDK for Windows 10 to do so correctly. I think it's an uncommon issue that some have run into seeing that a lot of people have now switched over to Windows 10.

avatar image cizaphil Mar 11 '17 at 07:48 AM

Hi Tim, I just installed windows 10 sdk, yet the generateprojectfiles is still requesting that I install windows v8.1 sdk, is there any way to resolve this problem?

avatar image Light_Shock Mar 15 '17 at 07:03 PM

My reading of this is that because you have 10 and the build is trying to create something that when shipped will work on 10 AND 8,1 it needs you to install the 8.1 kit so that it has the things needed for 8.1.

avatar image miraomid Jul 17 '17 at 06:30 AM

i have windows 10 installed. i installed windows sdks bot v8.1 and v10 , and i still get this error : Error windows SDK v8.1 must be installed in order to build this target

avatar image brenwayne Jul 20 '17 at 03:26 AM

I have the same issue. I installed windows SDK 8.1 and I'm still getting the error that says it needs to be installed.

avatar image Adam USW Jul 20 '17 at 10:27 AM

Have you got c++ components installed in Visual Studio? (They aren't installed by default). Microsoft's MDSN site explains how to too add c++ support:

"In Visual Studio 2015, Visual C++ is not installed by default. When installing, be sure to choose Custom installation and then choose the C++ components you require. Or, if Visual Studio is already installed, choose File | New | Project | C++ and you will be prompted to install the necessary components."

avatar image brenwayne Jul 20 '17 at 02:00 PM

Thanks Adam, that worked.

avatar image Zerdath Apr 14 '17 at 04:15 AM

Bravo Tim, TY so much!

avatar image Leniaal Sep 25 '17 at 11:58 AM

For the people installing visual studio 2017. alt text

More info here: https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/ scroll down to visual studio 2017 users

avatar image Ceilbird Oct 10 '17 at 01:15 AM

Thank you!

avatar image Ceilbird Oct 10 '17 at 01:18 AM

You can also download it by modifying the Visual Studio 2017 file in "Change/Uninstall"

avatar image Wallenstein Nov 24 '17 at 12:45 AM

I just installed a new Windows 10 machine, switched from 4.17 to 4.18 and installed VS2017 instead of 2015. I had to download the 8.1 SDK from the link above plus I set an "Everyone" with full access in the access list for my project directory tree as well as the complete Epic install tree. Also my project depended on the dungeon Architect plugin so I had to install that too. After several restarts it seems to work now

avatar image LordArdiNugraha Jan 04 '18 at 04:43 AM

I have same problem, but here in my case: i have installed the windows 10 sdk via here https://developer.microsoft.com/en-us/windows/downloads/windows-10-sdk but the windows 10 sdk is not detected in vs installer , and win 8.1 sdk is not installed.

but i can run the GenerateProjectFiles by changing the line of code on \Engine\Source\Programs\UnrealBuildTool\U nrealBuildTool.csproj from 8.0 to 8.1 which based on solution from here https://forums.unrealengine.com/development-discussion/engine-source-github/1400696-errors-when-run-generateprojectfiles-bat-in-uwp-unreal-release

is it ok or no?

avatar image ilias48rus Mar 10 '18 at 09:18 PM

I got the issue, installed 8.1 SDK (didn't helped), modified VS with 8.1 SDK ,the issue still persist, can't add any c++ asset to the project, please help.

avatar image Wallenstein Mar 10 '18 at 11:37 PM

Check the toolchain setting sin VS project options. In my case I had a mix of old and new toolchains in my project. Once I cleared it all and deleted all temporary files it was OK

avatar image ilias48rus Mar 10 '18 at 11:57 PM

sorry for possibly dumb question ,but what "toolchain" you mean ? (couldn't find such setting)

avatar image Wallenstein Mar 14 '18 at 09:42 PM

Sorry I may have mixed it up, when you have regular projects you ahve this field in the general tab of the project settings and if you have VS 2015 and 2017 installed you get different options there. After upgrading to VS2017 I had to use some tool to remove the remaining toolchaing from 2015 completely, my programs used a mix of old and new. I don't know how this can be set for Unreal Projects I seem to remember there was a way but I don't know anymore. For me, the final solution after many tries was to get rid of Visual Studio 2017 and even restore windows to a previous point in time before I installed 2017. Conclusion for me: As long as Epic does not request VS 2017 as mandatory, I stick with 2015. There isn't anything I need in 2017 anyway. Oh and BTW: My Visual Assist performed terribly in the VS2017 environment, that was another reason to go back to the older one alt text

toolset.jpg (57.6 kB)
(comments are locked)
10|2000 characters needed characters left

Hello, I had the same problem with windows 10, Visual Studio 2017 and Epic Game Launcher 4.19.1. I had solved the error with this step : - Open Programs and Features - On Visual Studio Community 2017 and click on Change - In Visual Studio Installer click on Modify - Click on Individual components on top - Then click on checkbox Unreal Engine installer in the section Games and Graphics.

I hope this can help you :)

alt text

alt text

more ▼

answered Apr 23 '18 at 10:23 AM

avatar image

Cello-kzk
16 2

avatar image StoshFerhobin Nov 11 '18 at 06:19 PM

This worked for me, thanks! Also here is how to get to "modify": https://docs.microsoft.com/en-us/visualstudio/install/modify-visual-studio?view=vs-2017 basically just find and run the vs installer

(comments are locked)
10|2000 characters needed characters left

hi for solving this problem when you want setup vs in vs community make sure you selected windows sdk 8.1 for setup...

more ▼

answered Apr 13 '18 at 01:31 PM

avatar image

the_nessepa
1

(comments are locked)
10|2000 characters needed characters left

hi for solving this problem when you want setup vs in vs community make sure you selected windows sdk 8.1 for setup...

more ▼

answered Apr 13 '18 at 01:31 PM

avatar image

the_nessepa
1

(comments are locked)
10|2000 characters needed characters left

Hey. Try installing Visual Studio 2015.

more ▼

answered Apr 16 '18 at 06:04 PM

avatar image

mcgpc64
0 1

(comments are locked)
10|2000 characters needed characters left

Thanks Cello, your fix solved it for me

more ▼

answered May 03 '18 at 08:45 AM

avatar image

Freeccs
1 1 3

(comments are locked)
10|2000 characters needed characters left

I have UE 4.18.3 and Visual Studio 2017 community edition installed. When I tried packaging my project for Windows x64 only I got the message described in this topic. So I downloaded and installed it from Microsoft's website.

Then when I tried to package the project again I got this message:

"The Binaries for this Target Platform are not currently installed, would you like to use the Launcher to download them?"

When I clicked Yes, the launcher crashed.

I then followed Cello's advice and rebooted. Still getting a launcher crash.

Any ideas?

more ▼

answered May 31 '18 at 10:52 PM

avatar image

Gamieon
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question