x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unknown Cook Failure

I have been stuck on this for a couple weeks. Every time I build it fails on UAT/cooking. I have cleared all warnings. I have created a new package and imported all content. I updated my Visual Studio Community. Also I tried building a separate package and it works. If someone could please have a look at my logs and suggest ways of debugging I would appreciate it. I have version 4.14.1 installed.

PackagingResults:Error: Error Unknown Cook Failure

UAT_Log.txt

Cook-2016.12.19-15.34.21.txt

Product Version: UE 4.14
Tags:
more ▼

asked Dec 19 '16 at 08:04 PM in Packaging & Deployment

avatar image

Brahzoo
11 1 5 5

avatar image Steve Hardister ♦♦ STAFF Dec 20 '16 at 08:04 PM

Hi Brahzoo,

I did not find the text "Error Unknown Cook Failure" in either of the two logs you have posted. Please open your Output Log, right-click and select "Clear." Then try and package your project again.

When packaging fails, cut and paste the entire newly generated data from the Output Log into a text file and post here. This should allow us to identify the cause of the packaging fail.

Lastly, please include what platform are you packaging for.

Steve H.

avatar image Brahzoo Dec 21 '16 at 03:10 AM

[link text][1] [1]: /storage/temp/119462-outputlog.txt

Hi Steve, I am trying to build a package for Windows 64bit (I tried 32 bit and got similar results). I have uploaded the output log as you requested. Thanks.

outputlog.txt (483.6 kB)
avatar image Steve Hardister ♦♦ STAFF Dec 21 '16 at 08:12 PM

Here is the error that is currently causing your build to fail:

 Error: === Critical error: ===
 ...Assertion failed: Result != NULL 
 [File:D:\Build\++UE4+Release 4.14+Compile\Sync\Engine\Source\Runtime\Engine\Private\EdGraph\EdGraphNode.cpp] [Line: 107] 

Debug "EdGraphNode.cpp" and retry packaging. Looking for the first "error" in your Output Log will reveal what needs to be corrected before moving forward.If after fixing the EdGraphNode you still need help, post a new log.

Some general steps you can take in the meantime are:

  1. After compiling and saving all, delete the Intermediate and Saved folders from the Project Folder

  2. Right-click on the Contents folder and select "Fix up redirectors in Folder"

  3. If EdGraphNode is part of a Blueprint, open the blueprint, click on Edit, and choose "Delete unused variables."

  4. Recompile & save all.

  5. Package and save and post new log if packaging fails.

-Steve H.

avatar image Brahzoo Dec 22 '16 at 05:09 PM

I have never debugged a source code cpp file in Unreal. My project is fully in blueprints. I have located the EdGraphNode.cpp under: C:\Program Files\Epic Games\4.14\Engine\Source\Runtime\Engine\Private\EdGraph

I have found the line that it is complaining about: UEdGraphPin* UEdGraphNode::FindPinChecked(const FString& PinName, const EEdGraphPinDirection Direction) const { UEdGraphPin* Result = FindPin(PinName, Direction); check(Result != NULL); return Result; }

I opened up the EdNodeGraph.cpp file in VIsualStudio and tried adding some print statements. Now I saved it, and how do I compile? How do i link it with my project?

avatar image Steve Hardister ♦♦ STAFF Dec 22 '16 at 06:11 PM

Since it was referencing a .cpp file and you mentioned that you updated VS Community I thought you were working on a Code Project. However, it should not make a difference: Skip the compile and recompile steps, following the remaining steps, including deleting the Intermediate and Saved folders.

Clear the output log and try to package again. If it still fails to package, cut and paste the contents from the new output log into a text file and post.

avatar image Brahzoo Dec 22 '16 at 07:31 PM

I did the steps as you mentioned above. I had to compile every blueprint individually, I found some new warnings got rid of the, but still that didn't help my case. I also deleted the cache in: C:\Users.....\AppData\Local\UnrealEngine

Here is my updated output.log, it seems very similar: link text

Thanks

outputlog.txt (494.8 kB)
avatar image Steve Hardister ♦♦ STAFF Dec 22 '16 at 08:26 PM

Can you locate and post the following log: C:\Users\Brahzoo\AppData\Roaming\Unreal Engin e\AutomationTool\Logs\C+Program+Files+Epic+Games+4.14\Cook-2016.12.22-14.13.40.txt

avatar image Brahzoo Dec 22 '16 at 09:14 PM

as requested: link text

avatar image Steve Hardister ♦♦ STAFF Dec 22 '16 at 10:04 PM

This log is almost identical to the Output log which is not giving me anything to go on beyond the EdGraphNode.cpp error. (If you haven't already, remove this blueprint or node from your project).

At this point, the last thing I can suggest is to send your project as a link to a zipped project on Dropbox, Google Drive, etc to me on our Forums and I will try to recreate the crash on our end.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The error log is basically saying that one of your blueprints is returning a null reference. We tried to locate the blueprint in question, unfortunately the project is too complex for us to track down without any indication on where it may be.

more ▼

answered Dec 27 '16 at 09:36 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question