x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.14 Cannot open project anymore.

I added a C++ class to my Blueprint project and then the nightmares began. I am using VS Studio Enterprise 2015 update 3 & Windows 7 64.

Now it won't even open the project because it says "Missing Project Modules" - "The following modules are missing or built with a different engine version: Would you like to rebuild them now?"

If you say No, it just shuts down, if you say Yes, it shows "Error - Project could not be compiled. Try rebuilding from source manually."

and then shuts down.

Product Version: UE 4.14
Tags:
more ▼

asked Dec 20 '16 at 01:10 PM in Using UE4

avatar image

Justice777
8 3 4

avatar image Holybreath Dec 20 '16 at 03:21 PM

Right click on the .uproject select, Generate visual studio files , then open visual studio, and if it still has problem with windows.h, then i don't know. best of luck.

avatar image Justice777 Dec 20 '16 at 03:26 PM

Tried that, doesn't work. Says "This project does not have any source code. You need to add C++ source files to the project from the Editor before you can generate project files."

Catch 22: Can't load the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Justice777

My C++ code had some problems and was stopping the editor from launching my project. I thought that if the custom C++ code has bugs, then UE4 will not show my C++ classes in the Editor, or not compile the c++ classes at all, but in Unreal's case, the editor will not launch the project at all if the C++ code is buggy. This is one of the very scary quirks of UE. I can suggest a temporary workaround and it worked for me. See if this works for you.

Here is the temporary workaround:

  1. Save a copy of your YourProject.uproject file somewhere safe before proceeding.

  2. In the YourProject.uproject config file, look for the section named 'Modules'. Here is the pic of a sample .uprojectalt text

  3. Under the 'Modules' section, remove any mention of your C++ project from the "Modules" section. Here is the pc showing your c++ project removed from the Modules section: alt text

  4. Move your c++ project folder from under Sources folder to some other folder outside your UE project.

  5. Now try starting your project.

    Since your C++ project references have been removed from YourProject.uproject, UE4 will not try building your C++ project and will launch your project without your c++ classes.

This works for me. However, please note that I did not have much code and it was easy for me create a new c++ class from the UE4 editor and proceed with the compilation. The main problem is figuring out the dependencies.

Let me know if this helps. d0d0

more ▼

answered Dec 20 '16 at 06:54 PM

avatar image

d0d0
466 15 7 14

avatar image Justice777 Dec 20 '16 at 07:38 PM

Thanks. Well, that solved the one problem of not being able to open the editor but I still cannot compile the code.

avatar image Justice777 Dec 20 '16 at 07:42 PM

It's the "fatal error RC1015: cannot open include file 'windows.h'" that many people have talked about but none of their solutions have worked for me.

avatar image d0d0 Dec 20 '16 at 08:52 PM

Awesome.

Now, to solve your other problem, you need to provide sufficient info about your project, about your targets and attach the entire error message.

Also what have you done about getting UE to recognize windows.h so far ?

Thanks

avatar image Justice777 Dec 20 '16 at 11:35 PM

Not sure what other information you would be looking for. I am only targeting Windows Desktop right now.

I've tried the VC++ inherit paths "solution" and I've tried manually putting in the Windows 7 SDK path. I've also reinstalled that SDK.

I put the compiler error message two comments back.

avatar image d0d0 Dec 21 '16 at 12:43 AM

I want to know about the following: 1) Your build.cs files for your project, this is where you mention your dependencies. 2) Your entire build error log, whatever you mentioned is insufficient.

When I am building for a specific platform like windows, I make sure that the windows specific includes are mentioned between PLATFORM_WINDOWS like this: #if PLATFORM_WINDOWS #include "Windows/WindowsSystemIncludes.h" #endif

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You probably need to install the Windows SDK via the Visual Studio Installer.

I believe you need the Windows 8.1 SDK with VS2015.

Windows.h should then be in a path similar to

C:\Program Files (x86)\Windows Kits\8.1\Include\um

Hope that at least gets you on the right path.

more ▼

answered Dec 20 '16 at 03:28 PM

avatar image

Fijit
46 2 4 6

avatar image Justice777 Dec 20 '16 at 03:41 PM

Nope, have that installed. Visual Studio installs the SDK as part of it's install.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found a solution:

  1. Check if you have Visual Studio installed properly;

  2. Install "Windows SDK 8.1" or later.

Ta da! It worked for me!

more ▼

answered Aug 14 '17 at 01:04 PM

avatar image

March3wQa
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question