x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Imported FBX files are 100 times too large

As of at least 4.14.1, all FBX files imported into UE4 are 100 times too large when "Convert Scene Unit" is enabled. Unit settings when exporting the mesh has no impact, and neither does editing UnitScaleFactor inside the FBX file.

This is not a big problem with skeletal meshes/animations, where you can simply uncheck the box, but all camera animations imported into Sequencer are scaled up as well with no way to disable it.

This means a camera movement of 9 units (cm) becomes 900 units in Unreal, and I don't see a way to scale Sequencer animations. This behavior is not present in 4.11.

Steps to reproduce:

  1. Download this FBX file of a camera animation exported from After Effects.

  2. Create a new Sequencer animation. Create a camera, and highlight the Transform track for the camera.

  3. Go to General Options -> Import, and load the FBX file.

  4. In 3ds Max, the X axis is at about 9.6 units in frame 1. In Unreal, it's at 960 units.

Product Version: UE 4.14
Tags:
camera_test.zip (16.7 kB)
more ▼

asked Dec 21 '16 at 05:14 AM in Using UE4

avatar image

Loginer
8 1 3 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Check your 3ds Max units, as well as the FBX units export options. 3DS Max has a display units and a system units to work with. For ue4, change both of them to cm.

Customize > UnitsSet up. alt text

And then check the System Unit Setup. alt text

Finally, when you export your FBX out, check what units you have set up for it. alt text

more ▼

answered Dec 21 '16 at 02:57 PM

avatar image

Motanum
620 58 63 306

avatar image Loginer Dec 22 '16 at 02:08 AM

Thanks, I was being stupid. By changing the system unit, I was able to import the camera movement and re-export it in centimetres.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question