x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to update Blueprint project from 4.0.2 to 4.1 or 4.2

I have a fairly old Content-Only (Blueprint-based gameplay) project that I can run successfully in 4.0.2, but attempts to open it in 4.1 are mostly broken and unstable, while opening the project in 4.2 completely fails.

I spent some time in 4.1 opening, compiling and saving out all my blueprints, but the game remains unstable and I'm unable to work in it at all.

  1. simply fails to load any of my blueprints. Even right-clicking on them in the content browser crashes the editor.

I know this isn't a terribly detailed report, but I don't have much solid to report. I've submitted about 50 crash reports today between the two versions. I've attached the logs and .dmp files from 4.2. I can't include 4.1 files as I've reverted my project in perforce after getting frustrated and wanting to make some progress on the design side.

Is there some way of seeing what's wrong with the blueprints without having to simply start again from scratch or stay with 4.0.2 for the life of the project?link text

Product Version: Not Selected
Tags:
logs_137328672.zip (90.4 kB)
more ▼

asked Jun 08 '14 at 10:59 PM in Bug Reports

avatar image

Tom Shannon
99 8 10 18

avatar image tomofnz Jun 09 '14 at 01:53 AM

Are you using migrate? It seems safer to use that than to just copy content from one place to another.

avatar image Tom Shannon Jun 09 '14 at 02:13 AM

That's a good suggestion. I'll give it a try and see what comes of it!

avatar image Tom Shannon Jun 09 '14 at 02:19 AM

Okay, gave it a try and it's still crashing as soon as I touch any of my blueprints.

Callstack: !Id:15bd1610c47e3426c44338b2f6af2a36

We apologize for the inconvenience. Please send this crash report to help improve our software.

avatar image tomofnz Jun 09 '14 at 05:04 AM

It happened to me too. I gave up and started over. I didn't get a reply about it in my posts. I haven't yet run into the project doesn't open problem with my current v4.2 public release project, but I wonder if it is just a matter of time. I started using 'AlienBrain Essentials for Artists' so I can rollback at such a time I cause my blueprints to stop working ... hopefully that helps.

avatar image robbiecooper Jun 09 '14 at 07:06 AM

Out of curiosity, I tried to load a 4.0.2 project in 4.2. I got a message asking if I wanted to open a copy, because its safer. Crashed the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

So, while not quite an answer to the issue, I did manage to resolve most of it and found a pattern of instability. Here's what I did to get my project up and running in 4.2:

1) Created the project copy (I'm running Perforce, so this wasn't totally needed, but I wanted to ensure I was working with a fully fresh project folder.)

2) Moved the Blueprints folder out of the Content Folder (ALL my logic blueprints exist in here: pawn, gametypes, powerups, weapons, etc.) to a temp folder outside the project.

3) Added my blueprints back one by one, starting with the most important (Pawn, gametype, HUD, etc.) until I ran into crashes. I payed close attention to the output log and saw where my errors were coming from. If An added blueprint made the game crash, I'd move it back to the temporary folder, and continue.

4) Opened each Blueprint, compiled and saved. Those that referenced enums needed the switch on enum nodes to be refreshed to display the correct enum string.

5)Continued adding, compiling, adding compiling, testing until everything seemed to work again!

Eventually, I was left with all my core gameplay, but the issue seems to be : Derived Blueprints with custom blueprint scripting. Derived blueprints that were data-only (Only changing default values) seemed to do just fine. and/or Redirectors and old, unused classes that had been cluttering up my project may have been causing issues.

While this isn't a solution, it did get my old 4.0.2 game up and running in 4.2. YMMV

--Tom

more ▼

answered Jun 09 '14 at 02:52 PM

avatar image

Tom Shannon
99 8 10 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Oops, spoke too soon. The editor disappeared for a while and then came back again. The 4.0.2 project appears to work fine. Try something- update your .uproject files by right clicking on them, selecting the 4.2 engine and reloading the VS files. Then in VS, hit "rebuild".

more ▼

answered Jun 09 '14 at 07:11 AM

avatar image

robbiecooper
766 79 60 235

avatar image Tom Shannon Jun 09 '14 at 01:15 PM

Thanks for the tip, however it's a content-only project and doesn't have any source to compile. I'm wondering if that's part of the issue as it doesn't have a chance to fix linking errors is VS or something (Way above my paygrade)?

avatar image robbiecooper Jun 09 '14 at 01:19 PM

Sorry, you did say that in your post. Has it ever given you the option to open a copy of the project?

avatar image robbiecooper Jun 09 '14 at 01:24 PM

As in, not the original project, a copy that it makes for you to prevent problems? If it hasnt, I'd be tempted to try compiling 4.2 from source.

avatar image Tom Shannon Jun 09 '14 at 01:28 PM

It did, and I did. It's really just a copy of the project folder, nothing too fancy.

avatar image robbiecooper Jun 09 '14 at 01:45 PM

I guess the good news is that means the project is still intact. I'd probably still switch to the github version. If you just follow the instructions on the github page, step by step, it isnt going to give you any major headaches...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question