x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Blueprint nativization fails

I was trying to see if BP nativization would give my Gear VR app a performance boost. I ticked that option in the project settings, ticked Full rebuild in packaging, deployed to Android ETC2 and when I loaded my UE4 app on the device (Galaxy S6 with Gear VR) the only thing I saw was a sky sphere. Nothing else was working.

If someone from Epic wants to have my project for testing, I can share it privately.

Thanks beforehand

Product Version: UE 4.14
Tags:
more ▼

asked Dec 23 '16 at 10:30 PM in Bug Reports

avatar image

motorsep
373 39 48 66

avatar image Rudy Q ♦♦ STAFF Dec 27 '16 at 06:38 PM

Hello motorsep,

Before grabbing a copy of your project, is it possible for you to reproduce this issue in a clean project? If not, feel free to send your project to me in a private message and I will take a closer look. Please be sure to provide a list of steps along with either answer so that I can reproduce this issue on our end.

avatar image Rudy Q ♦♦ STAFF Dec 30 '16 at 06:48 PM

Hello motorsep,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

avatar image motorsep Dec 30 '16 at 06:57 PM

This a bit ridiculous. This week is a holiday week. I am afk and you replied to me only 3 days ago. To be fair, some of the bug reports here remain unanswered for years.

I also provided you with my project for another bug report (capsule trace issue), and that's the same project that fails nativization. It could have been already confirmed without my participation :/

Please unmark this as resolved and I'll test the issue in the clean project next week (and by clean I mean migrating BPs into FPS Template; it still doesn't make any sense to me why test on a clean project when I migrate BPs anyway).

avatar image Rudy Q ♦♦ STAFF Dec 30 '16 at 07:13 PM

The last response was for tracking purposes and to inform others who may come across this issue that the latest status for this issue is that we are still seeking additional information.

I was not aware that it was the same project or that the version of the project that we currently have would exhibit the issue mentioned.

As for being asked to reproduce an issue in a clean project, this is supposed to be without any previous content when possible. If it is not possible, then it serves the purpose of helping eliminate any extraneous variables that don't have anything to do with the issue. I hope that this information helps.

avatar image motorsep Dec 30 '16 at 07:17 PM

So, for clean project I don't need to recreate my BPs from scratch? Should I simply try nativizing FPS Template as is ? I assume in that case nativization would work because that's what has been tested at Epic internally.

avatar image motorsep Jan 03 '17 at 05:51 AM

Tried nativization with FPS Template - seems to be working fine (to be fair, there is not whole a lot of BP script in FPS Template, not even basic level BP).

Basically I created a new project using FPS Template, set up Project Settings exact same way as my project (the one I sent you for capsule trace issue) and deployed it without and with nativization option on.

Worth mentioning that I have level BPs and streaming levels in my project (not the clean test project). However, besides levels not streaming, basic stuff such as back button on Gear VR isn't working either when deployed with nativization option in my project.

avatar image Rudy Q ♦♦ STAFF Jan 04 '17 at 08:42 PM

I ran a few tests with the project provided. Could you run a quick test? Could you unhook the construction script in the blueprint "BP_Door_base" and try to package again and let me know if you are successful?

avatar image motorsep Jan 05 '17 at 02:38 AM

Alright, totally weird stuff happened - I wanted to build again with nativization on, just to make sure I am not missing anything. I could not build it - was getting Unknown Error: http://pastebin.com/sDH5jf4b

After I unhooked Construction script, I was able to build with nativization and the game worked on Gear VR.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Thank you for running that test. I was able to narrow down the cause of the failure. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: https://issues.unrealengine.com/issue/UE-40237

Additional info: If you check your output log you will see an error similar to the one provided below. This is caused by setting a variable to itself in the construction script

Example:

alt text

Error: UATHelper: Packaging (Android (All)): UnrealBuildTool: C:/Users/YourUserName/Documents/Unreal Projects/YourProjectName/Intermediate/Android/NativizedAssets/Source/NativizedAssets/Private/NativeError__pf3688439234.cpp(237,20) : error: assigning field to itself [-Werror,-Wself-assign-field]

Make it a great day

more ▼

answered Jan 05 '17 at 04:33 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image motorsep Jan 05 '17 at 04:39 PM

Just noticed that issue has affected version set to 4.14.1, but it also affects 4.14.2 (if that even matters at this point). Just fyi.

avatar image motorsep Jan 11 '17 at 02:17 PM

Could you please clarify why is this marked as "Won't fix" ?

avatar image Rudy Q ♦♦ STAFF Jan 11 '17 at 02:47 PM

It appears that this is a restriction when compiling for Android. However, this setup could be changed to have a hard coded default value seeing as how this takes place in the construction script.

avatar image motorsep Jan 11 '17 at 03:11 PM

The value isn't hardcoded. This system is designed to be modular - drop BP actor into the scene, adjust parameters in the Details panel and you have a different door. This way level designer doesn't have to touch BP at all.

Is there a workaround? (like having an intermediate var first using var from the Detail panel and then set that var using intermediate var)

avatar image Rudy Q ♦♦ STAFF Jan 11 '17 at 04:15 PM

There is not a reason to set the variables to themselves in the construction script (out side of setting a default value). I have provided an example below of how you can modify a blueprint through the details panel without having to set a variable to itself. I hope that this information helps.

Example:

Here I have created a variable name "Scale" I will be using this to dynamically change the scale of a cube by altering this variable via the details panel.

alt text

Here I have set the variable to be editable. This will allow me access to the variable in the details panel. I have also given it a default value of (1,1,1).

alt text

In this image I have highlighted my new "Scale" variable as it appears in the details panel. It is currently set to a scale of (1,1,1) as indicated by the default value that I have set.

alt text

In my final step I simply type 2 into the Z value and hit enter. This immediately updates the scale of the cube.

alt text

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question