x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem importing apex cloth

Hi everyone!

I'm having some weird problem importing apex cloth from maya (2016) into the engine after the switch to physx 3.4, I updated my plug-in and reskinned the cloth mesh to make sure no vertices had more than 4 influencing bones then I painted the cloth, ran the simulation and exported the cloth same as always without any errors, butthis time when I bring the cloth into UE4 the "apex details" panel doesen't show any details and I cannot apply the cloth to the proper material.

I also exported the whole mesh again just to be sure bit still having the same issue

here's a screenshot if the panel I mentioned alt text

the thing is I had already done this without any problem right when 1.14 came out

Product Version: UE 4.14
Tags:
more ▼

asked Dec 24 '16 at 06:29 AM in Bug Reports

avatar image

MGGeymonat
31 3 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Mordragos,

APEX Details is only a panel that shows details, but doesn't let you edit them. Physics Properties are all of the things you can change.

To apply cloth to a material, you must go into the LOD section to change the cloth.

alt text

-Matt W.

more ▼

answered Dec 28 '16 at 09:41 PM

avatar image MGGeymonat Dec 28 '16 at 10:13 PM

Hey Matt! Thanks for your response, though my problem is the cloth doesn't seem to be importing properly, because I can't apply it to any material in the LOD section, the thing is the engine doesn't show any errors and neither does Maya when I validate the scene =/

alt text

I'm starting to think It may have something to do with the cloth mesh's skinning and the new cloth skinning changes in 4.14 but I don't really know.

avatar image Matt.Williams Dec 29 '16 at 08:29 PM

Can you do me a favor and rename your .apx file to something other than just "cloth"? I'm thinking we might have a naming exception for that.

I'm noticing that the Clothing options only ever appear after you add an APEX file, so it seems that it isn't recognizing "cloth.apx".

If that doesn't work, can you migrate your content to a standalone project and send it to me? You can PM me a download link on the forums.

-Matt W.

avatar image MGGeymonat Dec 29 '16 at 11:04 PM

I tried changing the name but I still get the same issue, =/

I sent you the project files in a pm, thanks for taking the time to look into this!

avatar image Matt.Williams Dec 30 '16 at 09:31 PM

Hey Mordragos,

I think something is probably wrong with your apx files. I took your fbx and recreated all the PhysX Cloth in Maya, then exported the mesh and apx. When I brought it into UE4, the second I added the Clothing File, the Clothing options appeared.

I would suggest recreating the clothing files and particularly making different material ID's for each cloth (i.e. separate material IDs for the cape, kilt, etc).

Try this out to see if there is anything that you missed: https://www.youtube.com/watch?v=uTOELBNBt04

-Matt W.

avatar image MGGeymonat Dec 30 '16 at 11:18 PM

Thanks, I'll try separating and remaking the cloth files. would you mind telling me which version of maya and the physx plug in are you using though? just to be sure I'm not using a wrong version

avatar image Matt.Williams Jan 03 '17 at 04:36 PM

Hey Mordragos,

I'm in Maya 2016 Extension 1 + SP6 and the plugin is PhysX SDK Version 3.3.4 and Apex SDK Version 1.3.4(Overall plugin version is 3.4.11121.04262).

-Matt W.

avatar image MGGeymonat Jan 05 '17 at 12:23 AM

Hey Matt!

thanks for the info, I think I got it fixed, after downgrading to the plug in overall version 10202.23462 then going back to 11121.04262 and telling it not to reset the settings, so I guess it was a plug in thing!

Though now I have a new issue, after importing the cloth asset some parts of the cloth seem to be flipping , kin of as if they were simulating in in different axis

withouth cloth
alt text

with cloth

alt text

avatar image Matt.Williams Jan 09 '17 at 08:45 PM

Can you show me your cloth painting weights in Maya? That's usually the issue when I see this type of thing.

avatar image MGGeymonat Jan 09 '17 at 09:15 PM

Sure thing, here they are. alt text

alt text

avatar image Matt.Williams Jan 13 '17 at 04:24 PM

Hey Mordragos,

I've been experimenting more since yesterday and see a drastic difference between the cloth results in 4.13 and 4.14 with the same file (I exported the cape by itself for testing). I've contacted one of our engineers for some guidance on this, but I suspect it may be related to the physx 3.4 update present in 4.14.

-Matt W.

avatar image Matt.Williams Jan 13 '17 at 06:36 PM

Hey Mordragos,

We did some talking and I realized that I was being a little thick when searching the plugins. I got 3.3.4 thinking it was the latest on accident. You SHOULD be using the plugin you had originally(3.4), but the issue you had noticed (where the Clothing setting wouldn't appear after importing the apx) is truly a bug. Since we are using 3.4 in UE4, files created with 3.3.4 won't work correctly.

This was a mixup on my end and I've entered UE-40614.

-Matt W.

avatar image MGGeymonat Jan 13 '17 at 09:32 PM

Great! I will upgrade to the 3.4 plug in and wait for the fix, this really takes a weight off my back.

Again, thank you for your time and looking into this whole thing!

avatar image Matt.Williams Jan 16 '17 at 04:18 PM

Well, new developments! So the reason it wasn't importing correctly is because the 3.4 plugin exports no simulated verts if you leave a percentage of your verts at a cloth weight of 0. We only found this out after we flooded the meshes with a value of 120 (it exported and imported successfully...looked like crap with 120 everywhere, but it worked). We then worked our way backward. I'd suggest simply flooding your mesh with a value of 0.001 before painting for the time being. We're going to poke Nvidia about this, but it wouldn't hurt for you to do the same.

avatar image AlsonEntuna Jan 23 '17 at 04:30 AM

I tried painting my skinweights with a value of 0.001 and when I exported the apex file and the mesh it did not work for me :(

avatar image AlsonEntuna Jan 23 '17 at 04:46 AM

alt text

01.png (286.0 kB)
avatar image AlsonEntuna Jan 23 '17 at 06:50 AM

already got it working with the solution that you've posted. I hope that this bug will be resolved in the next version of unreal. Thanks!

avatar image AlsonEntuna Jan 23 '17 at 03:49 AM

I'm also having this problem because I was using 3.3.4 version of the PhysX plugin but when I upgraded it suddenly doesn't give me any options to add apex clothing inside the engine

avatar image MGGeymonat Jan 23 '17 at 04:16 AM

As Matt said the best way to fix it right now is to use the latest (3.4) apex plug in and to flood your cloth mesh with 0.001 weight before painting to ensure all your vertex are exported in the apx file (so UE4 can actually read it).

I'm currently testing it and it seem to work though I admit its quiet a hassle specially the old collision ragdoll now pushes the .001 vertices =/, hopefully nvidia will change the way the plug-in exports the apx on a future release.

avatar image AlsonEntuna Jan 23 '17 at 04:25 AM

I'm trying it right now. :( PhysX was working fine until the update of the new one.

avatar image AlsonEntuna Jan 23 '17 at 04:33 AM

It's not working for me :( i tried painting it to a skin weight of 0.001 and when I exported the mesh and apex file unreal still doesn't read it

avatar image AlsonEntuna Jan 23 '17 at 04:35 AM

alt text

01.png (286.0 kB)
avatar image MGGeymonat Jan 23 '17 at 04:45 AM

you need to flood the cloth "max distance" weight with .001 instead of the skin =P

avatar image AlsonEntuna Jan 23 '17 at 04:48 AM

oh god hahaha I really though I should be flooding the skin weights first ugh ahahahah

avatar image AlsonEntuna Jan 23 '17 at 06:50 AM

already got it working! thanks :D I really do hope that this will get fixed in the next version of unreal.

avatar image Matt.Williams Jan 23 '17 at 03:31 PM

Hi AlsoEntuna,

Thanks for following up on the issue and I'm glad you have it resolved. There's no way for us to fix this since it is an issue with the PhysX 3.4 plugin that Nvidia makes. When you export with a lot of 0 painted cloth weights, the .apx exports no simulated data.

-Matt W.

avatar image melmaster Jan 23 '17 at 06:15 PM

Hey, sorry to jump on such a long thread, but I'm having a similar problem and even upon setting my max distance to .001 the cloth is still breaking when i apply it. alt text Any ideas?

brokencloth.png (152.4 kB)
avatar image Matt.Williams Feb 01 '17 at 09:37 PM

Try flooding with 1 or a higher fraction. I chose .001 as it was such a small number, but it might just be too small.

Please report all of this to Nvidia or chime in on any existing threads on their website. This is an NVIDIA plugin, not one of ours.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I got here looking for a solution to my apex/badnormals problem. But I have a workaround to your problem:

in resume you must export first from ClothinToolProfile.exe, import on unreal, export again from 3ds max, and click refresh on unreal.

here the detailed steps:

-run ClothinToolProfile.exe -import cloth mesh -switch to max distance -flood with 0,10 -switch to "Single Layered Cloth" tab and "save asset"

-open unreal and import the new .apx file to your cloth mesh (the cloth will fall)

-open 3ds max, select the cloth, export OVERWRITING the apx you saved before from ClothinToolProfile

-open unreal, click the refresh button again to reload the apex file. done.

after you have the cloth working on unreal, you don't have to do all this again, just exporting from max will do the job.

if everything worked fine, now you just have my "bad normals" problem apex is kind of bad right? hope someday the awesome guys at epic will come with a new cloth system =)

hope this helps =)

more ▼

answered Jan 29 '17 at 06:10 AM

avatar image

gustavorios2
218 18 26 36

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question