x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.14 "Enable HMD" VR not working on "Launch Game" command

Hey guys,

To test the game, I usually close the editor, then "right click" on my game project file and choose "launch game" to test the in-game FPS without the editor load. Ever since the 4.14 update I get a black screen when I switch from desktop to VR HMD with the command that I registered in the Main Character Blueprint (see below).

I have the Oculus CV1 and a GTX 970, I installed all the latest drivers from Nvidia and Oculus.The problem persists on both the CV1 and the DK2.

The forward shader option in the project settings is enabled, but it happens even when this option is disabled.

To check the issue in a new project do the following steps:

  • Launch the engine and create a VR or third person template with starter content

  • Open the Character Blueprint Add an "input -" node and connect it to a flip flop (see below).

  • Create two nodes with "enable HMD", one of them enabled the other disabled and connect them to the flip flop

  • Build, save and Close the editor

  • Right click on the project file ---> launch game ---->wait for it to load

  • click on the button that you registered as "input -" node to switch to HMD

  • Observe the screen going black and no image on your HMD

  • Commands such as "stereo on" or "Enable HMD" in the console won't work either

The internal editor "play in VR" mode works flawlessly, but I wish to test it without the editor load, so I can get an accurate estimate of the FPS and prevent motion sickness from constantly testing the world in VR.

Does anybody else experience a similar problem? I would really like to stay on 4.14 because the forward shader is a great asset of this engine version.

alt text

Product Version: UE 4.14
Tags:
hmdblack.jpg (211.1 kB)
more ▼

asked Dec 25 '16 at 01:21 PM in Using UE4

avatar image

jalte
13 4 5 9

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I'm not fully sure what the problem is for you but this might help. Either way, others with similar problems may be happy of this answer/redirection, cause I got to this question by trying to solve my problem. https://answers.unrealengine.com/questions/569987/toggle-vrpc-mode.html#answer-572543

more ▼

answered Mar 07 '17 at 01:06 PM

avatar image

Devgroup
233 7 5 14

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question