x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ProjectLauncher build error: AutomationTool.AutomationException: Failed to find command Release

Hi all,

I'm currently experimenting with the ProjectLauncher and figuring out how to use the release building works using versioning as well as the patching and DLC implementation. However I seem to be running into issues left and right. The workflow I'm using is the one described on the following page: https://docs.unrealengine.com/latest/INT/Engine/Deployment/Releasing/index.html

As I'm just experimenting with the feature I'm working in a completely new blank code project running on 4.14.1 downloaded via the launcher. I saved the startscene as a new MainScene and made that my main startup scene.

Following the example and attempting to build the project as is with only the main scene included I ran into a first error complaining about "Only staged builds can be paked". Adding the the -stage command resolved this and then everything cooked, packages and so forth. The releases folder is created and in the saved folder I can find the stage builds.

However I do get an error message during the build process: "Program.Main:ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Failed to find command Release". I'm not sure if that has any implications as I did end up with an executable but still it's an error. Any ideas what I might be missing here?

Click here for the build log

And here are my launcher settings, based on the example page: alt text alt text

Thanks for the help and happy holidays!

Product Version: UE 4.14
Tags:
more ▼

asked Dec 26 '16 at 02:18 PM in Packaging & Deployment

avatar image

Brechtos
8 2 3 5

avatar image Dex82 Jan 05 '19 at 05:07 PM

But if you have no number in versions u cant create a patch ?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

try.. take out "1" in "Release version this is based on" section. That section is for patching. Don't add -stage for release one.

more ▼

answered Jan 02 '17 at 07:02 AM

avatar image

SuKim
41 2 4 6

avatar image Brechtos Jan 04 '17 at 05:04 PM

Aha ! Thanks :)

(comments are locked)
10|2000 characters needed characters left

I have the same issue, it is caused by Name of the new release to create. You choose "Main Release" as a name, there should not be space in it.

more ▼

answered Jun 19 '17 at 08:31 AM

avatar image

rz1974
136 10 14 21

avatar image BoteRock Jul 27 '17 at 02:04 PM

This worked for me. Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question