x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Start with tick enabled not working for components?

I made a simple Actor Component and unchecked the "Start with tick enabled". Yet when I wire a "Event Tick" I see it still executing. It's possible to stop tick with explicitly using "Set Component Tick Enabled", but not within the "Begin Play" event.

I want the component to be ticking only when mouse button is held down, and it works like that. It's a small optimization as I want to avoid checking if button was pressed in a tick event.

alt text

Product Version: UE 4.14
Tags:
more ▼

asked Dec 31 '16 at 09:59 AM in Blueprint Scripting

avatar image

Daniel K.
160 9 21 23

avatar image Daniel K. Jan 10 '17 at 02:47 PM

Sorry, but ... bump?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Daniel,

Did you also disable Start with Tick Enabled in the blueprint actor Class Defaults? Because if it is still enabled, you will see the ticking from the actor itself.

I set up something similar here and it seem to be working on my end. Please let me know if I misunderstood exactly what you are trying to do though.

alt text

alt text

Cheers, TJ

more ▼

answered Jan 10 '17 at 05:40 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image Daniel K. Jan 10 '17 at 06:36 PM

Well I suppose that could work like that, but it doesn't make a sense really. Why would there be a separate "Start with Tick enabled" for components if only the setting for actor would matter?

avatar image TJ V ♦♦ STAFF Jan 10 '17 at 06:53 PM

I'm sorry, I thought from your description that you had a tick in both the component and the actor.

When just using the tick in the component, the setup I provided above works correctly on my end. If Start with Tick Enabled is disabled in the Details panel, the tick will not start until I enable it in the component blueprint.

If you are still getting the issue, could you try reproducing it in a new project just to rule out any per project issues?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question