x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaged Game Ignoring "Default GameMode" Setting

I've set up a custom GameMode class for my game called ScreenGameMode that uses a custom PlayerController class, and I have it set in "Project Settings -> Maps & Modes" as "Default Game Mode." When I play in the editor it uses ScreenGameMode and my custom PlayerController correctly, but when I package a build, it uses the base GameMode instead and the base PlayerController class. Any ideas why this might be?

There's no "Game Mode Override" set in "World Settings." This is the first time I've tried to make a packaged build of this project.

I have upgrade this project a few times from older versions of UE4; I saw this question that sounds like possibly the same issue. Maybe I need to recreate my GameMode blueprints? Ugh! https://answers.unrealengine.com/questions/253263/wrong-playercontroller-in-cookedpackaged-version.html

Product Version: UE 4.12
Tags:
more ▼

asked Dec 31 '16 at 11:44 PM in Packaging & Deployment

avatar image

clt2488
270 17 35 37

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Solved it. It looks like the issue is that if you define a custom GameMode in your settings, and then you move and/or rename that GameMode blueprint, the editor knows where to find the blueprint still but the Config\DefaultEngine.ini config file still points to the old path, which causes packaged builds to fail to load the custom GameMode and fall back on the base class GameMode. The fix was to simply go into "Project Settings -> Maps & Modes", change the "Default Game Mode" to GameMode and then back to my custom ScreenGameMode class. I probably could have also just updated DefaultEngine.ini manually to point it to the new location.

more ▼

answered Jan 01 '17 at 12:01 AM

avatar image

clt2488
270 17 35 37

avatar image Imagine-Games Sep 20 '18 at 05:52 PM

yup, same issue here, just browsed to the defaultengine.ini and confirmed that it is linking to the old file location... either updating that or in the editor fixes it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question