x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

(Solved) New Project C++ Compile Failed

Unreal Engine 4.10

Hello,

I am having a issue with my C++ project not able to compile the code when I have created a New Project. I have no idea on what it is causing this to happen and I do not understand this error.

alt text

When I Open with Visual Studio and Build Solution, I seem to get 5 errors as well.

alt text

Can anyone please help me understand the issue on why it is doing this?

This never happen to my old PC and I have no idea why it is doing to my new PC. Also, show some screenshots as that would be helpful for me to see the clear picture.

Thanks,

Kyle

Product Version: UE older version
Tags:
capture.jpg (118.2 kB)
capture 2.jpg (112.5 kB)
more ▼

asked Jan 01 '17 at 11:41 PM in Installation & Setup

avatar image

Kyle Carpio
124 13 17 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Kyle,

If you're using UE 4.10 or later, it will require Visual Studio 2015. Additionally, if you are already using 2015 and your version of Visual Studio is running Update 3, you will need to update to 4.11 or later. Update 3 introduced an error that was fixed later. If you're using 4.11, you will need to manually add the fix which can be found here: https://forums.unrealengine.com/showthread.php?3147-Current-Available-Quick-Fix-Solutions . Versions after 4.11 have this fix already included, so if you are using 4.12 or later, you should be able to create code projects without this error. Let us know if this is not the case for what your'e experiencing.

Cheers

Doug Wilson

more ▼

answered Jan 03 '17 at 04:17 PM

avatar image Kyle Carpio Jan 03 '17 at 04:31 PM

Hello Doug,

I had tried with 4.11 and had the issue but I never try to fix this link you have sent me.

I tried with 4.13 now and it worked fine creating a new C++ project, but there is another issue with Visual Studio not working with the code even I had used this code before and worked last year.

alt text

Here is the problem. This has happen to a lot of people from a code that had work before on this video:

https://www.youtube.com/watch?v=BY6hOyb16j8&list=PLZlv_N0_O1gb5sdygbSiEU7hb0eomNLdq∈dex=5

capture 3.jpg (244.8 kB)
avatar image Doug E ♦♦ STAFF Jan 03 '17 at 04:48 PM

The "OtherCopilationError(5)" message means that the error that occurred isn't something that has an error code related to it. You can check the Output log for more information in the majority of situations that involve this message.

avatar image Kyle Carpio Jan 03 '17 at 04:57 PM

alt text

capture 4.jpg (118.2 kB)
avatar image Kyle Carpio Jan 03 '17 at 05:04 PM

Hold on... I just realised the Catergory well spelt wrong... it suppose to be Category.

I compile it in Unreal Engine and it succeeded but when I clean solution, I get a lot of errors.

Strange.

avatar image Kyle Carpio Jan 03 '17 at 05:40 PM

Thanks for the help, seem like I will have to be using Unreal Engine 4.13 for now on.

I hope for the best that nothing goes wrong from it or changes to the engine itself on how they are place.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

how i fixed it is by using the git hub version(possibly use the higher versions) . if u have the internet facility use it and report back if the error is still existent or wait for a fix

more ▼

answered Jan 02 '17 at 02:29 AM

avatar image

A GUPTA
4.1k 103 46 618

avatar image Kyle Carpio Jan 02 '17 at 02:51 AM

Oh, I have no idea what are them to be honest.

Can you send me a link or screenshot this?

avatar image A GUPTA Jan 02 '17 at 05:40 AM

Well the engine source code is at the github https://www.unrealengine.com/ue4-on-github This is the page

avatar image Kyle Carpio Jan 02 '17 at 03:28 PM

How do I use this?

avatar image A GUPTA Jan 02 '17 at 06:12 PM

u need to download it . first create an acccount in github then link with ue4 then download it rest of the steps are given.

avatar image Kyle Carpio Jan 02 '17 at 06:17 PM

The page download is not found for some reason.

Sorry for being an idiot, I am unsure on how to use these type of websites.

avatar image A GUPTA Jan 03 '17 at 01:36 AM

That is not an issue . Whatever be the query please do post it . Here is a vid https://www.youtube.com/watch?v=T7tDaoTA8WA

avatar image Kyle Carpio Jan 03 '17 at 02:29 PM

Oh I see it's just a way to get the old version back before the update of Visual Studio. Seems confusing for me to know which one to download there.

Well, I'm only using Unreal Engine 4.10 and I just downloaded Unreal Engine 4.13 which the code compile seem to work. I hope the code and blueprint is not much of a big difference. I don't like how Unreal Engine 4 layout changes a lot including when I watch old engines tutorials.

Thanks for helping me.

avatar image Kyle Carpio Jan 03 '17 at 03:59 PM

Hey it is Kyle again.

Turns out, the Compiler works when you make a new project but when you Compile it with Visual Studio in Unreal Engine or Build Solution. It shows the error issue with Visual Studio and not the code itself.

I do hope they will fix this problem.

avatar image A GUPTA Jan 04 '17 at 01:43 AM

U still facing trouble or are U ready to go on ???

avatar image Kyle Carpio Jan 04 '17 at 03:14 PM

Hello again,

The issue has been resolved.

avatar image A GUPTA Jan 05 '17 at 11:43 AM

great now surely get started

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question