x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Unable to render Custom Depth with translucent material applied

I'm unable to see the mesh rendered into Custom Depth while I have a translucent material applied. This does work with any opaque material.

Nasty workaround is to create a blueprint with second copy of mesh (gets works when animation gets involved) that is only drawn into custom depth and not main pass and has a simple opaque material applied.

Product Version: Not Selected
Tags:
more ▼

asked Jun 09 '14 at 07:21 PM in Rendering

avatar image

Tom Looman
444 34 87 55

avatar image thk123 Jun 23 '15 at 12:46 PM

Is this intended behaviour? It also stops the object showing up the scene depth texture, it would be nice if it could be toggled on a per object basis. This comment seems to suggest is intended behaviour but sadly doesn't elaborate on how to change it.

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

There is a property called "Allow Custom Depth Writes" within "Translucency". Set it to true and it will compile additional shaders to enable custom depth.

I hope this helps.

more ▼

answered Nov 21 '16 at 11:16 AM

avatar image

Bionic Ape
124 16 19 23

avatar image uNfree Oct 27 '17 at 09:21 AM

Thanks, that works for me.

avatar image Adder1812 Oct 02 '18 at 09:43 AM

Perfect!! Thanks!!

(comments are locked)
10|2000 characters needed characters left

You will need a separate mesh with an opaque material currently. You can set that copy to not render in main pass and to render only in custom depth.

more ▼

answered Mar 03 '16 at 10:39 PM

avatar image

RyanB STAFF
2k 56 24 118

(comments are locked)
10|2000 characters needed characters left

It has not been mentioned before, but I want to point out that you need to set the "Opacity Mask Clip Value" of the Material properties to something you can work with. For example. Currently in UE4 4.20, this value is set to 0.33. If you use the technique above with a translucent material set to 0.32 in opacity, the post processing material will not show.

In my case, i need to show only the outline of a completely transparent material, so I had to set this value to 0.0.

more ▼

answered Jan 31 '19 at 11:32 PM

avatar image

cesar_montero
56 1 6 8

(comments are locked)
10|2000 characters needed characters left

You will need a separate mesh with an opaque material currently. You can set that copy to not render in main pass and to render only in custom depth.

more ▼

answered Mar 03 '16 at 10:39 PM

avatar image

RyanB STAFF
2k 56 24 118

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question