x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

PlayButton not working?

I am using UE4 4.10.4, and whenever I use my "PlayButton" it removes all of the widgets, but it does not let me move, shoot, or anything else. Here are some screenshots.

https://gyazo.com/a25d0bcdf2b4521adcb224f5640192b1 https://gyazo.com/72e4cd5e1e6cde840e3ee9f52f2a03d6 https://gyazo.com/98507848239a205c366c152ea13dfd90 https://gyazo.com/52a8ced9ed92148eea33294506382d60 Before I hit play (Game already started for some reason..): https://gyazo.com/12fb41cd6ebad3f72275d0929af69b52 After I hit play (Game continues going and doesn't reset, I can also not move, shoot, or cannot see my crosshair I created or score or health, I can also not die.): https://gyazo.com/536341c0cc5216eba161761031c09a86 Could someone please explain my error to me? Thanks.

Product Version: UE older version
Tags:
more ▼

asked Jan 03 '17 at 06:33 PM in Blueprint Scripting

avatar image

Bhechmer
1 1 2 2

avatar image Mutivoda Sep 09 '18 at 05:14 PM

Does anyone knows how to fix my PLAY button, i am pressing it but nothing, like am pressing a picture, plas help???

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The answer to the problem was my GameMode settings. It was set to a different Default Pawn Class then mine. Thanks alot, Fryderider!

more ▼

answered Jan 04 '17 at 04:22 PM

avatar image

Bhechmer
1 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Bhechmer!

Try these nodes, SetInputModeGameOnly SetInputModeUIOnly

Use the SetInputModeGameOnly after you press the Play Button, and the SetInputModeUIOnly when you're heading back to the main menu.

Let me know if it doesn't work!

more ▼

answered Jan 03 '17 at 07:57 PM

avatar image

Fryderider
120 6 11 13

avatar image Bhechmer Jan 03 '17 at 08:09 PM

I tried this: https://gyazo.com/9ff195cfaa63929dbc6f24baf6adca1c and it is still not working

avatar image Fryderider Jan 03 '17 at 08:34 PM

Remove SetInputModeUIOnly after Remove From Parent.

avatar image Bhechmer Jan 03 '17 at 09:41 PM

It still does not show the crosshair, the health, the score, the ammo, or let you move.

avatar image Fryderider Jan 04 '17 at 10:10 AM

I don't see any screenshots of the PlayerHUD, so I don't know what's up with that. Could you try feeding GetPlayerController into the SetInputModeGameOnly Node?

Are you sure you're spawning correctly in the world? If you'd disconnect the CreateWidget node from the BeginPlay in your Level Blueprint temporarily, can you move around and see the PlayerHUD?

avatar image Bhechmer Jan 04 '17 at 03:32 PM

I just tried to thing in the level blueprint, and I still cannot play. Here is a screenshot of my PlayerHUD:https://gyazo.com/86631128acaf1d42024b0bb4accc13cd https://gyazo.com/6b4db3bf9ead9fd5901d89fa15d1f5fc https://gyazo.com/7bad9fa13ed20e4f9f248282b045a684

avatar image Fryderider Jan 04 '17 at 03:44 PM

The problem isn't within your MainMenuWidget then. Do you have any Player Start in your level? Are you using the right classes in your Game Mode Settings?

And your PlayerHUD, I can't see that you're actually creating the widget anywhere and adding it to your viewport.

avatar image Bhechmer Jan 04 '17 at 03:50 PM

Well, currently my gamemode settings are: https://gyazo.com/631e0f83fbfec64af69b2b5c5c89d08b and how do I add a player start to the level?

avatar image Bhechmer Jan 04 '17 at 03:51 PM

Also, I added my PlayerHUD in the PlayerCharacter graph:https://gyazo.com/43cf5a89d9aaca79fbec266464f80476 should I add it in the PlayerhUD graph instead?

avatar image Fryderider Jan 04 '17 at 03:56 PM

Make sure that the Default Pawn Class is the Character Blueprint that you're using.

Player Start can be found in the Modes panel under the Basic category. Just drag and drop into the level where you want your player to start.

Edit: If your Character Blueprint is namned "PlayerChar", then you should select that as your Default Pawn Class.

avatar image Bhechmer Jan 04 '17 at 04:02 PM

Thank you so much! When I switched the default pawn class to "PlayerChar" it let me play the game, but I'm still having a bit of an error: https://gyazo.com/e359a26b9012496cc9537ebd4ebc397c The game wants to start before I even hit PlayGame. Is there a quick fix to that?

avatar image Fryderider Jan 04 '17 at 04:19 PM

Glad it worked out :)

If you're just looking for a quick fix, then SetGamePaused might work. Set the game to paused when you start the game (EventBeginPlay) and when you press the Play Button, unpause the game.

avatar image Bhechmer Jan 04 '17 at 04:21 PM

Worked perfectly! Thanks so much for being such a help!

avatar image Fryderider Jan 04 '17 at 04:22 PM

You're welcome, good luck! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question