x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

XBox Gamepad Problem UMG 4.14

Please, we need help to find a workaround for a problem we are experiencing with the gamepad since we updated from 4.12 to the version 4.14.

We have an UMG menu where you can navigate using your left thumb stick up and down. This was scripted in the tick, checking the Input Analog Stick State for the Y axis as seen in the image:

alt text

This menu has some checkboxes that you could check and uncheck with the button A if they had focus. What we were doing was to SetKeyboardFocus to the proper checkbox while you navigate up and down, so you could press "A" and it toggles the state of the current checkbox.

The problem is that now, whenever you use the SetKeyboardFocus node, the analog stick state value gets 0 as result in both axis. You can still check and uncheck the checkboxes, but the sticks are not receiving inputs so you are stuck on that checkbox forever.

Please, is someone experiencing the same problem? Is there anything am I missing?

Summary: SetKeyboardInput disables GetAnalogStickState node.

Cheers!

Product Version: UE 4.14
Tags:
stick.jpg (34.1 kB)
more ▼

asked Jan 04 '17 at 09:39 AM in Blueprint Scripting

avatar image

JavierRamello
71 6 10 16

avatar image Artemaix Jan 09 '17 at 11:53 AM

I have the same problem, I updated to 4.14 and now it doesn´t works. Any idea?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Maybe a long shot, but are you using the left thumbstick for something else in your game, like moving a character? If so, you're probably getting the Axis Values from the left thumbstick somewhere. From there you can store the Axis Value in a variable, and use that variable instad of GetInputAnalogStickState.

more ▼

answered Jan 05 '17 at 04:29 PM

avatar image

Fryderider
115 6 11 13

avatar image JavierRamello Jan 05 '17 at 04:36 PM

I have just tried that, but not even the character is receiving the stick input once I SetKeyboardFocus() to a widget. Thanks for your reply though :(

avatar image JavierRamello Jan 05 '17 at 04:45 PM

I have just noticed that is not only the gamepad but also the keyboard stops working when I set focus to a widget manually

(comments are locked)
10|2000 characters needed characters left

Have you tried the SetUserFocus node instead of SetKeyboardFocus?

more ▼

answered Feb 07 '17 at 03:02 PM

avatar image

Fjellgnu
557 18 24 41

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question