x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Opening map file(s) crashes UE4

Opening map file(s) crashes UE4. I deleted the intermediate folder and data cache as I had seen it helped some people, but it didn't make a difference. Here is the Error:

MachineId:14554A554B86064EBBD03EB915EB1377 EpicAccountId:bddcc2f6b7bf4f0b913813bd7bffcebc

Assertion failed: IsImport() [File:D:\Engine\Source\Runtime\CoreUObject\Public\UObject\Linker.h] [Line: 62]

I have no idea whats causing this.

Product Version: UE 4.13
Tags:
more ▼

asked Jan 04 '17 at 04:16 PM in Bug Reports

avatar image

Ore Creative
67 4 8 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

After looking into your crash, I'm seeing something that's slightly similar in callstack that has been resolved in 4.14. Would you mind opening a copy of your project in 4.14 to see if the same crash occurs?

If it is a certain map causing the issue, it might be worth rolling back to an older version of the file as well to see if there was a particular change that could have caused this crash to occur.

Also, I'd recommend checking your log in your project's Saved->Logs folder. It looks like there are some animation errors that could use resolution. Not saying that this is the cause of the crash, but it's worth a shot.

Let me know if any of that helps!

more ▼

answered Jan 04 '17 at 06:39 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image Ore Creative Jan 04 '17 at 08:02 PM

Sean Flint! Small world, I hope you're still writing about indie games.

I've already rolled back the project in P4V to a few hours prior to the crash and that seems to have solved the issue. Although, I may never know what actually caused the problem.

So, for now its fixed! Thanks Sean.

avatar image Sean L ♦♦ STAFF Jan 04 '17 at 08:06 PM

No problem, glad to help. Good luck with Ira!

Feel free to reopen this thread if it comes back and I'll be glad to investigate further.

avatar image Ore Creative Jan 04 '17 at 09:27 PM

Sadly the error is back with no clear sign as to why its happening. The last thing I did was move a few blue prints around, and replace some old character BP with a new one using the replace and delete feature. Fixing up redirecters also causes the same crash. Its affecting many different maps and I cant see a pattern involved.

I opend the project in 4.14.2 and it did fix the problem. However we are currently running a custom built version of UE4 that has xbox one support built in along with a custom lighting model. We've settled into 4.13.2 and it would take many hours of work to upgrade right now. So, hopefully its possible to figure this out.

avatar image Sean L ♦♦ STAFF Jan 05 '17 at 04:37 PM

Sorry to hear that the error has come back.

I've done some more digging and found that this crash is most likely related to UE-35448, which unfortunately contains sensitive information and cannot be made public.

I've spent some time trying to look into the fix commit but unfortunately it appears to have been included directly into the 4.14 release, which means that you won't be able to access the individual commit in order to merge it into your custom build. However, this does explain why you are not running into the same issue in 4.14.2.

Unfortunately, at this time the only thing I'd be able to recommend is performing the work to upgrade the project to the latest as a result of the specific commit not being made available.

Let me know if you have any further questions and I'll be glad to help!

EDIT: In the meantime, I'm going to see if I can do some more digging to be able to get the file that was updated to fix this issue and I'll come back and let you know what I find.

EDIT 2: So the best I can do as far as providing a fix is to provide you with the file that was changed so you can at least try to grab the updated version: https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/CoreUObject/Private/Blueprint/BlueprintSupport.cpp

Let me know if that helps

avatar image Ore Creative Jan 06 '17 at 03:41 PM

Thanks for digging deeper Sean. I went ahead and rebuilt the engine in 4.14.1 and I'm getting an Unknown cook error when testing a build for windows 64 bit. Nothing else appears to be failing in the build up to that point.

UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)

Should I open a help thread somewhere else due to this question being different than the original?

avatar image Sean L ♦♦ STAFF Jan 06 '17 at 03:44 PM

Yeah go ahead and open a thread in the Packaging & Deployment section and then provide the link to the new question on this thread and I'll take a look.

In the new thread, if you could provide the full output log, that would be fantastic.

Thanks!

avatar image Ore Creative Jan 06 '17 at 05:42 PM

Awesome, thanks Sean. Here is the link new post

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question