x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Flipbook component in VR only appears in one eye.

Hi,

I'm trying to use a flipbook component in my VR project. It is only appearing in one eye.

Is there an easy fix for this?

Repro steps 1) Open a VR project 2) Add a flipbook to any object. 3) Look at it in VR. Mine only apprea in the left eye.

Thanks Russ

Product Version: UE 4.14
Tags:
more ▼

asked Jan 04 '17 at 08:03 PM in Bug Reports

avatar image

Rstenberg
25 3 6 8

avatar image Rudy Q ♦♦ STAFF Jan 05 '17 at 05:40 PM

Hello Rstenberg,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps (including any small steps that may have been left out of your original step) to reproduce this issue on our end?

  3. What VR device are you currently using?

avatar image Rstenberg Jan 05 '17 at 07:21 PM

Thanks Rudy.

So I loaded a completely fresh project in 4.14.2 and sure enough both eyes saw the flipbook. So then the itch of "Why does this not work in our engine" took over and I had to figure it out. We are using 4.14.1 with some custom things the programmers have done.

We use forward rendering so that was my first guess. Bringing up the project render settings I set all clean project settings to that of our engine. Forced engine restart. When I played it sure enough, only one eye. Looking at the settings I changed I was able to figure out Project Settings > Rendering > VR > Instanced Stereo is the culprit. The bool is unchecked by default and I got both eyes. We have the bool checked, I don't know why I deal with characters. When checked the flipbook only appears in my left eye.

We use the Oculus Rift.

Repro Steps

  1. Start a clean UE4 project, I do not use starter content. (No render changes)

  2. Import an image

  3. Create a sprite from the image

  4. Create a flipbook from the sprite

  5. Create an actor BP

  6. Add the paper flipbook component to the actor

  7. Add the flipbook you just made to the flipbook component.

  8. Drop the actor into your scene.

  9. Play in VR.

  10. You should see the sprite on both eyes.

  11. Save the whole project

  12. Project Settings > Rendering > VR > check Instanced Stereo

  13. Forced engine restart.

  14. Load the level you just saved.

  15. Play in VR.

  16. You should only see the sprite in your left eye.

I look forward to hearing if you can reproduce that. Russ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Use Translucent blend mode instead of masked in flipbook material

more ▼

answered Apr 17 '18 at 08:15 AM

avatar image

Airat
13 1 3

avatar image Brandalf Jul 20 '18 at 09:14 PM

This worked for me! Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Rstenberg,

After doing some digging I was able to find that this is a known issue. There is a developer note on this report stating that it affect flip books as well. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-37611

Make it a great day

more ▼

answered Jan 05 '17 at 07:46 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image laggyluk Aug 28 '17 at 12:53 PM

I have same problem in 4.17.1 with Sprite component, bug tracker says it was fixed jun 28 but it also says "This issue has been closed as 'Won't Fix' due to an extended period of time without updates. " so is it fixed or not?

avatar image Rudy Q ♦♦ STAFF Aug 28 '17 at 02:50 PM

Hello laggyluk,

I have reopened this issue. Feel free to use the link provided for future updates.

Make it a great day

avatar image BreakMaker Oct 16 '18 at 03:33 PM

Hello, the tracker indicates that this has been resolved. However in my project (forward renderer, instanced stereo) sprites and flipbook animations still only render on the left eye. (I am not sure about the editor billboards, but would surprise if it is different).

avatar image AlexM Dec 01 '18 at 12:45 AM

I also have the same issue. In fact now it's worse because the translucent hack doesn't work either in 4.21

avatar image alex-beyond Dec 05 '18 at 01:01 AM

I also have this same issue when using a sprite flipbook

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question