x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Steam app ID issues

Steam works with the dev app id of 480. However when I change it in the config file to use our custom app id, no steam, no steam overlay.

I've followed http://allarsblog.com/2016/02/26/BasicSteamIntegration/ and had no luck. Also I'm not the only person with this Issue. https://forums.unrealengine.com/showthread.php?131730-Steam-App-ID-Not-Working&p=639607

Product Version: UE 4.14
Tags:
more ▼

asked Jan 06 '17 at 01:39 AM in Packaging & Deployment

avatar image

bigpapaleo
74 10 10 13

avatar image Sean L ♦♦ STAFF Jan 06 '17 at 04:06 PM

Hey bigpapaleo,

What build configuration are you packaging your game for?

avatar image bigpapaleo Jan 06 '17 at 04:54 PM

I did Windows 64bit for each type of build. I tried development, shipping, and then debug. The steam ID 480 worked on all builds expect the shipping version and it worked when launched in stand alone game mode. My app ID didn't work on any of them.

avatar image Tesla Jan 10 '17 at 07:02 PM

Hi Sean,

There seem to be a few of us having this issue.

https://forums.unrealengine.com/showthread.php?131730-Steam-App-ID-Not-Working

Steam works with the 480 id, however as soon as you change the app id in the config file to the custom one it stops working.

avatar image project.gheist Jan 10 '17 at 08:07 PM

Have you tried changing the RelaunchAppId variable in function ConfigureSteamInitDevOptions in OnlineSubsystemSteam.cpp to the required custom one? That is the AppId it will use when in UE_BUILD_SHIPPING.

Hope that helps.

avatar image Sean L ♦♦ STAFF Jan 12 '17 at 07:36 PM

Thanks for the suggestion, project.gheist

Tesla, give this a shot if you haven't already and let me know if it works.

avatar image Sean L ♦♦ STAFF Jan 10 '17 at 07:13 PM

Thanks for the additional info Tesla. I'm going to spend some time tomorrow testing this and I'll get back to you as soon as I have new information.

Feel free to update with new information if you come across any in the meantime.

avatar image RaviTeja1212 May 16 '18 at 09:47 AM

i have the packages on steam. But still steam is not working. It works only on app ID 480. How to solve this?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Jan 17 '17 at 02:03 PM

avatar image

Sean L ♦♦ STAFF
43.9k 485 152 440

avatar image Tesla Jan 24 '17 at 07:10 PM

Hi Sean,

That post was nothing to do with the issue. The guy in the forum thread seems to have got the guys at steamworks to help, it's something on there end that they need to do.

This seems like an important thing to make people aware about :)

You can find the info out here in this thread:

https://forums.unrealengine.com/showthread.php?131730-Steam-App-ID-Not-Working&p=639607

avatar image Tesla Jan 24 '17 at 08:03 PM

I can now confirm this is the case, you need to contact valve and they will add the packages for you, by default they seem to be missing. Once they have done this (they did it within minutes of posting) the custom dev app ID works. It might be worth adding this to the steam works page on the UE4 docs. :)

avatar image bigpapaleo Jan 25 '17 at 01:44 AM

Doing what qdelpeche did on the forums worked for me.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question