x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

I got to correct a mistake for UE4, which I downloaded via the launcher with the help of the program update, which I found on the forum, but what UE4, which I downloaded via GitHub? The program-update not see UE4 from GitHub! Crash occurs when the editor starts.

Here is the error code:

MachineId:F4412F3946E742FE3B70A3A0CFF1B0E5 EpicAccountId:b879a722949044ceb94f37a7925777be

Fatal error: [File:C:\Users\matus\Documents\UnrealEngine\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

UE4Editor_Core!FDebug::AssertFailed() [c:\users\matus\documents\unrealengine\engine\source\runtime\core\private\misc\assertionmacros.cpp:332] UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [c:\users\matus\documents\unrealengine\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:176] UE4Editor_D3D11RHI!VerifyD3D11Result() [c:\users\matus\documents\unrealengine\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225] UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIReadSurfaceFloatData() [c:\users\matus\documents\unrealengine\engine\source\runtime\windows\d3d11rhi\private\d3d11rendertarget.cpp:1176] UE4Editor_RHI!FRHICommandListImmediate::ReadSurfaceFloatData() [c:\users\matus\documents\unrealengine\engine\source\runtime\rhi\public\rhicommandlist.h:3025] UE4Editor_Renderer!ComputeSingleAverageBrightnessFromCubemap() [c:\users\matus\documents\unrealengine\engine\source\runtime\renderer\private\reflectionenvironmentcapture.cpp:316] UE4Editor_Renderer!ComputeAverageBrightness() [c:\users\matus\documents\unrealengine\engine\source\runtime\renderer\private\reflectionenvironmentcapture.cpp:379] UE4Editor_Renderer!TGraphTask<`FScene::UpdateReflectionCaptureContents'::`19'::EURCMacro_FilterCommand>::ExecuteTask() [c:\users\matus\documents\unrealengine\engine\source\runtime\core\public\async\taskgraphinterfaces.h:868] UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [c:\users\matus\documents\unrealengine\engine\source\runtime\core\private\async\taskgraph.cpp:932] UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [c:\users\matus\documents\unrealengine\engine\source\runtime\core\private\async\taskgraph.cpp:679] UE4Editor_RenderCore!RenderingThreadMain() [c:\users\matus\documents\unrealengine\engine\source\runtime\rendercore\private\renderingthread.cpp:320] UE4Editor_RenderCore!FRenderingThread::Run() [c:\users\matus\documents\unrealengine\engine\source\runtime\rendercore\private\renderingthread.cpp:454] UE4Editor_Core!FRunnableThreadWin::Run() [c:\users\matus\documents\unrealengine\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Product Version: UE 4.14
Tags:
more ▼

asked Jan 06 '17 at 01:57 AM in Installation & Setup

avatar image

NODARYN
122 10 21 33

avatar image Ed Burgess ♦♦ STAFF Jan 10 '17 at 02:27 PM

Hi MrPrane,

What you are referring to is the QFE. If you update to 4.14.2 that will include the fix that addresses this issue. If you are still getting the crash then you have a unique issue that needs investigation. Try out 4.14.2 and see if you still get the crash. If so, please comment here.

Thanks,

avatar image NODARYN Jan 11 '17 at 05:00 AM

I shook Release version from GitHub January 6 this year, so I have version 4.14.2 likely.

avatar image Ed Burgess ♦♦ STAFF Jan 11 '17 at 03:02 PM

The update is intended for specific hardware. Could you provide your DxDiag? To do this open your windows command prompt and enter dxdiag.

When the window appears save all information and attach the generated file in this post.

Also, to ensure this isn't a hardware issue could you test this on a binary build of 4.14.2?

It would be very useful to know if the Binary version of the engine crashes. By binary build I am referring to the build of the engine you get via the launcher. Just install the epic games launcher and grab the latest engine version.


One last note, when I looked up your machine ID on crash reporter I got a different crash callstack. When you get this particular crash could you make sure to submit it in the crash window.

avatar image NODARYN Jan 11 '17 at 08:45 PM

In UE4, downloaded from the launcher, I had the same problem, I decided with the help of the program-fix, which I downloaded on the forum.link text

dxdiag.txt (95.1 kB)
avatar image Ed Burgess ♦♦ STAFF Jan 13 '17 at 03:31 PM

Thank you for all of the useful information.

Now that I have your system info I'm going to start testing on a machine similar to yours.

Could you please provide the exact list of steps that reproduce your crash reliably in a blank project. Once I have that information I can begin testing to see if I get the crash on my side.

Thanks!

avatar image NODARYN Jan 13 '17 at 09:46 PM

I downloaded a project, made by another person chosen for his version of the engine, which I downloaded from GitHub, and launched the project. Then came the automatic adjustment of shaders (approximately 3,000 units) and as soon as the adjustment has reached the end - flew error. Now when I try to open the same project, I get out error immediately and with little computer freezes.

avatar image NODARYN Jan 13 '17 at 09:51 PM

I also want to add that the engine that I downloaded via the launcher, also causes an error when you try to edit the actor is, but it helped me a program-fix I downloaded on the forum, but GitHub version of this program does not see!

avatar image NODARYN Jan 13 '17 at 11:50 PM

I downloaded version 4.14.3 with GitHub and still flies out error.

avatar image Ed Burgess ♦♦ STAFF Jan 16 '17 at 01:53 PM

Unfortunately, I can't reproduce the issue with the information you provided. Could you provide steps to reproduce the crash from a blank or template project.

If that isn't possible could you provide a small sample project that reproduces the issue?

Without these things I can't continue with this investigation.

avatar image NODARYN Jan 17 '17 at 09:27 AM

In pure project I'm fine, no errors. The error occurs when loading the project, as a famous world "MMO Starter Kit 1.7". https://forums.unrealengine.com/showthread.php?53208-MMO-Starter-Kit

avatar image TraneTM Mar 02 '18 at 09:05 PM

Fatal error: [File:D:\Jenkins\workspace\Live_Ship\UnrealEngine\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

I tried everything from this subject. Help!

avatar image liumingod Apr 05 '17 at 07:01 AM

All things metioned in this thread i have tried,still HUNG crashed. I wait to solve the problem and continue to work :(

gtx 1070 i7 6700

avatar image arke1 Sep 29 '17 at 06:24 AM

How is this problem so common and still not fixed?

avatar image BenjvC Sep 03 '18 at 06:52 PM

No kidding, a year later and this bug is killing me, nothing touches it; reset Windows, reinstall UE4, load 4.20.2, load backup of stable project, what else is there? GPU passes with flying colors in MSI Kombuster.

avatar image Zambonee Sep 11 '18 at 02:43 AM

I bought a new monitor with higher refresh rate. Started seeing this when I launch pubg

LowLevelFatalError [File:D:\wk\tsl-client-dev3-branch\build\UnrealEngine\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 182] &nl;Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0007 - &apos;RESET&apos;)&nl; Only changed monitor. Started using the display port on my Nvidia 970 so I can get the 144hz instead of the DVI ports and Enabled G-sync for the new monitor. Launch Pubg crashes on main menu. Not sure if this helps anyone try to figure this issue out.

avatar image HBustani May 10 '19 at 01:13 PM

I found Lost 3D Device error happens almost immediately in Soul Calibur 6 when my desktop has just been turned on, then it becomes less frequent as the PC warms up. This suggests it is due to a still-cold power supply being unable to meet the peak demand of the GPU. Some voltage may be dropping too low and hanging the GPU.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

9 answers: sort voted first

Hey MrPrane,

Good News! We were finally able to reproduce this crash and have a JIRA for it here: https://issues.unrealengine.com/issue/UE-40807

You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may take some time to address.

Cheers,

Ed Burgess

more ▼

answered Jan 18 '17 at 10:00 PM

avatar image NODARYN Jan 19 '17 at 12:23 AM

Well, thank you for your support! If this case is just me - you do not hurry up, I have another project works and I work in it, just leave a review about the existence of a problem. Thanks again!

avatar image Ed Burgess ♦♦ STAFF Jan 19 '17 at 07:04 PM

Hi MrPrane,

There is a possible workaround that we are investigating. The GPU crash may be related to microsoft's Timeout Detection & Recovery(TDR) feature. You can find out more about it here: https://msdn.microsoft.com/en-us/library/windows/hardware/ff570087(v=vs.85).aspx

Basically, it detects if your GPU is hung up and if it passes a certain amount of time Windows will automatically reset the GPU resulting in the crash. This is done to prevent a freeze forcing a hard reboot of the system.

Sometimes you need to add a little more time for your GPU to process before Windows causes the reset. To do this you need to change the TDR delay.

I have two suggestion on how to do this you can do it manually yourself OR you can download a tool that will do it for you. However, I haven't used the tool that much myself but it does appear to work. (Use at your own risk)

avatar image Ed Burgess ♦♦ STAFF Jan 19 '17 at 07:04 PM

Method 1 (manually):

  • Go to the this link: https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx

  • There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time

  • To open your registry open your start menu and type "run" once the window is open type "regedit" and hit OK

  • Now you should have Registry Editor open this is where you will use the info at the website I just linked.

  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

  • Right click on GraphicsDrivers and go to new> DWORD (32 bit) value

  • You will see a new key appear make sure to name it "TdrDelay"

  • Right click it and select "modify"

  • Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base

  • Hit okay and restart your system

Method 2

avatar image NODARYN Jan 23 '17 at 01:16 PM

Unfortunately it did not help. Thank you for having tried to help!

avatar image Ed Burgess ♦♦ STAFF Jan 23 '17 at 02:10 PM

Okay, thank you for the feedback. We are still investigating this issue. I will update this post once more information is found.

Thank you for your patience.

Ed

avatar image NODARYN Jan 23 '17 at 02:36 PM

Perhaps this is something to do with the failure of my video card. It is, starts to act, there are artifacts and helps only GPU warming. If I have a unique situation, this video card is the problem.

avatar image Ed Burgess ♦♦ STAFF Jan 23 '17 at 02:52 PM

[UPDATE] A user (IronicParadox) suggested that going into the content browser pane > click the little eye that says "View Options" and uncheck "Real-Time Thumbnails." made the engine much more stable.

Could you let me know if this helps?

avatar image NODARYN Jan 24 '17 at 03:25 AM

So far, there are no errors, but may appear in the future. What is the option?

avatar image Brohan11 Feb 01 '17 at 11:03 PM

This actually worked for me. Thanks!!

avatar image VictorSoulbound Oct 24 '17 at 09:37 PM

+1

this fixed it for us on a very heavy level that we were getting this crash pressing PIE

avatar image Tetsuwan Jul 20 '17 at 06:28 PM

Thanks, it helped me.

I'll write if something changes

avatar image Luos Mar 31 '17 at 08:45 AM

For those who keep having this issue even with unchecking "Real-Time Thumbnails" get "MSI Afterburner" or other means to down-clock the gpu a few 100 mhz, this is almost always guaranteed to work. (tested it on multiple occasions, and suggested it to multiple people)

afterburner link: https://www.msi.com/page/afterburner

avatar image Ed Burgess ♦♦ STAFF Mar 31 '17 at 02:17 PM

I appreciate the post Luos, If I see anyone else having issues I'll give them your suggestion.

Thank you!

avatar image CinderTheone Apr 03 '17 at 12:23 AM

disabling real-time Thumbnails have for the time being sorted out my crashes! Don't know for how long but I am hopeful, really appreciate the input guys! Thanks

avatar image liumingod Apr 05 '17 at 07:01 AM

All things metioned above i have tried,still HUNG crashed. I'm wait to solve the problem and continue to work :(

gtx 1070 i7 6700

avatar image Ed Burgess ♦♦ STAFF Apr 05 '17 at 05:30 PM

In an upcoming hot fix we plan to implement Nvidia Aftermath which should help us get to the bottom of these d3d crash issues.

avatar image RuTzoT May 13 '17 at 04:57 PM

I have the same problem: "Unreal Engine is exiting due to D3D device being lost." I did all the above written - nothing helped. At me this error appears at opening practically any editor (the Skeletal, particles, a material). Without this it is impossible to work. You can put a cross on the project, which took a lot of time. If there is any solution, I will provide all the data about errors and their reproductions. Sorry, if something is not clear, I translate through Google.link text

dxdiag.txt (78.1 kB)
avatar image Ed Burgess ♦♦ STAFF May 15 '17 at 06:01 PM

Hi RuTzoT,

We are still investigating this d3d hung crash issue. If none of the suggested work arounds assist you I would suggest working in a previous engine version that doesn't have issues.

Nvidia Aftermath has been introduced and we are still analyzing the data coming in.

avatar image Positivity Jun 17 '17 at 09:17 AM

Hey, I would like to add to this issue one thing, I have this same issue happening in 4.16.1 This Fatal Error happens if my Oculus Headset is Plugged in and I launch a game with Dedicated Server Ticked and as Single Proces. If I Launch game without Dedicated Server no Error occurs, Oculus Still Plugged in. If I Unplug Oculus I have no Fatal Error in DS mode. Fatal Error is happening Exactly after I try to close the New Editor Window and not on Start of the Play Windows 10 64x GTX 1080

avatar image Spacemonkey907 Jun 27 '17 at 10:27 PM

Most of my steam games are giving me problems now. Crashing, giving me fatal errors left and right.

One error is this: create_index_buffer:CreateBuffer failed.HRESULT: 2289696773=DXGI_ERROR_DEVICE_REMOVED: GetDeviceRemovedReason() = DXGI_ERROR_DEVICE_HUNG

At "F:\BuildAgent\work\1358eaafe6731564\runtime\d3d11_render_de vice\d3d_geometry.cpp:266"

Another error is this: http://imgur.com/qANnNO5

Another error is this: http://imgur.com/TYodlY5

Just what on earth is happening? Is there a solution yet???

avatar image MADHOUSE Aug 23 '17 at 10:30 PM

We just finished a playtest with a shipping build of a multiplayer game with UE 4.17.1, one of the clients got a lot of these crashes:

alt text

crash.jpg (26.9 kB)
avatar image Luneya Sep 20 '17 at 01:04 PM

I have encountered these errors every 2 minutes when playing Hellblade: Senua's Sacrifice whilst streaming via OBS Studio. Mind you, I have done so many times before and nothing has changed in my settings. And somehow since today these crashes keep happening. I have tried all the suggestions in this thread, but nothing has prevented these crashes from happening. The only thing I could ofcourse not try was disabling the thumbnails, because I am not making a game. Just trying to play one ;)

MSI GTX 770 Gaming GPU / i5 4670K

avatar image KrayZ-t May 13 '19 at 01:36 PM

Issue occurs without fail for me everytime I attempt to run SCUM or a select few other UE4 games (Only UE4 games are causing this for me).

Desktop build: MSI x470 Gaming Pro Carbon, Radeon VII (Manufacturer OC) 1802MHz HBM2 16GB GPU, Ryzen7 2700x 3.75GHz Octo-core CPU, 32GB Corsair Vengeance LPX 3200MHz, M2.(1) 240GB Kingston SSD M2.(2) No device HD1 - 2TB Firecuda SSHD HD2, 3, 4 - No Devices.

This needs fixing, workaround which get people to clock down their devices is unacceptable, do your job as devs and fix things, and if you cannot fix them then stop teh avilabiulity of engine versions which are not in an acceptable state!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

thats the solution that worked for me:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers]

"TdrDelay"=dword:0000000a

"TdrDebugMode"=dword:00000001

"TdrLevel"=dword:00000000

more ▼

answered Feb 12 '18 at 09:56 PM

avatar image

Klamsi
6 2

avatar image 9robin3 Feb 16 '18 at 07:38 PM

Where do I write this?

avatar image sabarife Jun 06 '18 at 12:34 PM

You should create new keys in regedit as you did for "TdrDelay" Here is instructions from Ed Burgess

Ed Burgess ♦♦ STAFF Jan 19 '17 at 10:04 PM 2 Method 1 (manually):

Go to the this link: https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx

There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time

To open your registry open your start menu and type "run" once the window is open type "regedit" and hit OK

Now you should have Registry Editor open this is where you will use the info at the website I just linked.

First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

Right click on GraphicsDrivers and go to new> DWORD (32 bit) value

You will see a new key appear make sure to name it "TdrDelay"

Right click it and select "modify"

Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base

Hit okay and restart your system

You can do the same for "TdrDebugMode" and "TdrLevel", But you sould use hexadecimal instead of decimal.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The only way works for me is to use my laptop with plugged to the electricity. And I know one collague who use this solution as the only solution.

more ▼

answered Aug 03 '18 at 01:31 AM

avatar image

sabarife
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Also have this problem but only on some computers. Please help

more ▼

answered Feb 16 '18 at 07:25 PM

avatar image

9robin3
36 1 5 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am crashing also while playing Conan Exiles. In addition I get always corrupted files after them. It wastes my time (several hours now!) to correct it. After them I get always the same crash.

more ▼

answered May 12 '18 at 03:16 PM

avatar image

VokALchimist
1 1

avatar image BenjvC Sep 04 '18 at 04:03 PM

VokALchimist, I've now encountered this persistent badness with D3D device being lost in 4.20.2, a new trouble ticket states an expected fix in 4.21, but I don't see how Epic Games can deal with this non-reproducible issue until they remote into a given user's PC, their project, where the issue is reproducible and representative of the greater issue experienced by hundreds of UE4 users. In any event, I've suspected what you describe with files getting corrupted, but how did you determine that? And how did you remedy that? I restored from a stable backup project folder, yes?

I'm questioning if UE4 may have allowed some conditions to exist in a project without protection against compromising gpu hardware. This project I'm now consistently seeing the crash in ran completely stable for two months, during which time I only worked on BPs and things that added no workload to rendering, e.g. no added geo or textures. My system spec (GTX 1080) supported 90+ fps throughout this period, so after resetting Windows, fresh instal of UE4, restoring a stable project folder, what is left? If nothing, does that point to compromised GPU? MSI Kombuster reports 100% usage and runs without event for ten minutes, Nvidia techs say this GPU is up to spec. This all doesn't add up. Your thoughts. Many thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

LowLevelFatalError [File:Unknown] [Line: 826] Rendering thread exception: LowLevelFatalError [File:Unknown] [Line: 251] Result failed at D:\RadiantUnreal_420\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:304 with error 8876017C

0x00007ffaaf75a388 KERNELBASE.dll!UnknownFunction [] 0x00007ff68b8a3e39 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b864c9c Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b83219d Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68bce0deb Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68bcd09da Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68bcd8681 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c13847b Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c136136 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c29d315 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c29f2b9 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b7a484b Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b7a4953 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c156fc2 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68c157048 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b8ae937 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ff68b8ac157 Radiant-Win64-Shipping.exe!UnknownFunction [] 0x00007ffaafcb3034 KERNEL32.DLL!UnknownFunction [] 0x00007ffab2631431 ntdll.dll!UnknownFunction []

i get this fatal error and ive tried everything uninstalling reienstalling its not just this game drives are all upto date benchmarked to test to see if something was failing it happens to gme slike dead by daylight and golfit what do i do

more ▼

answered Aug 22 '18 at 05:18 AM

avatar image

blacksoul93
6 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have found out how to fix the problem with the "LowLevelFatalError GPU crashed" or found a workaround that no longer causes this error.

LowLevelFatalError [File:D:\build\PC\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: ***] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

Please support me to spread this in other forums as there are a lot of people with this problem. I've been busy for a week now and read a lot, which did not help! (At least 7x 3 hrs. Ie 21 hrs.)

Please also help by writing to the devs that fix this bug, as I do not know exactly who is to blame for this bug. Maybe the Unreal Engine Devs or graphics cards Devs. (Graphics card manufacturer or driver creator)

Long story short, it is related to the Nvidia Garfikkarten that are already overclocked from house !!! The so-called Nvidia OC graphic cards!

The overclocked Nvidia graphics cards have a problem with the Unreal Engine or its programming or vice versa! That's what I found out after days of testing!

Now for the help of me:

It now depends on the graphics card manufacturer, whether he provides an overclocking OC software on his website. In my case I have a Zotac Geforce GTX 1080 AMP! Extreme and Zotac I had to download the overclocking tool "Firestorm" which is only intended for the Zotac OC graphics cards.

The point here is that with this tool we need to lower our graphics card back to normal, so that we can play the Unreal Engine games that get this low-level FatalError / GPU crashed. So you download this tool, like Firestorm, MSI it is the Afterburner etc. down and changes the GPU clock down -200 / -400 MHz it was with me and saves! (do not forget!) I have to leave the tool open, or in the background, if you can close it, I do not know.

(Before: It's best to save the default settings so that you can use your OC Garfikkarten Power games that do not have this problem. Some have but a standard setting button "default" which you can reset the back in auszusungszsutand with OC Pwoer.)

That's it already! Your Unreal Engine game should now work without this bug!

Have fun and maybe support me and let me have a small donation for the week of hard research and troubleshooting. https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=57WG66MBSZTM6

PS: For me it was 3 games that had this error. I do not list these now because I will copy and paste this text to spread it and I do not want it to be deleted for advertising another game.

By the way, game developers are welcome to help inform Nvidia and Unreal Devs about this issue and have it resolved in collaboration. After all, it also saves you a lot of time, trouble and above all money, as there are many players who will return the game due to this error.

Since I am a German, I have this text translated by Google Translator, I hope you can handle the English translation. If not just comment or answer.

Thank you!

more ▼

answered Sep 10 '18 at 01:13 PM

avatar image

BlackEagle2k18
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

BlackEagle2k18, I too have worked this problem for days on end, have had techs from Microsoft involved, as well as Nvidia. I'm told by Microsoft my system checks out, all drivers uptodate, Microsoft C++ Redistributables are solid, the TDR issue discussed above is a normal function in place to protect the GPU in the event other protective measures, such as Nvidia's temp threshold, doesn't preempt. I'm told by Nvidia techs that my GPU is behaving normally, MSI Komubuster shows stable performance, even with 90° C temps on my laptop, which they say speaks well for my particular build, a GoBoxx, but that they don't want to see higher temps than that on this machine. When we test my UE4 project, I used "r.screenpercentage 50" to halve the rendering workload in a project that had consistently crashed with the D3D device being lost error, temps ran to high 80s, but stable. I bumped rendering quality to 75, still stable at 90°, but there we stopped.

Evidently, my project crashes with full rendering quality and thus higher temps, leaving me to wonder why this issue now and not during a two-month period before in which I could work for hours with the project open, fly the cameras as fast as I'd like, no crashing. The crashes began around the time my air conditioner in my "server room" (A/V closet/bathroom) went down, am still awaiting a part. So, with ambient temps here around 29° C, this could explain why the crashing began. If I were just under the threshold of what my PC could take, note my project has some 40 million polys with well over one hundred 8K textures, this running on a laptop with a GTX 1080, then this PC's ability to shed heat would most certainly be compromised with the 5°+ higher ambient temp than the usual 22.2° I get with AC.

Even if a broken AC figures in to explaining my particular case, that proximate cause says nothing to explain why hundreds of Unreal users have begun reporting this issue since February of 2017 since the 4.14 release. We have two trouble tickets describing the chase and hoped for resolution with the next build. I read about various workarounds, disabling live thumbnail previews, turning down rendering quality, and as you point out, forcing lower clock speed. Each of these workarounds achieves the same effect of lowering rendering workload, so while everyone may have a different PC/gpu and stress those system resources differently based on a project or cooked build, these workarounds may point to a simple fact, that the driver to the crashes is simply exceeding whatever threshold to high temperature. It may take a heavier workload by a given project on a stronger machine, but whatever it takes to exceed that threshold, the result is the same, GPU hangs, Microsoft TDR says "party over".

Why this problem only beginning with 4.14? Did 4.14 introduce appreciably higher workloads on GPU than before? If it's only about reaching this thermal threshold, then that theory doesn't add up. UE4 kicks out warnings in Editor, "Exceeding texture pool limits", also messages asking user if they'd like UE4 to lower frame speed or lower rendering quality, so I'm wondering why UE4 isn't invoking those same type warnings before things get too hot?

I get my AC fixed in less than a week. Then I can test my project and see if the crashes go away. It seems the D3D device being lost error is a bug no matter which way you cut it, but if my project(s) that acted stable before continue to crash after I restore cool ambient temps, then that says something yet more troubling about this bug. Afterall, I had reset Windows, reinstalled Epic Games, fresh install of 4.20.1 (crashes began on 4.19.2 and 4.20), so if Nvidia is correct that my GPU is strong and healthy, then what's left? It would have to be a bug persistent through each these engine versions.

more ▼

answered Sep 12 '18 at 03:11 PM

avatar image

BenjvC
65 3 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

,1) I went to https://www.wagnardsoft.com/ and downloaded DDU v17.0.8.4

 - Install the software

 - Reboot into safe mode

 - Run software and let it do its thing

 - Reboot once its done

 

2) Re-Downloaded Nvidia Latest drivers (not autodetect). Installed using "Express" option

3) "Disable real time thumbnails"

 - Here is the guide: https://www.windowscentral.com/how-disable-taskbar-thumbnail-preview-windows-10 


4) Go to Control Panel --> System --> Advanced System Settings. On the "Visual Effects" tab I selected "Adjust for best performance"

5) Ensured desktop scaling (DPI) within windows was at 100% (not 125%, 150%).

I rebooted and was able finish the entire game in Fullscreen with no crashes.

Hope this helps anyone else with these frustrating crashes!

more ▼

answered Jan 23 '19 at 06:46 PM

avatar image

suta01
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So, I should update about my experience with this D3D device being lost issue, a 6-month epic finally makes more sense, note the qualifier. For starters, to relate this to the two more recent posts above, I checked with GoBoxx who makes my gaming laptop w/ GTX 1080, they disabled the auto overclocking software that Clevo shipped these cards with precisely because they didn't like what they were seeing. This company specializes in PCs for entertainment industry and engineers, handles lots of overclocking on beefy PCs, but on the laptops they saw grounds to pull back. So, that my GoBoxx MXL VR laptop not only encountered these error with frequent crashes, but then totally fried the card, raises the question, what's different here? I'll tell you.

I run another app, Reality Capture, that pushes GPU pretty hard during depth map creation for photogrammetry-based workflow, then work the card even harder in UE4, my work being all about the environment, very little about game-play. 43 million polys with many dozens of 8K maps, dozens of movable lights, looks killer but you get the picture. When I first encountered the crashing it was only in UE4, Reality Capture remained solid and a tech from Nvidia said the card seemed totally up to spec based on testing in MSI Kombuster, ran an hour at 100% with CPU stressed and whatever settings this tech setup, so this seemed to point solely within UE4. Add to that the fact that hundreds, many hundreds of users over Steam and this forum report this issue related to UE4, in project and in games like Fortnite. Add that the fact that Epic devs have had what is it, a JIRA posted since 2016, one version after the next promising a fix, and here we are today.

When I was totally out of ideas what to do I came upon a post from one user who wasn't even encountering this problem but tried to help with a suggestion, "whenever I encounter problems like this in UE4, 90% of the time if I remove the GPU and DIMMs, clean them with alcohol and reseat them, the problem goes away". So, I tried that last July and that worked. Yay. The beast reared its head again in September and this time that trick didn't work. That it worked at all is weird. Is that like resetting your PC, or going further to power drain by unplugging and pressing the power button a few secs, and going yet further by physically disconnecting PCBs? WTH In any event, during this relapse I then encountered (for the first time) crashes in Reality Capture, GPU lost error 30, woah. Then tested in Kombuster, couldn't even go 10 seconds at low settings without crashing.

$1100 later I'm here to say, woe ye who doesn't take these errors seriously, it's not just about software crashing, it can hurt your hardware. I didn't know that was possible these days, but clearly I push my system hard, actually happy to learn where too hard lies so I can stay south of it. I'm now setting quality settings to Low while developing, believe that helps quite a bit, don't care what things look like during much of the work. I'm also moving my work to a maxxed out Mac Pro, only use the laptop to test and present. And sure, if you're overclocking, I'd reconsider, especially on gaming laptops with their super constrained issues with thermal regulation.

On a final note, dear Epic Games. I submitted a bug report and have been in dialogue with someone who has always returned my emails whenever I've written him with detailed updates, but hasn't written once proactively with the first bit of information. All he ever responds with is to say, "Thank you for the information, we'll let you know if we learn anything." To show some understanding, if an issue isn't reproducible then big surprise that a dev team would largely have their hands tied. I offered to ship my laptop to them and let them hang on to a PC with very reproducible crashing from this error, but same response, "don't call us, we'll call you".

I don't see that this is simply about GPU workload surpassing some threshold. The overclocking thing may well be related, set up conditions that some illegal instruction from UE4 then serves as the straw that broke the camel's back. I say that because my card wasn't overclocked, yes running hard, but performed fine in Kombuster at 100% for an hour. Also, I could be in UE4 doing nothing, just open this project, no key commands, no mousing or navigation, static, watching system resources, GPU-Z, seeing clock speed climbing on its own higher and higher, temps still totally fine in the 70s, crash. It's my expectation that between Microsoft C++ Redistributables like TDR (will shut app down if GPU freezes), protective measures operating within the GPU like ramping fan speed in response to temps, and UE4 lowering frame speed in response to strained performance, that there are all kinds of things going on to protect this very expensive component in any system. To learn there's an upper threshold where a user can damage a GTX 1080 is one thing, got it, but I see that's more a proximate cause. The ultimate cause really seems to be some illegal instruction coming from UE4. Many hundreds of users having many thousands of variables in play have one thing in common, UE4. Alas, this issue still ranks as low priority at Epic Games. If the tech handling my case showed the slightest sign of caring. I don't agree with the logic of whining online, gets you nowhere. I'm good now, can work within the lines. I'm venting, but also sharing with others scratching their heads and hoping my experience saves others from frying their cards.

Benjy

more ▼

answered Jan 28 '19 at 11:24 PM

avatar image

BenjvC
65 3 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question