x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Still having driver Hangs in 4.14.2, any ideas welcome.

Still Experiencing Driver failures in 4.14.2

The issue on my end can be triggered from editing mesh and material slots to moving the mouse over various actors and objects details to opening and closing Blueprints, most things can trigger a black screen and then crash to desktop with a Driver recover bubble popping up.

-D3DDebug in use for ue4error.log.txt attachment

Things i have tried,

New drivers, checked Card temps , memory checks, clean projects in 4.14.2, etc

My card is on the low end Nvidia Geforce 610 GT but it worked well enough for me in 4.13 and previous engine builds with little to no issues other then low FPS when i had a ton of higher end render effects or lots of geometry going on.

I love the features of 4.14 and really want to make use of this and future versions but things are to much like a mine field at the moment to use this engine thanks for working on this issue and this engine.

Link to forum post on related issue i have a similar post here as well

[1]: /storage/temp/121762-recenterror.zip

Product Version: UE 4.14
Tags:
ue4error.log.txt (46.4 kB)
dxdiag.txt (43.2 kB)
recenterror.zip (66.7 kB)
more ▼

asked Jan 06 '17 at 05:22 PM in Bug Reports

avatar image

TheSlowLourse
6 3 5

avatar image TheSlowLourse Jan 06 '17 at 05:40 PM

windowssysingo.nfo.txt is just extra in case it helps remove the .txt to view more easily on a windows system

avatar image BloomandBlight Jan 10 '17 at 03:59 PM

Experiencing the same crash in 4.14.2. It happens generally when I open a blueprint and try to change some of the settings (e.g. mesh and mat slots) or just moving my mouse over the bp screen.

avatar image Ed Burgess ♦♦ STAFF Jan 11 '17 at 08:04 PM

Hey TheSlowLourse,

I'm going to need some additional information from you. Could you provide the callstack and the Machine ID that is listed in the Crash window that appears after you experience the crash. Make sure you submit the crash as well.

Thanks!

-Ed

avatar image TheSlowLourse Jan 12 '17 at 04:31 PM

In my attachments list above iv added a zip file (recenterror.zip) containing a text file with machine id and call stack along with a new error file and mini-dmp in case that helps iv also submitted a report using the error window after a crash

thanks for the help

avatar image Ed Burgess ♦♦ STAFF Jan 16 '17 at 09:40 PM

I was unable to reproduce this crash. I've put together a machine that is somewhat similar to your setup. I could tell from you logs that you were using your own personal project and it looks like the engine crashed when you clicked on bobble_bp_C.

Could you please try to reproduce this in a blank project or a template project. This issue has had a history of being difficult to reproduce for EPIC internally and a very specific set of steps may be needed for us to solve this.

I know it may seem like any random thing may trigger the crash but keep in mind that there are many variables that could be different that is causing us to not experience the issue.

Giving a list of steps that consistently will crash the engine from a blank/template project on a machine like yours greatly assists us.

Thanks!

avatar image TheSlowLourse Jan 17 '17 at 03:53 PM

steps taken to get driver to crash using blank project.

  1. launch 4.14.3 from a short cut with -d3ddebug enabled

  2. created blank project called drivererrortest4143

  3. created new level using the template Vr-basic

  4. begin clicking on details of various static meshes in scene , swapped or clicked on materials in content broswer when trying to change the material of one of the static meshes in the level the crash can occur for me duing any of these actions.

attached is a blank 4.14.3 project i used to get the crash a text file with machine id and call stack in the folder as well (errorsteps.txt) the project should also have the last log file file with error information. i have also submitted using the error window that comes up afterwards.

Thanks again for the help

avatar image Ed Burgess ♦♦ STAFF Jan 17 '17 at 09:20 PM

Thank you for all the information. When I opened your provided project it asked me to install a couple plug-ins. Would you mind disabling all your third party plugins (substance for example) to see if that resolves the issue.

Even with your project and steps, I was unable to reproduce the crash. The only thing that is different is that I wasn't using any plug-in features.

It may also be worthwhile to check if you still crash using the 4.15 preview. (it is pretty likely that you will still crash though).

Thanks!

avatar image TheSlowLourse Jan 17 '17 at 10:47 PM

Thanks for that info I had not considered the two third party plugins iv had them installed for so long .Im not at the same machine right now and will try out both disabling the plugins using the same test project that i provided above using the same steps,and will try out preview 4.15 just in case .

avatar image TheSlowLourse Jan 18 '17 at 01:08 AM

Ran a test in 4.14.3 this time disabled third party plugins crash still occurs and tested 4.15 as expected a very similar crash. attached is a zip with both projects used to get crashes with text files in them with call stacks and machine id or login id ,submitted crash reports for both.

steps taken to get crash using a blank project.

  1. launch A Ue4(4.14.3 or 4.15) from a short cut with -d3ddebug enabled

  2. created blank project

  3. created new level using the template Vr-basic

  4. begin clicking on details of various static meshes in scene , swapped or clicked on materials in content browser when trying to change the material of one of the static meshes in the level the crash can occur for me during any of these actions.

Thanks for taking time on this 4.14 and 4.15 look like they have great stuff.

errorinfo.zip (2.0 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi SlowLourse,

Thank you for all the information. We have a ticket in for this crash and will continue investigating the crash. You can find it here: https://issues.unrealengine.com/issue/UE-40773

You may notice that your callstack isn't exactly the same. We decided to lump you in with batch for now due to how similar your crash was.

Feel free to track the ticket as we continue to investigate and review this issue. Keep in mind that we don't have a time frame on when this will be addressed so don't rely on a fix to be made quickly if it is crucial to development.

I may also return to gather additional information if needed.

Thanks!

more ▼

answered Jan 19 '17 at 03:31 PM

avatar image Ed Burgess ♦♦ STAFF Jan 19 '17 at 07:08 PM

Hey!

There is a possible workaround that we are investigating. The GPU crash may be related to microsoft's Timeout Detection & Recovery(TDR) feature. You can find out more about it here: https://msdn.microsoft.com/en-us/library/windows/hardware/ff570087(v=vs.85).aspx

Basically, it detects if your GPU is hung up and if it passes a certain amount of time Windows will automatically reset the GPU resulting in the crash. This is done to prevent a freeze forcing a hard reboot of the system.

Sometimes you need to add a little more time for your GPU to process before Windows causes the reset. To do this you need to change the TDR delay.

I have two suggestion on how to do this you can do it manually yourself OR you can download a tool that will do it for you. However, I haven't used the tool that much myself but it does appear to work. (Use at your own risk)

avatar image Ed Burgess ♦♦ STAFF Jan 19 '17 at 07:08 PM

Method 1 (manually):

  • Go to the this link: https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx

  • There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time

  • To open your registry open your start menu and type "run" once the window is open type "regedit" and hit OK

  • Now you should have Registry Editor open this is where you will use the info at the website I just linked.

  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

  • Right click on GraphicsDrivers and go to new> DWORD (32 bit) value

  • You will see a new key appear make sure to name it "TdrDelay"

  • Right click it and select "modify"

  • Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base

  • Hit okay and restart your system

Method 2

avatar image TheSlowLourse Jan 19 '17 at 07:41 PM

Thank you very much for taking time with this and making a ticket, will try out those methods when i have time and update This section with info.

avatar image BloomandBlight Jan 20 '17 at 11:22 AM

Just tried method 2, setting TdrDelay to 10. At first it seemed more stable - I was able to change the mesh on a BP without a crash. But lingering on the settings eventually resulted in the usual crash (albeit with a longer period during which my comp was frozen).

At any rate, thanks Ed for continuing to look into this issue.

avatar image TheSlowLourse Jan 21 '17 at 11:54 PM

I also tried the methods above and had similar results to that of BloomandBlight

I did find some possible work-arounds that may help out, at this ue4 forum post a user by the handle IronicParadox suggested turning off Real-Time Thumbnails this worked pretty well for me and reduced the crashes significantly. Another possible workaround is to try out the -opengl4 launch option this one also reduced issues but some materials did not work in this mode.

avatar image Ed Burgess ♦♦ STAFF Jan 23 '17 at 02:34 PM

Thank you for the info! I'll see if this helps other users. I'll also update this post once we have more information.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question