x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

linux dedicated server binding 127.0.0.1

Hello !

I have a little problem like this guy (Unreal Forum) but he has no answer ...

TL;DR : My windows client can join my windows dedicated server but can't join my linux dedicated server ...


My configs :

  • I test my game with development build and cook for all, compiled in the same row with Unreal Launcher,

  • I have my computer (Win7 64bits) to run the windows client,

  • I have a virtual machine (Win7 64bits) to run the windows dedicated server,

  • And another virtual machine (CentOS 7 x86_64) to run the linux dedicated server.


With Windows Server :

My windows server listen the 192.168.0.15:7777 which is reserved in the dhcp , and the connection between the two windows is ok (and really fast thanks to the local network !)


With Linux Server :

My linux server listen the 127.0.0.1:7777 while the enp0s3 interface has the 192.168.0.16 (reserved in the dhcp too). So the connection don't want to establish ...

The server is launched by "WTWServer" user with full rights on the game folder, it's waiting for a player like the Win7 but on a bad IP. I tried disabling firewall, enabling it with a rule in udp 7777 ... Even the "open 192.168.0.16:7777" stuck and fails after 20 secs.


Of course IP of the VM where checked with "ipconfig/ifconfig" and all VM have the right IP ...

If you have any idea or need more info I can add/try !

Have a nice day !

mdonge

Product Version: UE 4.14
Tags:
more ▼

asked Jan 06 '17 at 10:03 PM in Using UE4

avatar image

mdonge
830 31 12 37

avatar image mdonge Jan 07 '17 at 08:46 PM

I found a workaround ... I forwarded 192.168.0.16:7777 to 127.0.0.1:7777 ... I hope there is a real answer !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question