x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging fails with 103 error code (x86)

Hi!

I have a project that i wanted to make a x86 build from it, but it's giving me a 103 error code and it say's that i should build it with my IDE. I have made succesful builds in x86 about a week ago, but now it gives me this error. Also i have attached the entire log of when it's creating a x86 build.

How can be this solved?

Thanks in advance for any help.

Build Log x86

Product Version: UE 4.13
Tags:
x86 log.txt (628.1 kB)
more ▼

asked Jan 06 '17 at 08:49 PM in Packaging & Deployment

avatar image

Balint3DDesign
42 8 14 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Balint3DDesign,

Please delete your Intermediate and Saved folders from your project folder and try to package again. If you run into "UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game " again, please try the following suggestions:

  • If your project is a Blueprint only project, please add a blank code class to get the source files generated for the project as this will be required for cooking when working from a source build.

  • If you have code in your project, open the .sln file for the project in Visual Studio and then build your game project for either the Development (not Development Editor) or Shipping configuration with the platform set to Win64. The one you need to build is determined by how you plan to package your game.

Let me know if you've resolved the issue or not. :)

more ▼

answered Jan 09 '17 at 06:50 PM

avatar image Balint3DDesign Jan 09 '17 at 09:33 PM

Hi, Samantha!

Thanks for the help, i have deleted the Intermediate and Saved folders and added a blank code class to the project and now it shows another error "Program.Main: AutomationTool exiting with ExitCode=5 (5)".

I have tried to make a build with Visual Studio but, it gives me some errors then it freezed and crashed the program.

I don't know if this helps but, i'm using the launcher version 4.13 of the engine not a customized or source version of it.

Also, here is the new log with the error within it.

Log x86

log x86.txt (7.2 kB)
avatar image Samantha Sutton ♦♦ STAFF Jan 10 '17 at 03:58 PM
 ERROR: Windows SDK v7.1A must be installed in order to build this target.

According to the error, you do not have the SDK v7.1A installed on your computer. You're likely going to need to install it but I did find Microsoft Documentation explaining an issue with 7.1A which will hopefully help in your instance.

avatar image Balint3DDesign Jan 13 '17 at 11:46 AM

Thanks for the help, Samantha!

That SDK was already installed on my computer, it was build into "Visual C++ 2010 Redistributables".

I found it odd that it's installed but UE4 didn't recognized it. This particular error were only produced by this project.

So, i opened some older ones which were using the same 4.13 engine version and they made successfully x86 & x64 builds.

Than, i thought that some of the project settings had gone crazy.

I have made a blank blueprint project and migrated the files to it, after that i have changed every project settings by hand then it made working builds in x86 & x64 too without any error or warning.

So, now it works as it should.

avatar image Samantha Sutton ♦♦ STAFF Jan 13 '17 at 08:35 PM

I'm glad that you were able to resolve this issue. Please let us know if you have any further questions or concerns. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question