x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

LogCookDisplay: Forcing save package because was already requeued once

okay, so i have gotten a demo for my game finished and started packaging it, after about 30 minutes, unreal hangs on it's package and the console is stuck on this command:

LogCookisplay: Forcing save package C:/Users/Mikequeen123/Documents/Unreal Projects/FNS_2 4.14/Content/Characters/UnscrappedFreddy/Endo1.uasset because was already requeued once

i decided to delete this material to see if it was only a problem in the material, but the error moves to another material referenced by the same character. just this morning, i decided to delete the character and all materials that he referenced and the error moved to another material for a prop.

as i never got this error before while packaging, i really don't know what this bug means and the only fix to it that i found so far didn't work. does anyone know what this error means and how to get past it?

Product Version: UE 4.14
Tags:
more ▼

asked Jan 07 '17 at 05:42 PM in Packaging & Deployment

avatar image

Mikequeen123
6 2 2 3

avatar image Mikequeen123 Jul 17 '17 at 07:36 PM

as i have tried and failed many times to get this problem away, i had decided to stop and remake the whole thing from scratch. using completely new models and textures, i had made sure it was updated to the latest (at the time) of 4.14 and started working on it. once i got the first AI character in, i decided to package the game to see if it works and i had somehow gotten the same error. i had tried my best to try to fix this, using the other fixes from this page, but nothing seemed to have changed and whenever i delete the asset it's referencing, it moves to another one. the longer i am getting this error, the more i feel it's not the engine, but really how my current computer's specs are slightly under minimum requirements.

avatar image Mikequeen123 Jan 20 '18 at 11:56 AM

I have recently bought a newer (And much better) computer. After installing unreal engine and trying it out on the saves, they seemed to have packaged without any problems. It still got the code, but it never stuck on it. Only stayed there for a minute or two.

avatar image darkangel1335 Jan 22 '18 at 04:08 AM

can you tell me the old pc spec s? i have the same problem

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Hi Mikequeen,

There are a few trouble shooting steps to follow initially when having packaging issues:

1. Delete The following folders and then try repackaging

  • Intermediate

  • Saved

  • Config (deleting this folder will result in having to re-enter all values for your Editor and Project Settings. So make a copy somewhere safe! Removing this file is optional and a last resort)

2. Disable Plugins

3. Another thing you can do is to clear up all redirectors. To do this right click your content folder and select "Fix Up Redirectors in Folder"

NEXT Please provide the Log file by clearing your Ouput Log, package your project, then Cut and Paste from the newly generated Output Log into a text document and post.

Thanks,

Ed Burgess

more ▼

answered Jan 11 '17 at 10:17 PM

avatar image Mikequeen123 Jan 12 '17 at 01:17 AM

i have tried deleting those folders about 10 times already, i already have plugins disables, and i have fixed up redirectors a few times by now. none have seemed to help yet.

avatar image Mikequeen123 Jan 14 '17 at 02:35 AM

log.txt

well, i have tried the first step again and this is what i got.

log.txt (226.2 kB)
avatar image Ed Burgess ♦♦ STAFF Jan 25 '17 at 07:14 PM

Hmmm, that's odd there was another user with the same issue here: https://answers.unrealengine.com/questions/542285/forcing-save-package.html?sort=oldest

His problem was solved by deleting everything but the content folder and .uproject then pasting back in the config folder.

If that doesn't help I would do the following:

  • Make a copy of your entire project

  • In the copied project start removing all of the problem assets if there are too many try removing half of your project entirely. Then see if it is able to package.

  • If you can package successfully your issue is in the half that was deleted so next time around delete the content that is okay so you are left with the bad half and the delete half of that.

  • Repeat this process until you have a good idea of where all the problem assets live.

  • Once you have narrowed down the problem assets see if you can reimport them or replace them with fresh copies.

  • If that still doesn't resolve the issue please try to provide a small sample project that is unable to package that way I can see if I can lock down the problem.

I can provide an email in a private comment to send the project if you are concerned with privacy.

avatar image Mikequeen123 Feb 02 '17 at 06:37 PM

this was the save of the demo of the game that i was going to release. [Edit] Link removed for user privacy.

avatar image Ed Burgess ♦♦ STAFF Feb 02 '17 at 08:44 PM

Hey Mike the issue is coming from your Unscrapped Freddy asset. The skeletal mesh just needs to have the materials reassigned to them. I went down the list of all the material elements and cleared them then reassigned the materials. I guess a reference got messed up in the editor but doing that fixed the issue on my end.

avatar image Mikequeen123 Feb 02 '17 at 11:26 PM

Either something is wrong on my end or unreal just plain hates me. It's not working for some reason.

avatar image Ed Burgess ♦♦ STAFF Feb 03 '17 at 05:00 PM

hmmmm, well that must mean something else I did while testing must have fixed the issue and I mistakenly thought editing the freddy mesh was the cause.

Here is everything I did, while testing various things.

Keep in mind I was packaging nearly every time I did something to see if the message would go away. I also fixed up redirectors in my content folder and in the engine content folder just in case.

  • Verified the engine (do this by going to the launcher and click the drop down arrow next to "launch")

  • Deleted the Freddy asset and replaced its reference to a different skel mesh (epic mannequin). Thats when I stoped getting the forcing saved message.

  • Reopened the copy of the project so Freddy was back, opened all of the materials assigned to him one by one and compiled then saved.

  • Unassigned all the materials from freddy. (this is again when I stopped getting the "forcing save" when packaging)

  • Reassigned a few materials and tested packaging with groups of 3-4 at a time and I never got the message to come back.

(comments are locked)
10|2000 characters needed characters left

I'm having the same problem, forcing save package, and it just hangs there, entire night doing that.

Deleted everything from saved, intermediate, build, nothing helps, I'm just deleting those 1 by 1 until I can finally package but it's been very inconvenient... issue is happening on 4.14

more ▼

answered Feb 01 '17 at 06:13 PM

avatar image

Esteves
91 5 9 16

avatar image Esteves Feb 01 '17 at 06:17 PM

and just hit a snag from my deleting everything idea: Forcing save package ../../../Engine/Content/EditorMeshes/ColorCalibrator/M_GreyBall.uasset because was already requeued once

Now it's editor materials... what can we do to fix this?

avatar image Ed Burgess ♦♦ STAFF Feb 02 '17 at 06:30 PM

Hi Esteves,

Would you mind sending me a small sample project that reproduces the issue? You can PM me over the forums here is my page: https://forums.unrealengine.com/member.php?484739-Ed-Burgess

Thanks,

Ed

avatar image Ed Burgess ♦♦ STAFF Feb 02 '17 at 08:45 PM

Hey Esteves, see my reply above to Mikequeen123.

(comments are locked)
10|2000 characters needed characters left

I had the same problem yesterday. I fixed it by reinstalling all Microsoft Visual C++ Redistributable except Microsoft Visual C++ 2017 Redistributable. Then I packaged my project successfully. I think Microsoft Visual C++ 2017 Redistributable caused the problem.

more ▼

answered Jan 20 '18 at 11:10 AM

avatar image

UG_Official
23 4 4 8

(comments are locked)
10|2000 characters needed characters left

Cook using command line instead of Unreal Editor GUI. For example: UE4Editor-Cmd.exe YourGameName -run=cook -targetplatform=WindowsNoEditor -map=MenuScene

More detail about cooking is in the documenation https://docs.unrealengine.com/en-us/Engine/Deployment/Cooking

more ▼

answered Oct 01 '18 at 01:29 PM

avatar image

PhungDinhThang
15 1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question