x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.14.x OpenGL ES Deferred Reflection Broken

hi, i've been using nvidia shield to do archviz in some time now since UE 4.9 i'm using source build from github.

until UE 4.12 i have no problem packaging my projects into shield with OpenGL ES31 + AEP everything just works.

however since UE 4.13 Epic separate OpenGL ES31 and AEP and rename it into OpenGL ES Deferred, i couldn't even build UE 4.13 with OpenGL ES Deferred, i always got error in MS Visual Studio 2015. so i keep using UE 4.12 for a while.

when UE 4.14 released i tried to build the engine again hoping OpenGL ES Deferred is working. the engine did completed the build process, and i'm happy using it. since it got many nice new features like automated LOD generation which is helping so much with deploying into Nvidia Shield. but then this reflection problem came.

so far i tried to build from source from 4.14.0-4.14.2 and the problem still there.

i attached screenshots from my shield: alt text

how it should looks like (screenshot from editor): alt text

in shield screenshot all reflection capture didnt work, result is black. i don't know if IES spotlight didn't show up in other two light is part of them problem. it was working fine in UE 4.9.x-4.12.x so i'm wondering if this is new bug

by the way if i tried packaging with OpenGL ES3.1 alone without OpenGL ES Deferred, reflection is working, but graphics quality is like OpenGL ES2 with improvement just more texture slot, and that's not for me.

I need OpenGL ES Deferred for high quality rendering with temporal anti aliasing, post processing, deferred decal and such for my archviz.

so if anyone can help me it will be very helpfull. thanks in advance.

Step to reproduce: 1. using realistic rendering example (tested in other example like Reflection Subway and even in new blank project with simple reflective floor and some primitive objects and reflection capture) 2. build UE 4.14.2 from github with changes: bBuildForESDeferred=true 3. make sure BuildForESDeferred is ticked in project setting 4. using android-21 for NDK API Level (tested with android-19 and android-23 with same result) 5. using Nvidia CodeWorks for Android 1R5 6. package the project using Android_DXT (for tegra) 7. run in device and all reflection is black

Product Version: UE 4.14
Tags:
more ▼

asked Jan 09 '17 at 06:54 PM in Packaging & Deployment

avatar image

ruminaire
1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question