x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Suddenly "Failed to connect to bundle"

Hi,

I have an ios project in unreal engine(Using windows 10). Launching worked fine, I could deploy my game on my iPhone5 without any problem. I just had an issue with an in-game video: it didn't play on my phone, so I guessed it must be because I have to put the video file in the content/movies folder of my project, so I did. Since then I cannot launch my game on my phone, I get the "Failed to connect to bundle com.xxx.xxx" message in the log.

This is rather strange, that copying a video file in the content folder, gives me an error message related to my bundle.

How could I fix this issue?

Product Version: UE 4.13
Tags:
more ▼

asked Jan 09 '17 at 11:49 PM in Packaging & Deployment

avatar image

AronD
88 6 13 21

avatar image AndrewHurley Jan 10 '17 at 04:16 PM

Hey AronD,

Have you made sure to replace the file path within the Media Source asset so it is pointing/referencing your newly updated Content/Movies directory?

What type of video are you using? i.e. format

It could be looking for your old file path for the movie, and fails at that point during the packaging process.

Let me know if you have additional questions.

Thank you,

Andrew Hurley

avatar image AronD Jan 11 '17 at 11:34 AM

Hey Andrew, Yes, the media source pointing to the right path, and I'm using h.264 mp4, custom resolution.

avatar image AndrewHurley Jan 11 '17 at 04:06 PM

Can you provide me with some steps or a test project so I can reproduce this on my end?

Can you also provide me with your 'dxdiag' so I can test on a machine with similar specs to reduce environment differences/variables.

Thanks,

Andrew H.

avatar image AronD Jan 19 '17 at 11:33 PM

Hey, sorry for the late reply, my pc just screwed up totally in the last few days, and had to fix it(there was an overheating, and had to clear the cmos). But, now it's fixed, and I just played around with the project, so I can figure out what was going on. Basically, I created in an empty level a new UI Widget. I've put an image in it that fills the screen, and have set the brush texture to the video texture, and created an Open Source blueprint, to open the right video texture for the associated media player(on construct). Then I launched the project on my iPhone5, it was successful, but the video didn't play, so I checked the Media Player, and it wrote "none" to the video screen. Ok, I double clicked the media source file in the lower window, the video loaded, played. I tested in a new player window with 'play', and it worked. Then I launched again on IOS, and got the error "Couldn't connect to bundle com.xxx.xxx".

Machine specs: Iphone5 with ios 10 Pc: intel i5 3.2ghz 8gb ram 2gb video card

avatar image AndrewHurley Jan 20 '17 at 03:52 PM

Apologies, but it is hard to understand from your comment if the issue is still occurring or you managed to fix it. It sounds like you are being thorough and providing the steps you took to reach the incorrect state.

If the issue is considered resolved, you can select the check mark next to my answer, and it will accept it as the solution.

If you have additional questions please let me know.

Cheers,

Andrew Hurley

avatar image AronD Jan 21 '17 at 01:59 AM

Sorry for not being clear about that. Actually it still doesn't work. As you can see from my previous comment, when there is no media source selected, in the media player, the game launches, but the video doesn't play. When I double click the source video in the list of possible sources(that are already loaded, and connected to the media player, but not selected, as the actual source), so when I double click the desired source in the media player, then I get the error "failed to connect to bundle", and the game doesn't launch at all on my ios device.

avatar image AndrewHurley Jan 27 '17 at 02:57 PM

Hey again AronD,

Thanks for your patience. So I do somewhat understand now what you are saying, and the more I think about your setup the more I am led to believe it is how you are calling your Media Player to open the source within Construct of your Widget itself. I would try adding a delay before calling it to play, and moving it out of Construct.

In essence, even though your media file is loaded in your project, it might take a second for it to play when called to do so, and if you have a widget that is instantly being called to load when the level loads followed by your media source to play, I could forsee an issue with playback. So like I mentioned earlier, try adding a slight delay or moving it out of construct and controlling the playback a different way.

Let me know if you have further questions.

Thanks,

Andrew Hurley

avatar image AronD Jan 27 '17 at 04:35 PM

Hi Andrew,

Since then I realized , that the "Failed to connect to bundle" error message comes in randomly after a few launches on the device. This can be solved by restarting my device. That's Ok.

BUT. The video still DOES NOT play. I've put a delay right after the construct node, but it still does not play. On the PC, the video plays well, but NOT on the iPhone. So. it could be some video codec compatibility problem, or something like that. Do you have any idea?

Thank you.

avatar image AndrewHurley Jan 27 '17 at 07:42 PM

Yes, check to make sure your video is compatible with your device. You can more than likely find multiple lists of this via google search.

As I mentioned, try moving it out of construct, and making sure your movie file is in the Content/Movies directory, and the file has been copied to that directory. Be sure any references are pointing to that directory as well, and not where it was originally imported from.

Cheers,

Andrew Hurley

avatar image AronD Jan 31 '17 at 10:06 AM

Okay: 1. Video is compatible with device 2. Moved it out of construct 3. Movie file is in the Content/Movies directory, references pointing to the right file.

Still doesn't work on device.

avatar image AndrewHurley Jan 31 '17 at 05:19 PM

So at this point, would you be able to recreate your simple setup and get the issue to occur so you can share with me the project in order for me to reproduce the issue on my end?

I just read that if your video uses QuickTime's AVC1 encoder. Please be aware that this may not work on all PCs if QuickTime isn't installed. A more compatible encoder would be H.264.

Let me know if you have additional questions.

Thanks,

Andrew Hurley

avatar image AronD Feb 07 '17 at 08:35 AM

Hi Andrew, The issue hasn't been resolved, I just had to take care of some other things, that took time. So, I'd like to send you the whole project with a text document that cleanly explains, where you can find the problematic things quickly and easily. It's a small mobile game that's about to be released. I don't want to post here a public dropbox link, as it is a fully developed project, but I trust the staff at Epic games, so if you would be kind and give an email where I can send the project, that would be great! Thank you.

avatar image AndrewHurley Feb 07 '17 at 04:21 PM

That would be fine. We take users project very seriously and will never share anything that is not permitted by the user providing said project. What you can do is send me a link to the project to download via a PM on the Forums. My name is the same as it is seen here on the AnswerHub.

Thanks for taking the time to gather the necessary things so we can further assist you.

Andrew H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey AronD,

Apologies for taking some time to return I have been. The ultimate answer here is that this is not really a bug and you are just encountering some of the limitations of the media framework for that specific engine release. We are going to be reworking the system again to improve further upon its compatibility and playback of various media files.

We have done some of this refactoring already for 4.15, but with the release of 4.16 we also plan to do some heavy refactoring so issues like the one you are experiencing will be potentially resolved.

Let me know if you have further questions.

Thank you,

Andrew H.

more ▼

answered Mar 06 '17 at 08:01 PM

avatar image AronD Mar 07 '17 at 05:15 AM

Oh, ok, thanks for taking the time. Guess I'll have to wait for the next UE release.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question