x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why might my AI not be moving using NavMesh?

I have a simple A.I set up using a NavMesh. When I use the Example Map it works fine. However, on a different map, I am using a landscape. I can use the same enemy bp and it does not move at all. It does all of its other function that I have set up but it will not move. Any ideas?

Product Version: Not Selected
Tags:
more ▼

asked Jun 10 '14 at 03:18 PM in Blueprint Scripting

avatar image

VigeoJames
111 34 28 42

avatar image DJMidKnight Jun 10 '14 at 03:57 PM

Do you have your Navmesh visible (push P for shortcut)? If so what does it look like? if you are using the landscape to build on you may have to look at your navmesh settings.

I tried it a while back and remember you have to tweak it some to work properly.

avatar image VigeoJames Jun 10 '14 at 04:17 PM

Yeah the the ground is green. I have it setup the same way as the Example map and it works there. I also tried creating a flat box geometry and put navbounds on there and it still didnt work. So I dont think its the landscape. But without changing anything it works fine on the Example map.

avatar image DJMidKnight Jun 10 '14 at 04:44 PM

if possible can you post up a screen shot ?

avatar image VigeoJames Jun 10 '14 at 05:01 PM

alt text

ai.jpg (206.6 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

RIght now in 4.2 simple move to is bugged and don't work.

more ▼

answered Jun 10 '14 at 05:10 PM

avatar image

fanzypantz
377 31 42 63

avatar image Wes Bunn ♦♦ STAFF Jun 10 '14 at 09:08 PM

Hello,

Would you be able to post an image of your BP setup so that we may take a look?

-W

avatar image VigeoJames Jun 11 '14 at 03:45 AM

alt text This is the setup I am using to get the AI to chase the character. I have found that on the landscape, the AI falls through the floor, then moves towards me, only reason I know he is moving without seeing him is that I have him shooting a projectile at me. So I guess it is working to some degree, but now I have to figure out why the actor is falling through the landscape.

ai.png (87.9 kB)
avatar image fanzypantz Jun 11 '14 at 06:04 PM

you might just need to set the capsule collision to work with the terrain, and Simple Move to Actor is bugged in 4.2 and will not work until they release 4.2.1 with the fix(confirmed fixed)

avatar image VigeoJames Jun 14 '14 at 10:09 PM

Thanks for the information. I shall wait for the update!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question