x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Error Cooking Android Game 4.14

I have tried lots of times and still end up with the same error 'Unknown Cook Failure' and highlighted parts that may seem to be the error (the failed to find tutorial files is also weird, how to solve?).

Running 4.14 github version and cooking for android ETC2

I have tried with a blank project and it also gave me the same error.

cook log: http://pastebin.com/kN3MFyp2

Some highlights

UATHelper: Packaging (Android (ETC2)): UE4Editor-Cmd: [2017.01.11-09.36.00:634][ 0]LogTexture:Display: Building textures: WhiteSquareTexture (AutoETC2) UATHelper: Packaging (Android (ETC2)): UE4Editor-Cmd: [2017.01.11-09.36.00:640][ 0]LogTextureCompressor:Warning: Failed to find compressor for texture format 'AutoETC2'. UATHelper: Packaging (Android (ETC2)): UE4Editor-Cmd: [2017.01.11-09.36.00:650][ 0]LogTexture:Warning: Failed to build AutoETC2 derived data for /Engine/EngineResources/WhiteSquareTexture.WhiteSquareTexture

and

UATHelper: Packaging (Android (ETC2)): UE4Editor-Cmd: [2017.01.11-09.36.27:534][ 0]LogWindows:Error: Assertion failed: Mips.Num() > 0 [File:F:\411slnue4\UnrealEngine\Engine\Source\Runtime\Engine\Private\TextureDerivedData.cpp] [Line: 1233]

Thanks

Additional Edit: Using UE4.14 Github Version, Android CodeWorks 1R5, Visual Studio 2015

Product Version: UE 4.14
Tags:
more ▼

asked Jan 11 '17 at 09:53 AM in Packaging & Deployment

avatar image

inferno121
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Alright, i have fixed the issue 'Failed to find compressor for x'. After downloading the android SDK i just had to rebuild the ue4 engine, which gives the compressors.

more ▼

answered Jan 12 '17 at 03:19 AM

avatar image

inferno121
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

HI inferno,

Before all the error messages, there are a bunch of 'Can't find file /Game/PuzzleBP/PuzzleOverview' and 'Failed to Load' errors.

Maybe if you deleted those files from your project and your project still refers to some of the assets from the deleted file ?

Thanks d0d0

more ▼

answered Jan 11 '17 at 06:25 PM

avatar image

d0d0
477 16 8 18

avatar image inferno121 Jan 12 '17 at 02:08 AM

Hi, those files were the tutorial files that were generated when using the puzzle blueprint template, I have deleted them and used 'Fix up Redirectors' but the error is still there, and the thing that is even more confusing is that when i am packaging a blank project it still shows the can't find file /game/puzzlebp/puzzleoverview which is in a totally different project..

However, these aside I would like to know why i am getting the main error Assertion failed: Mips.Num() > 0 both in my project and a blank project.

Thanks

avatar image inferno121 Jan 12 '17 at 02:23 AM

I have fixed the 'Can't Find File' errors now, only left the Assertion failed: Mips.Num() > 0 which i can't solve.

avatar image Sachamora Feb 18 '17 at 10:13 AM

have same problem. help please!

avatar image NaikSoftware Feb 16 '17 at 09:05 AM

Also got same error on Ubuntu.. Im using github release branch UE4, official android sdk (API 19) + latest android ndk (not strange tool codeworks).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question