x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging with Visual Studio 2017 RC.

Hi. What I have:

  • UE 4.14.3

  • VS Community 2017 RC 15.0.26020.0

  • Windows 7

There are 2 issues:

  • When I'm trying to package a (Windows) 64-bit build, I have a corecrt.h error just like here. I understand, that I need to look at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Kits\Installed Roots for KitsRoot registry key. But it's pointing to C:\Program Files\Windows Kits\10 and C:\Program Files\Windows Kits\8.1 by default.

alt text

If I change it to Program Files (x86), then everything builds fine. Not sure this is a great solution, because Visual Stuidio Installer doesn't like it. More like a temporary workaround.

  • Unfortunately I can't package a (Windows) 32-bit build at all. It's clearly looking for Visual C++ Build Tools 2015, which I do not have.

alt text

This advice doesn't help, because I have "C++ support" installed and "64-bit build" works.

alt text

No ERROR: No 32-bit compiler toolchain found in logs btw. Just this:

 UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: Performing full C++ include scan (no include cache file)
 UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: Performing 12 actions (4 in parallel)
 UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: E:\Studio\Program\Engines\Epic Games\Unreal Projects\Test\Plugins\AdvancedSessions\Binaries\Win32\UE4-AdvancedSessions.lib
 UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: Total build time: 18,90 seconds
 UATHelper: Packaging (Windows (32-bit)): CommandUtils.Run: Run: Took 19,1030926s to run UnrealBuildTool.exe, ExitCode=5
 UATHelper: Packaging (Windows (32-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): E:\Studio\Program\Engines\Epic Games\4.14\Engine\Binaries\DotNET\UnrealBuildTool.exe Test Win32 Development -Project="E:\Studio\Program\Engines\Epic Games\Unreal Projects\Test\Test.uproject"  "E:\Studio\Program\Engines\Epic Games\Unreal Projects\Test\Test.uproject"  -remoteini="E:\Studio\Program\Engines\Epic Games\Unreal Projects\Test" -noxge -NoHotReload -ignorejunk. See logfile for details: 'UnrealBuildTool-2017.01.12-01.57.09.txt' 
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.CommandUtils.RunAndLog(CommandEnvironment Env, String App, String CommandLine, String LogName, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary`2 EnvVars)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, FileReference Project, String Target, String Platform, String Config, String AdditionalArgs, String LogName, Dictionary`2 EnvVars)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.UE4Build.BuildWithUBT(String TargetName, UnrealTargetPlatform TargetPlatform, String Config, FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary`2 EnvVars)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary`2 PlatformEnvVars, Nullable`1 InChangelistNumberOverride, Dictio
 nary`2 InTargetToManifest)
 UATHelper: Packaging (Windows (32-bit)):    at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
 UATHelper: Packaging (Windows (32-bit)):    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
 UATHelper: Packaging (Windows (32-bit)):    at BuildCookRun.ExecuteBuild()
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.BuildCommand.Execute()
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.Automation.Process(String[] Arguments)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.Program.MainProc(Object Param)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
 UATHelper: Packaging (Windows (32-bit)):    at AutomationTool.Program.Main()
 UATHelper: Packaging (Windows (32-bit)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
 UATHelper: Packaging (Windows (32-bit)): BUILD FAILED

Any others thoughts instead of "just install VS2015"? Or should I wait for a patch?

Thanks.

Product Version: UE 4.14
Tags:
2222.jpg (83.4 kB)
111.png (23.8 kB)
more ▼

asked Jan 11 '17 at 07:11 PM in Packaging & Deployment

avatar image

Barnacle-Rus
1 1 3 4

avatar image Matthew J Jan 12 '17 at 04:28 PM

Hello Barnacle-Rus,

Have you selected Visual Studio 2017 as your compiler of choice inside of the Editor Preferences in the engine? This setting can be found under "Source Code".

avatar image Barnacle-Rus Jan 13 '17 at 10:40 AM

Hi, Matthew. Thanks for the advice. Yeah, I tried that. Same result.

Also tried to reinstall VS2017 and make new blank blueprint project.

Then I added C++ Class in Editor. Compiled fine. alt text

But whenever I'm trying to package 32-bit build it fails. alt text

64-bit build works "fine" though (except that "Windows Kits registry path problem"). alt text

1.png (636.5 kB)
2.png (447.7 kB)
3.png (434.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thank you for trying that. I should checked prior to leaving a comment, but it seems that even when using Visual Studio 2017, the 2015 toolchain is still required. You can continue to use 2017 but 2015 will need to be installed as well to do so as we do not officially support 2017 as it has still yet to officially release.

more ▼

answered Jan 13 '17 at 02:53 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question