x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Static lighting not showing up for imported meshes

So I made a custom mesh in blender and imported it to Unreal. The first problem is that the mesh is way too small which is odd because I imported another mesh to blender from Unreal Engine and the size of the two meshes are the same yet imported my second custom mesh to Unreal makes it small. The other problem is the fact that the static lighting isn't showing up on my custom mesh. Other lighting seems to show up but not static lighting. So is there something I have to do in blender to make my static lighting show up in Unreal?

Product Version: UE 4.13
Tags:
more ▼

asked Jan 12 '17 at 01:57 AM in Rendering

avatar image

Brandon236
88 29 40 45

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

To fix the size issue, make sure Blender is set to use 1 cm as its unit size. Then make sure that you apply all scaling modifiers before exporting. I also find the Blender 2.77 and later work much better than previous versions of Blender; especially for skeletal meshes.

In older versions of UE4 I am pretty sure you had to create a second UV layer in Blender before exporting. I have not had that issue since like version 4.6 or so, but you might give it a try.

You might also take a look at this and enable Generate Lightmap UV's and see if that makes a difference:

https://answers.unrealengine.com/questions/24957/auto-generate-uv-lightmap-second-channel.html

more ▼

answered Jan 12 '17 at 02:46 AM

avatar image

Dartanlla
2.6k 62 27 281

avatar image Brandon236 Jan 12 '17 at 04:45 AM

The scaling thing isn't working for me. What exactly do I have to do?

avatar image Dartanlla Jan 12 '17 at 05:20 AM

Starting at 1:20 this video shows how to change the scale in Blender to Metric. Then just scale your Blender objects to the right size in Blender and they will be that exact same size when they import into UE4.

https://www.youtube.com/watch?v=fdXzw225KVU

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question