x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

i updated my project from 4.13 to 4.14.3 and see a huge performance drop

i updated my project from 4.13 to 4.14.3 and see a huge performance drop. also when i build the game and test it it has a huge drop as well. it always gets an error (unknown cooking error) when i try to build it out of 4.13. but it builds just fine with 4.14 but takes a huge performance loss. when i compare the projects from 4.13 to 4.14 in editor there is a performance drop in editor as well. any help would be nice!

thanks!!

Product Version: UE 4.14
Tags:
more ▼

asked Jan 12 '17 at 10:14 AM in Packaging & Deployment

avatar image

randallelliott
20 10 5 6

avatar image Samantha Sutton ♦♦ STAFF Jan 12 '17 at 10:29 PM

Randallelliott,

Could you please upload your output logs if there are any errors, as a .txt file? What platform are you launching your project on? What type of project is it? Do you see this performance drop in regular templates from the engine, such as first person template as well?

Looking forward to hearing back from you, thanks!

avatar image randallelliott Jan 13 '17 at 04:07 AM

i will try to do this tonight. i am new to packaging so i might not be able to figure out where the output logs are saved. i'll ask you if i can't find it. i'm using windows and packaging for windows too. it is a 3d first person shooter project that i put together over xmas break. i have tried cloning the project while opening it with 4.14, i have tried making a blank project and pasting the content folder into the new project in both 4.13 and 4.14 and see the same problem. i did try a test with building a fresh first person template and that one works fine. i did notice that it caps the fps at 62 fps in my projects and the template so i thought this is normal. i used on begin play execute console command t.MaxFPS 120 and they all go back to 120 fps. the problem occurs when i stream levels out and in it freezes for a while and the fps will return to 120 but when my little AI come out fps drops down to 17 or so. in 4.13 the lowest it gets i think was 65. i'll make a few videos to show what its doing. templates tests work fine so i'm wondering if i have done something wrong. this is a little spoof project where i migrated most of the stuff from my main project and built it into a small game. it is done in blueprints. is it ok to migragte stuff like i have done? when i try to build the game in 4.13 i think i see alot of errors. ill try to upload both output logs. sorry i wrote such a long post...thank you!!

avatar image randallelliott Jan 13 '17 at 07:06 AM
avatar image randallelliott Jan 13 '17 at 07:09 AM

the 4.13 message log is too big it won't let me upload it

avatar image randallelliott Jan 13 '17 at 07:11 AM

UATHelper: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params) UATHelper: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] Arguments) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.Main() UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure) UATHelper: Packaging (Windows (64-bit)): BUILD FAILED PackagingResults:Error: Error Unknown Cook Failure

avatar image randallelliott Jan 13 '17 at 07:12 AM

here is the end of the 4.13 output log

avatar image Samantha Sutton ♦♦ STAFF Jan 17 '17 at 03:43 PM

I need the full log as a .txt file. You should be able to add it to a word document, save it and then upload it as you did before with the 4.14 output logs.

Looking at your 4.14 output logs, everything is building successfully. Do you have any print text logs from your game actually running showing the FPS drop or any performance information?

avatar image randallelliott Jan 21 '17 at 05:19 AM

i can't upload the 4.13 log to this web site. the file is too big. can i email it to you? yes i'm using stat unit and stat FPS to watch the performance. I tried to make some videos but i have to put the screen capture resulotion to 1280 x 720 or larger in order to see the numbers on the screen but then the frame rate drops so much from haveing the screen capture software running at the same time it doesn't work out to try to show

avatar image Samantha Sutton ♦♦ STAFF Jan 26 '17 at 09:40 PM

When you post on your question multiple times, it makes it seem as though it doesn't need to be responded to as quickly. So when more pressing matters come up, those with multiple responses are then delayed. Please keep that in mind, in the future.

You can upload your 4.13 log on Google Drive or Dropbox and provide the link to me through here. That would be perfectly fine. Just make sure that the link is set to share.

Looking forward to seeing your logs!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Randallelliott,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Jan 20 '17 at 07:52 PM

avatar image randallelliott Jan 21 '17 at 05:21 AM

yes i still have the problem

avatar image randallelliott Jan 23 '17 at 07:47 AM

hello?....

avatar image randallelliott Jan 27 '17 at 03:31 PM

actually it seems that the problem was that unknown cooking error came from corrupt blueprint nodes that got posibly got corrupted by migrating stuff over from a project that started in 4.9 then was updated to 4.10,4.11,4.12,4.13. then migrated to 4.14. after deleting all the migrated files and just rebuilding everything in 4.13 and then it works. it SEEMS like updating the project then migrating old stuff MIGHT not be a good idea

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question