x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simple anroid game won't run on device

Hi guys, I am just making my 1st android project in UE4,but when i deploy it on my device all I see is the splash screen "Your splash screen goes here"(I am guessing because i didn't put any image or text for that) and the UE logo in the corner and the game doesn't start. I am wondering if the problem is in my deployment or in my device since the device is old and cheap. The device is: sm-g313H , single core 1.2GHz more about the device: http://www.samsung.com/nz/consumer/mobile-devices/smartphones/others/SM-G313HZKA2DX/ Thank"s for any help!

Product Version: UE 4.14
Tags:
more ▼

asked Jan 12 '17 at 10:21 AM in Packaging & Deployment

avatar image

Krum
42 2 6 9

avatar image Adnoh Jan 12 '17 at 10:46 AM

some screenshots? is it working in PIE or mobile preview mode?

avatar image Krum Jan 12 '17 at 01:35 PM

It is working fine in PIE and mobile preview the only difference is that in Mobile Preview the lighting looks different. I am thinking that the problem is in my phone, because as i said in the 1st post it is old and cheap, but as you can see from the screenshots my so called game is not much of a thing. Here are the screenshots: PIE: alt text

and the Mobile Preview: alt text

I"ve tried to run the Tappy Chicken from the App store and had the same problem, tried 2D Side Scroller template and had the same issue - splash screen with "your splash screen goes here" and the unreal engine logo in the corner.

avatar image Samantha Sutton ♦♦ STAFF Jan 12 '17 at 09:48 PM

Krum,

In order to better assist you, I'm going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86

  • Open up Monitor.exe

  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

Thank you!

avatar image Krum Jan 12 '17 at 11:08 PM

Hi Samantha, thank"s for the help. Ok, so i opened Monitor.exe and the log window immediately started exploding with content. Since I've never done that before I don't know what exactly you need and i filtered the "warn", which are the warnings I guess? When i tried to start my so called game on the device I saw that in the log. alt text

Here is the .log file.(warnings[warn] only, if you want I will make new one, with everything.) link text

log.txt (63.5 kB)
img.jpg (619.4 kB)
avatar image Samantha Sutton ♦♦ STAFF Jan 17 '17 at 05:21 PM

I do not see any UE4 information in the logs provided. Did you copy and paste all of the logs from Monitor.bat while the game was opening and shutting down?

avatar image Krum Jan 18 '17 at 05:18 PM

What about now? link text

log.txt (522.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Jan 18 '17 at 07:38 PM

Your logs are unfortunately not giving us enough information to determine the issue. Could you please start with a very simple project (perhaps a Blank project with scalable 2d/3d instead of Max, make sure MobileHDR is off) and see if that works on your mobile device, or if we can obtain more logs.

Thank you!

avatar image Krum Jan 19 '17 at 05:28 PM

Ok , started new Blank project with 2d/3d tried to launch it on the device, the log: link text

log.txt (1.1 MB)
avatar image Samantha Sutton ♦♦ STAFF Jan 20 '17 at 03:17 PM

Krum,

Do you have an excess amount of unused assets in your project? Please go through your project, remove any assets that you're not using and then delete your Intermediate and Saved folders. After doing that, try to package again and launch onto your Android device. If it crashes again, please collect the logs. I'd like to see if the error changes.

Thank you!

avatar image Krum Jan 20 '17 at 03:40 PM

OK , but in the last log that i gave you (that was the one with the New Blank project, scalable 2d/3d, no starter content) or you want to delete Intermediate and Saved folders from my project? Anyways I will do both later tonight and will post. Thank's

avatar image Samantha Sutton ♦♦ STAFF Jan 20 '17 at 07:29 PM

I gave you that information based on your logs before the blank ones. I've been trying to narrow down what's going on. Do you have another device you can test on?

avatar image Krum Jan 22 '17 at 04:44 PM

These are the logs from my project, they should not be empty now. link text I will try it on another device , because i think the problem is in the device since blank project and Tappy chicken from the play store doesnt work.

log.txt (413.9 kB)
avatar image Samantha Sutton ♦♦ STAFF Jan 24 '17 at 06:43 PM
 01-22 18:39:58.256: I/WindowState(2071): WIN DEATH: Window{42abe7e8 u0 com.naumov.rooms/com.epicgames.ue4.GameActivity}
 01-22 18:39:58.256: W/WindowManager(2071): Force-removing child win Window{42b5a5e8 u0 SurfaceView} from container Window{42abe7e8 u0 com.naumov.rooms/com.epicgames.ue4.GameActivity}
 01-22 18:39:58.296: I/ActivityManager(2071): Process com.sec.android.widgetapp.ap.hero.accuweather (pid 27468) (adj 8) has died.
 01-22 18:39:58.326: W/WindowManager(2071): Failed looking up window
 01-22 18:39:58.326: W/WindowManager(2071): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@4261f798 does not exist
 01-22 18:39:58.326: W/WindowManager(2071):     at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:10132)
 01-22 18:39:58.326: W/WindowManager(2071):     at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:10123)
 01-22 18:39:58.326: W/WindowManager(2071):     at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:1532)
 01-22 18:39:58.326: W/WindowManager(2071):     at android.os.BinderProxy.sendDeathNotice(Binder.java:493)
 01-22 18:39:58.326: W/WindowManager(2071):     at dalvik.system.NativeStart.run(Native Method)
 01-22 18:39:58.326: I/WindowState(2071): WIN DEATH: null

This is what I see when looking at your project. It looks like you're having an issue with your BinderProxy.

  • Is the device as updated as it can go?

  • What type of device was tested on for these logs? That information isn't listed in the logs provided.

It's possible that some of the changes made in Java, or not updated on your device may be due to: Documentation: Android Developers Google Blog

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Krum,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Jan 30 '17 at 03:27 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question