x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes when adding client VR

4.14.2

I keep ACCIDENTALLY hitting the ADD client button because the damn icon looks like the RESUME! It crashes the editor 100% of the time and all unsaved changes are lost.

Not sure if its in general or just VR or just my project but its def a bug as it happens EVERY time I try and add a client (which is unintended).

Product Version: UE 4.14
Tags:
more ▼

asked Jan 13 '17 at 03:39 PM in Bug Reports

avatar image

thankstipscom
654 38 37 70

avatar image Doug E ♦♦ STAFF Jan 13 '17 at 04:01 PM

Hey thankstipscom-

Can you elaborate on what you're doing? I'm not sure I understand what you mean by add client button or resume button. Can you provide a screenshot of the buttons you're referring to.

avatar image thankstipscom Jan 13 '17 at 04:09 PM

Sure thing

alt text

addclientcrash.jpg (36.6 kB)
avatar image Doug E ♦♦ STAFF Jan 13 '17 at 06:31 PM

The screenshot appears to be from a blueprint, what type of blueprint are you using? Additionally, are you using a plugin? I ask because I do not see an Add Client button for any blueprints. Can you explain how you got the Add Client button? Lastly, can you provide the callstack and log files from the crash to provide additional information about the crash itself?

avatar image thankstipscom Jan 13 '17 at 07:02 PM

definitely not something I added. I upgraded from 4.13 to 4.14.2 and it was there, where RESUME used to be. Hence the accidental clicking.

Those buttons are part of the editor. Its when you're testing a game. Press play in editor or VR preview. the issue happens to me when i preview in VR. i dont use the play in editor now

avatar image Doug E ♦♦ STAFF Jan 13 '17 at 07:04 PM

Can you provide the callstack and log files from your crash for additional information.

avatar image thankstipscom Jan 13 '17 at 07:09 PM

I'll try... when it crashes the window is empty so i dont bother sending the report. is the stack trace written to a file somewhere?

avatar image thankstipscom Jan 13 '17 at 07:10 PM

In the meantime can we add a feature request to put the RESUME back over the PLAY button and put this new add client button elsewhere? Also change the icon?

avatar image Doug E ♦♦ STAFF Jan 13 '17 at 07:11 PM

You should find the log files in the Saved/Logs folder inside your project directory. Additionally, when the crash window opens it should include your Machine ID. If you submit the crash report, you can provide the machine ID to help me find your specific crash in our records.

avatar image Doug E ♦♦ STAFF Jan 13 '17 at 07:12 PM

Also, what kind of blueprint are you playing from when you see this? Are you able to reproduce this in a new 4.14 project? If so, please also include the reproduction steps to help me test the issue locally.

avatar image thankstipscom Jan 13 '17 at 07:25 PM

I havent tried in a fresh project. havent had time. Trying to get an update out for a game.

Its a sub class of a character BP. Customized for a VR pawn. The buttons are visible in all bp windows in the editor when playing. In fact i can probably close all windows and it will still show there.

The crash may be BP or class specific but the buttons arent, is my point.

I'll try and reproduce in a fresh project later but the steps are easy. If I load up a second instance of the editor it will mess up the VR headset and cause me headaches. And I'm building right now.

The steps are easy though for me.

Hit play. (VR Preview) Hit "play" again (now the add client button) Freeze.....Crash.

For a fresh project is there a working VR template in unreal yet? If so get a char pawn for VR (im using vive). Play in VR and then do whats above.

I'll see if it crashes later after backing my project up when im not previewing in VR. I also have no default pawn specified. I spawn and possess. Which works fine when i preview.. its adding the second client that fails. Since the button is new and I dont REALLY know what it does I can't really guess at what of my code could cause the issue. My project is pretty huge.

It was more of a cosmetic request here personally though there is an issue obv.

Until we can actually test VR Multiplayer projects in the editor, the add client button isn't useful anyway to me. I more would like it moved and / or at least the icon something different than the resume button we're used to.

avatar image thankstipscom Jan 13 '17 at 07:34 PM

When I play in editor and NOT use VR Preview I am able to open clients. I tried two. Then I closed them... then crash

If I play with VR Preview i cant open a client it simply crashes on press of the button.

Saw this in the output log:

 [2017.01.13-16.57.59:287][492]LogActorComponent: UnregisterComponent: (/Engine/Transient.EditorFloorComp) Not registered. Aborting.

[2017.01.13-16.57.59:287][492]LogActorComponent: UnregisterComponent: (/Engine/Transient.EditorFloorComp) Not registered. Aborting.

submitted this just now:

 MachineId:AAF5E6A445EF5E0EEC90249D0B7A4291
 EpicAccountId:
 
 You do not have any debugging symbols required to display the callstack for this crash.

avatar image Doug E ♦♦ STAFF Jan 20 '17 at 06:18 PM

Hey thankstipscom-

I've not yet been able to reproduce the crash you're seeing. There are a few questions to hopefully help me understand what's happening on your end.

  1. What type of project are you working in (third preson, first person, rolling template, etc)?

  2. If you create a new project, do you see the Add Client button?

  3. In the launcher, can you click the dropdown for the engine version you're using and select Options. Here you can enable "Editor symbols for debugging". This will provide additional information in the crash report window when the crash occurs.

  4. When the crash occurs, also use the submit button at the bottom of the page to allow us to find details about your crash on our end.

avatar image thankstipscom Jan 30 '17 at 04:47 AM

Hey..

  1. Its not a template its a custom VR project. There was no vr template when I started it and I dont think the VR template that exists now is very good anyway so theres no template. But I do have a customized char pawn with movement component as the main controlled pawn.

  2. I do not. Thats strange. No idea where it came from. It wasn't present in 4.13. Like I said, I upgraded to 4.14 and there it was and still is.

  3. I'll do this at some point when I can clear up some space. The SSD is nearly full right now and if im not mistaken it says that takes an additional 13gigs?

  4. I submitted the one up top a few weeks back. The crash doesn't occur anymore because I've trained myself to not press that button by accident anymore. I have other crashes though on 4.14 but unrelated to that button and not frequent enough to be worrisome like in the 4.8 days.

number 2 is an interesting point. I think you guys would be better to understand where the add client button comes from. I didn't modify any part of the UE4 front end. Those buttons are not mine so I have no idea how they got there. All I know is they are unstable for me and the duplicate use of the icon is very bad practice.

EDIT: For point 2: Editor Preferences > Experimental > Allow Late Joining shows or hides the button it seems.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey thankstipscom-

Thank you for pointing out the Allow Late Joining setting. After enabling the setting I was able to reproduce the crash and have reported the issue here: https://issues.unrealengine.com/issue/UE-41266 . You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Cheers

Doug Wilson

more ▼

answered Jan 30 '17 at 04:29 PM

avatar image phisigma Apr 17 '19 at 04:44 PM

By the way, the editor always crashed independent from project. I tested it e. g. with ThirdPerson and FirstPerson template game.

Nevertheless, this is really a great feature. What a shame it isn’t working!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question