x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

IOS packaging fails because UE4 adds extended attributes

During the packaging phase, I get this error:

resource fork, Finder information, or similar detritus not allowed

Which I found out after looking it up, means that extended attributes are added to the .app, and are now not allowed for security reasons.

As a last ditch effort I tried to run xattr to remove all the extended attributes and hope that UE4 doesn't add them back when packaging again, but it did.

How can I prevent UE4 from adding in extended attributes or otherwise prevent it from failing?

Product Version: UE 4.13
Tags:
more ▼

asked Jan 13 '17 at 07:24 PM in Packaging & Deployment

avatar image

Rael5
122 13 18 30

avatar image Steve Hardister ♦♦ STAFF Jan 16 '17 at 08:26 PM

Hi Rael5,

At what point during packaging for iOS are you getting this error? Please list repro steps in order for us to recreate the issue on our end.

Thanks,

Steve H.

avatar image Rael5 Jan 19 '17 at 07:18 PM

I've attached the build log with the error occurring. Currently as a workaround I run xattr -c on the .app file while the build is occurring and it works.

The build is Development. Let me know if you need any other information.

buildlog.txt (1.0 MB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Rael5,

This is the result of Apple changing its security policies as noted in this article https://developer.apple.com/library/content/qa/qa1940/_index.html

UE4 does not modify any extended properties. This is likely due to there being one or more files with extended attributes in your project somewhere, which UE4 will copy to the final app during the build process with whatever attributes they have set intact (except read-only which UE4 may modify, but that is not "extended"). When signing attempts to do so against the staging files, it will fail as you see here.

Can you verify that none of your project's files contain extended attributes? You can identify which files are causing the conflict with '$ xattr -lr path_to_app_bundle'

Cheers,

Jonathan

more ▼

answered Jan 20 '17 at 10:12 PM

avatar image

NaturalPanic STAFF
141 4 5 11

avatar image Rael5 Jan 21 '17 at 04:02 PM

Ah I see, thank you.

avatar image Onildera Mar 15 '17 at 10:01 PM

Come on. This wasn't happening to me until recently. Now, I have to delete the following:

/Binaries/iOS /Build/iOS /Intermediate/iOS /iOS

I haven't narrowed down which folder has the issue, but deleting those gets it to package again. I am needing to do that each and every time I package.

Obviously, it is a file that UE4 or Xcode is creating... Each and every time.

Any clue which one it is?

avatar image Onildera Mar 15 '17 at 10:03 PM

That was supposed to say...

ProjectName/Binaries/iOS ProjectName/Build/iOS ProjectName/Intermediate/iOS ProjectName/iOS

avatar image Onildera Mar 15 '17 at 10:04 PM

Apparently, it doesn't like my carriage returns...

Although the others seem to work...

avatar image BigJohn83 Oct 17 '18 at 05:07 AM

I'm facing this exact issue too. Has anyone had any luck figuring this out? No matter what I do, the .app file gets some xattr added to it, and I just can't get it to launch on the device

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question