x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Runnable thread PoolThread Crash

I'm trying to build out a version of my game for Android, and I'm running into a brick-wall of a problem. I can get builds for Windows just fine, but the Android build also dies with an "Unknown Cook Failure". I've been combing through the Cook text file to see what the problem is, and it seems to die right about here;

 [2017.01.14-06.40.49:504][  0]LogSavePackage: Async saving from memory to 'C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/SpiderTank/TankSkins/Tank-TurretBody01.uasset'
 [2017.01.14-06.40.49:515][  0]LogTemp: Running texturetool with '-i "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/48485e2349476eeb94830eabe4e5205bRGBToPVRIn.pvr" -o "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/48485e2349476eeb94830eabe4e5205bRGBToPVROut.pvr"  -legacypvr -q pvrtcfast -f PVRTC1_4'
 [2017.01.14-06.40.49:525][  0]LogSavePackage:Display: Finished SavePackage C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/SpiderTank/TankSkins/Tank-TurretBody01.uasset
 [2017.01.14-06.40.49:534][  0]LogThreadingWindows:Error: Runnable thread PoolThread 4 crashed.
 [2017.01.14-06.40.49:574][  0]LogWindows:Error: begin: stack for UAT
 [2017.01.14-06.40.49:584][  0]LogWindows:Error: === Critical error: ===
 [2017.01.14-06.40.49:596][  0]LogWindows:Error: 
 [2017.01.14-06.40.49:606][  0]LogWindows:Error: Fatal error!
 [2017.01.14-06.40.49:616][  0]LogWindows:Error: 
 [2017.01.14-06.40.49:626][  0]LogWindows:Error: Unhandled Exception: 0xc06d007e
 [2017.01.14-06.40.49:636][  0]LogWindows:Error: 
 [2017.01.14-06.40.49:646][  0]LogWindows:Error: KERNELBASE.dll
 [2017.01.14-06.40.49:659][  0]LogWindows:Error: UE4Editor-TextureFormatAndroid.dll
 [2017.01.14-06.40.49:666][  0]LogWindows:Error: UE4Editor-TextureFormatAndroid.dll
 [2017.01.14-06.40.49:676][  0]LogWindows:Error: UE4Editor-TextureFormatAndroid.dll
 [2017.01.14-06.40.49:686][  0]LogWindows:Error: UE4Editor-TextureFormatAndroid.dll
 [2017.01.14-06.40.49:696][  0]LogWindows:Error: UE4Editor-TextureCompressor.dll
 [2017.01.14-06.40.49:706][  0]LogWindows:Error: UE4Editor-TextureCompressor.dll
 [2017.01.14-06.40.49:716][  0]LogWindows:Error: UE4Editor-Engine.dll
 [2017.01.14-06.40.49:727][  0]LogWindows:Error: UE4Editor-Engine.dll
 [2017.01.14-06.40.49:737][  0]LogWindows:Error: UE4Editor-Engine.dll
 [2017.01.14-06.40.49:747][  0]LogWindows:Error: UE4Editor-Engine.dll
 [2017.01.14-06.40.49:757][  0]LogWindows:Error: UE4Editor-Core.dll
 [2017.01.14-06.40.49:767][  0]LogWindows:Error: UE4Editor-Core.dll
 [2017.01.14-06.40.49:777][  0]LogWindows:Error: UE4Editor-Core.dll
 [2017.01.14-06.40.49:787][  0]LogWindows:Error: kernel32.dll
 [2017.01.14-06.40.49:797][  0]LogWindows:Error: ntdll.dll
 [2017.01.14-06.40.49:807][  0]LogWindows:Error: ntdll.dll
 [2017.01.14-06.40.49:817][  0]LogWindows:Error: 
 [2017.01.14-06.40.49:827][  0]LogWindows:Error: Crash in runnable thread PoolThread 4
 [2017.01.14-06.40.49:837][  0]LogWindows:Error: end: stack for UAT
 [2017.01.14-06.40.49:857][  0]LogCook:Display: Cooking /Game/BossMonster/BossHitListWidget -> C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/BossMonster/BossHitListWidget.uasset
 [2017.01.14-06.40.49:868][  0]LogTemp: Running texturetool with '-i "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/176943ce4df1b12a8c0c8b1f156e9d1RGBToPVRIn.pvr" -o "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/176943ce4df1b12a8c0c8b1f156e9d1RGBToPVROut.pvr"  -legacypvr -q pvrtcfast -f PVRTC1_4'
 [2017.01.14-06.40.49:877][  0]LogExit: Executing StaticShutdownAfterError
 [2017.01.14-06.40.49:887][  0]LogSavePackage: Save=1.70ms
 [2017.01.14-06.40.49:897][  0]LogSavePackage: Async saving from memory to 'C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/BossMonster/BossHitListWidget.uasset'
 [2017.01.14-06.40.49:907][  0]LogWindows: FPlatformMisc::RequestExit(1)
 [2017.01.14-06.40.49:917][  0]LogSavePackage:Display: Finished SavePackage C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/BossMonster/BossHitListWidget.uasset
 [2017.01.14-06.40.49:927][  0]LogTemp: Running texturetool with '-i "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/177925840a3d69ee89bfe8377b5d3c5RGBToPVRIn.pvr" -o "../../../../../../Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Intermediate/Cache/177925840a3d69ee89bfe8377b5d3c5RGBToPVROut.pvr"  -legacypvr -q pvrtcfast -f PVRTC1_4'
 [2017.01.14-06.40.49:937][  0]Log file closed, 01/13/17 22:40:49
 

 `

I was able to build out Android packages just fine in 4.14, right up until I had a weird message-less crash. After that crash, nothing seemed to change. I could still make Windows builds, but Android no longer worked. I tried deleting Save, Intermediate, Build, and Binaries folders several times, but that didn't help. I also reinstalled Visual Studio 2015 twice.

I'm all out of ideas and none of my Google searches seem to help. Does anyone have some ideas as to how I might fix this? I was on the verge of my first Google Play release.

Product Version: UE 4.14
Tags:
more ▼

asked Jan 14 '17 at 06:54 AM in Packaging & Deployment

avatar image

MaxSMoke777
138 14 17 37

avatar image Samantha Sutton ♦♦ STAFF Jan 16 '17 at 10:16 PM

MaxSMoke777,

The crash that you're running into looks like it might be a texture issue. Did you follow the documentation to create a more efficient texture on a mobile device?

Are you able to reproduce this issue in a newly created project? If so, could you please provide me with the full reproduction steps?

Thanks!

avatar image MaxSMoke777 Jan 17 '17 at 10:05 PM

Well it couldn't be that I'm doing something outside the limits of UE4 and Android because I was able to compile and build using all of the materials.. at least up until recently. I haven't made any new materials between the time it did compile and didn't compile, just used the existing ones. I do use a system of swappable textures for random appearances, but that was working before I had compiler issues in 4.14, as well as in 4.12, 4.10, and 4.8.

When you say "Newly Created", do you mean like migrating all of my resources to a new package? Or do you mean just making any random thing and seeing if it will compile at all?

avatar image Samantha Sutton ♦♦ STAFF Jan 18 '17 at 05:28 PM

Upgrading your project between multiple versions of the engine can cause errors sometimes when packaging. If there were any major upgrades to the way the engine used specific blueprints, or features removed, that could be the reason.

However, I would like for you to test whether or not you're having this issue on a newly created project (without any additional content added, including your own). That will narrow it down to whether or not it's your assets.

Thanks!

avatar image MaxSMoke777 Jan 19 '17 at 02:54 AM

I made a new project, set it up for Android in Project Settings, tried to compile... and got a another crash. This is in UE4 14.4.3

Looks like it crashes right here. It stops right at the letter "f":

UATHelper: Packaging (Android (All)): UE4Editor-Cmd: [2017.01.19-02.53.31:510][ 0]LogCook:Display: Cooking /Engine/BasicShapes/Cone -> C:/Users/MaxSMoke777/Documents/Unreal Projects/MyProject8/Saved/Cooked/Android/Engine/Content/BasicShapes/Cone.uassetAsync saving f

UATHelper: Packaging (Android (All)): CommandUtils.Run: Run: Took 18.926s to run UE4Editor-Cmd.exe, ExitCode=3

UATHelper: Packaging (Android (All)): Project.Cook: Cook failed. Deleting cooked data.

avatar image Samantha Sutton ♦♦ STAFF Jan 19 '17 at 07:46 PM

I need to see the rest of the logs too. Please include those with your reply. Upload a screenshot of your Android SDK too, here is an example:

Android SDK

avatar image MaxSMoke777 Jan 20 '17 at 01:18 AM

Oooh, I think I might see a problem. For some reason the SDKConfig section is all blank, there's no directories in it at all. There must have been earlier, as I was able to build until recently. Are those the directories I should have in there?

BTW, I did try to post the logs, but I can't seem to post more then 2000 characters. I tried to post all of my log several times, but the comment wouldn't allow me to. How do I include such long files in a comment?


Ok, I updated my NVPack stuff and changed all of my settings to match yours... and it's still crashing on a "Pool 3" error. Nothing has changed at all!

avatar image Samantha Sutton ♦♦ STAFF Jan 24 '17 at 04:56 PM

Save your logs in a .txt file and upload them so I can review what's going on. Let me see a new screenshot of your Android SDK as well.

Much appreciated. :)

avatar image MaxSMoke777 Jan 25 '17 at 12:34 AM

Ok, that should be all of it. The screenshot is a bit pointless, as it exactly matches yours from before after I installed all of the new stuff. It still builds a package for Windows without any problem (knock on wood).

link text alt text

avatar image Samantha Sutton ♦♦ STAFF Jan 25 '17 at 07:18 PM

You're getting the error from this uasset file. Please check over the asset and make sure that all is set up correctly. If you're not sure, could you send it to me in a sample project? You can upload it to Google Drive and provide it to me in a private message on the forums.

 'C:/Users/MaxSMoke777/Documents/Unreal Projects/MineTank/Saved/Cooked/Android/MineTank/Content/BossMonster/Boss-Subbody-Anim-DownHeavyFire.uasset'

I would suggest checking out your deprecated blueprint and fix any issues with it:

 [2017.01.25-00.26.45:590][  0]LogBlueprintSupport:Warning: You're exporting a UBlueprint ('BossMonsterHeadPawn') editor object with your cook. This is now DEPRECATED (the Blueprint's class & CDO should be all that's needed). Please fix up any relience you have on it, and add the following to your editor ini file (these settings will become the default):
 [EditoronlyBP]
 bAllowClassAndBlueprintPinMatching=true
 bReplaceBlueprintWithClass=true
 bDontLoadBlueprintOutsideEditor=true
 bBlueprintIsNotBlueprintType=true

Thanks!

avatar image MaxSMoke777 Jan 26 '17 at 04:06 AM

What does "the Blueprint's class & CDO should be all that's needed" mean? I don't have any source code, it's all blueprints. I don't see any packaging options to turn that on or off. Also, what does CDO mean?

As for a sample project, should I just send you the whole thing? I think, if I delete stuff Saved, Intermediate, Build, and Binaries, it's only about 200Mbs total.

avatar image Samantha Sutton ♦♦ STAFF Jan 26 '17 at 04:49 PM

So the error:

 [2017.01.25-00.26.45:590][  0]LogBlueprintSupport:Warning: You're exporting a UBlueprint ('BossMonsterHeadPawn') editor object with your cook. This is now DEPRECATED (the Blueprint's class & CDO should be all that's needed). Please fix up any relience you have on it, and add the following to your editor ini file (these settings will become the default):

Means that some settings or how you've set up your blueprint is no longer valid in the version of the engine that you've upgraded to. As the engine is updated, certain aspects are deprecated and no longer used, it's possible that a feature you were using has since been replaced by another.

Please review the 'BossMonsterHeadPawn' and make sure that there aren't any errors in it, check to make sure it's working correctly. Sometimes you may simply need to refresh the pin node connections.

If you send me a sample, deleting those files should be fine. It depends on how your internet connection is. If uploading a smaller project using only that blueprint and necessary files is smaller, go ahead and do that. Whichever you feel comfortable with.

Please let me know when you've sent a link to me on the forums in a private message so I can begin my investigation.

Thank you! :)

avatar image Samantha Sutton ♦♦ STAFF Jan 30 '17 at 04:52 PM

I packaged your project using Android (ALL) without any troubles. Even with the deprecated files, I had no issue. I'm attaching my logs for you to see that I didn't run into an issue.

Output Logs

  • Did you try to package your project with the zip you provided me?

  • Could you upload your dxdiag from the machine you're developing on?

maxsmoke777.txt (1.6 MB)
avatar image MaxSMoke777 Jan 31 '17 at 02:32 AM

I just unzipped and put all of files in a new directory, started UE4, tried to compile for Android (All) and it failed like it did before.

I think this is the DXDIAG log you are looking for, right? I've never made one before. I've made no changes to my system that I can think of since my game last compiled successfully, but I did have that one crash where the UE4 editor just vanished without a crash message. After that, I couldn't compile my game. It started up normally, as far as I could tell, and seems to run fine now. I can also compile for Windows without any problems.

link text

avatar image Samantha Sutton ♦♦ STAFF Feb 01 '17 at 04:31 PM

Try the following:

  • Restart your computer

  • Delete your Intermediate and Saved folders from your project

  • Deactivate your anti-virus if you're using one

  • Make sure only the editor is open while trying to package

  • Try to package for Android ETC1, ETC2 and All

If any or all fail, please show me the logs. I have yet to reproduce the issue in-house with your project.

Make sure to turn your anti-virus program back on if you notice it doesn't make a difference. If there is an issue with your anti-virus, please let us know which one you're using and the version.

Thank you!

avatar image MaxSMoke777 Feb 04 '17 at 01:29 AM

I don't believe I have any anti-viral software running, at the moment. I've restarted my computer several times since the build failure started. I've also removed my Saved, Intermediate, Build, and Binaries folders to see if that helped, many times. In the past that alone fixed this problem, but it's not helped at all now. And I just tried to compile for ETC1 and got the exact same error. [1]: /storage/temp/124913-uat_log.txt

avatar image Samantha Sutton ♦♦ STAFF Feb 07 '17 at 04:29 PM

Are you able to delete your version of the engine and reinstall it, and pull the project from the zip that you provided me and see if that resolves your issue? I've seen where that's resolved a few others in the past.

Another suggestion, have you tried migrating your project to a new project? You'll have to set up the project settings again, but it's worth a shot. The fact that it worked on my computer and it's not working on yours though, seems that the project isn't have an issue and it may be with your engine or an application is preventing it perhaps.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

MaxSMoke777,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Feb 13 '17 at 03:48 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question