x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't untick 'never stream'

I've had some texture that have had 'Never Stream' enabled for awhile. I want to disable it now but I can't. Either pressing the arrow that resets the property to default, or clicking the checkmark to disable it, neither works. And it's only happened to half my textures, the other half works. I'm not sure what to do to fix this.

Product Version: UE 4.13
Tags:
more ▼

asked Jan 16 '17 at 01:24 AM in Bug Reports

avatar image

Rael5
122 13 18 30

avatar image AndrewHurley Jan 16 '17 at 08:12 PM

Hey Rael5,

You might want to try deleting your Saved, Intermediate, and Config folders. This stores temporary information like logs, screenshots, and configurations set within the editor for your project. Be sure to make a copy of these folders before deletion!

If that does not resolve the issue, can you give me some steps so I can reproduce it on my end in a new blank project?

Thanks,

Andrew Hurley

avatar image Rael5 Jan 16 '17 at 10:44 PM

That didn't work either. It also didn't work when copying and pasting a uasset to another project. Here is one of the uasset's in question.

Just use it in a project and try to disable 'Never Stream'.

2.zip (5.9 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

So your issue is that your texture file is not a power of two texture, meaning it cannot integrate into our streaming system. Streaming textures require mips, and mips cannot be generated for non-power of two textures. The texture file you provided to me was 127x128 which is why you cannot uncheck the 'Never Stream' option.

You have two choices from here if you want it to be a streaming texture. You can use the 'Power of Two Mode' option within the Texture settings. This will pad you non square textures to the nearest power of two so they can be integrated into texture streaming.

Original Texture

alt text

Padded to Power of Two

alt text

Here you can see that once I have padded my texture to the nearest power of two value, it creates a line of visible pixels which I have chosen to highlight in pink so you can better understand how the padding works. You can take this route, or you can simply reimport your texture at the correct 128x128 texture resolution.

Cheers,

Andrew Hurley

more ▼

answered Jan 17 '17 at 02:44 PM

avatar image Rael5 Jan 17 '17 at 03:47 PM

I see. It would be nice to have an indicator in the engine of what is available and what isn't when the texture isn't power of 2, but thanks for the explanation.

avatar image Pierdek Oct 28 '17 at 08:49 AM

Hi Andrew, I have another question related to NeverStream, whether texture marked with NeverStream will always reside in the memory even if it isn't currently used? MemReport shows 0 use count.

Regards

Piotr

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question