x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Online Multiplayer (Doesn't work over steam, Works over LAN)

Hello, I have been trying to network a multiplayer game for the past few weeks, and have been unsuccessful. When running on my machine, or via LAN I connect just fine. I have the online subsystem, and subsystem steam working, but I have never made a connection. It has been hard troubleshooting these problems, since I don't have regular access to two networks. Any help would be appreciated, thanks!

The tutorials my project is based around: https://docs.unrealengine.com/latest/INT/Videos/PLZlv_N0_O1gYqSlbGQVKsRg6fpxWndZqZ/abmzWUWxy1U/index.html

https://wiki.unrealengine.com/Steam,_Using_the_Steam_SDK_During_Development

Product Version: UE 4.14
Tags:
more ▼

asked Jan 17 '17 at 02:12 AM in Using UE4

avatar image

KitCatミΦᆺΦ彡
1 1 2 2

avatar image aoakenfoArchiact Feb 02 '17 at 10:12 PM

In your DefaultEngine.ini add this for verbose online logging:

 [Core.Log]
 LogOnline=All
 LogOnlineGame=All

In addition to that, you can set breakpoints in the online subsystem if you run it as "Debug Game Editor" and -game (under Project Properties -> Debugging -> Command Arguments in Visual Studio).

Although I'm a big fan of blueprints, I've often found it necessary to drop into the C++ to debug online issues.

avatar image 人生甜长 Jan 21 '19 at 09:56 AM

Have you solved your problem? I'm having the same problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello - i'm definitely having the same exact errors as you - this worked in a 4.13 LAUNCHER build with the AdvancedSessions plugin used .... but I am having no such luck with 4.14.3 SOURCE BUILD even with just using the engines FindSessions default node (NO PLUGIN REQUIRED).

MAKING SURE that your DefaultEngine.ini has the following (below) as well steam obviously running... I cannot get sessions to be viewable across the WAN.... i'm setting up to check local LAN now - but i imagine the same will be true.....

AGAIN - This works in 4.13 with the same exact setup no problem.

FIND SESSIONS: http://puu.sh/trohs/7333508a79.png

HOSTING SESSIONS: http://puu.sh/tromE/b4d9b9c032.jpg

:

 [/Script/Engine.Engine]
 !NetDriverDefinitions=ClearArray
 +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")
  
 [OnlineSubsystem]
 PollingIntervalInMs=20
 ; Uncomment the following line to use the Null Subsystem
 ;DefaultPlatformService=Null
 ; Uncomment the following lines to use the Steam Subsystem
 DefaultPlatformService=Steam
 VoiceNotificationDelta=0.2 
 
 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
 SteamAppId=480
 GameServerQueryPort=27015
 bRelaunchInSteam=false
 GameVersion=1.0.0.0
 bVACEnabled=1
 bAllowP2PPacketRelay=true
 P2PConnectionTimeout=90
more ▼

answered Jan 19 '17 at 04:34 AM

avatar image

walldiv
117 9 13 24

avatar image KitCatミΦᆺΦ彡 Jan 30 '17 at 08:22 PM

My DefaultEngine.ini has been properly modified, and even went so far to make sure the ThirdParty Binaries were in place. I upped the max results for sessions in case that was an issue too. The part that really has me stuck is that I receive 'No servers found' instantly, as if the search failed, however, it did not. Might this be an issue working on steam's AppId=480 "SpaceWars"?

The project seems to run fine in simulated multiplayer, replication etc seems to be okay. It is the pier-to-pier connection that isn't being made. Here is the example project I'm trying to get working.

http://www.unrealtek.net/wp-content/uploads/2015/08/MP_Steam.7z

Props to UnrealTek!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question