x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux compile option not appearing for cross compilation

Quite simple, the platform option in visual studio to compile for linux never appears. I've set my environment variables correctly, I've restarted, I've tried all versions of the clang toolchain. Currently using 4.12.5 as my engine version.

When I run Setup.bat it correctly downloads linux dependencies, but the generateprojectfiles.bat file doesn't give me a linux solution.

Furthermore if I try compile linux in the editor it brings me to the online documentation.

Thanks

Product Version: UE 4.12
Tags:
more ▼

asked Jan 17 '17 at 09:22 AM in Linux

avatar image

Constan7ine
138 14 15 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This lacks details on which exactly variables are set. Since you are using 4.12.5, you should use v7 cross-toolchain and LINUX_ROOT environment variable. Open a DOS prompt (cmd.exe) and type

 %LINUX_ROOT%\bin\clang++.exe --version

If your setup is indeed correct, you should see clang output with the version of 3.7.0. If it says that the command is not found then the cross-toolchain has not been set up correctly.

more ▼

answered Jan 17 '17 at 02:46 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image Constan7ine Jan 17 '17 at 04:28 PM

I did this and I got a confusing result:

alt text

I have correctly setup the environment variable, but it doesn't seem to register the path correctly.

capture.png (12.1 kB)
avatar image RCL STAFF Jan 17 '17 at 09:07 PM

Your directory is called C:\UE-Toolchain while environment variable holds value of C:\UE_Toolchain, so this is the problem (underscore instead of a hyphen).

avatar image Constan7ine Jan 17 '17 at 09:10 PM

Oh my god how did I not see that. Thank you, and apologies for the dumb moment.

avatar image RCL STAFF Jan 17 '17 at 09:13 PM

No prob, glad it was easy.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question