x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Engine Crashes when loading maps (Assertion Failed)

It started when I was importing some character models and the engine crashed and would crash on start-up. I reverted back to a version of the project that worked fine the day before (the latest Git Commit) and it happened again. I deleted everything except for the content folder and the .uproject file and I was able to get into the editor but now the engine crashes whenever I try to load maps.

This is what I have tried:

  • Updating from 4.14.1 to 4.14.3

  • Reinstalling the engine completely

  • Reverting back to the latest version of the project on our GitHub (that has always worked)

  • Updating my graphics drivers (I have a GTX 980Ti using driver version 376.33)

  • Restarted my pc(lol)

Here is the error:

 Assertion failed: Template
 [File:D:\Build\++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp]
 [Line: 3866]

Here is where the error occurs in LinkerLoad.cpp (line 3866) alt text

And here are the Crash Logs (zip)

Product Version: UE 4.14
Tags:
more ▼

asked Jan 17 '17 at 01:34 PM in Using UE4

avatar image

Wheeze
31 5 5 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

So my solution was more of a workaround: Find an old version of the project that didn't crash and then start systematically replacing the assets in that version with the assets from the latest version until I found out which assets were the culprit and then just fixing the compiler errors that occurred when I ran the game using the old versions of the assets that were the culprits.

more ▼

answered Jan 17 '17 at 04:09 PM

avatar image

Wheeze
31 5 5 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I started reverting back to old commits until I found one that actually loads maps. Even though this commit is 4 days old the commit that doesn't work is one where I organized the content folder, moved a few assets around. I downloaded the last working commit and I started replacing .uasset files and entire folders with the ones from the latest commit and I have been able to recover my work but so far the folders that initiate the crash again are the folders that I did the most amount of organizing.

So moving assets into seperate folders seemed to have corrupted my project somehow. I'm trying to get to the bottom of this, I'll report back with more as I find out exactly which assets are problematic.

more ▼

answered Jan 17 '17 at 03:15 PM

avatar image

Wheeze
31 5 5 12

avatar image Wheeze Jan 17 '17 at 04:08 PM

Alright this all seems to stem from one asset: My crafting menu widget.

When I started recovering all my files folder by folder I found out that my interface folder and folders containing blueprints that referenced the crafting menu widget. So I used the old interface folder and then a bunch of blueprint compiler errors occurred and I had to go to each blueprint that referenced the crafting menu (and the other widgets that I moved as well when I was organizing my content folder) and reconnect some pins and change some variable types.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just adding to the record, I was unable to get into the editor after attempting to update from 4.13.1 source version to 4.14.3 source version. It looks like a similar error to this but more specifically I am getting: Assertion failed: ExportMap.IsValidIndex . Reverting back to the 4.13.1 source version got me back into the editor.

more ▼

answered Jan 18 '17 at 07:16 PM

avatar image

Allenheathx
16 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question