x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash - 4.15.0preview1 during "Open a copy" of a project on Mac

I tried to open my 4.14.3 project in 4.15.0preview1 on macOS using the "Open a Copy" button.

It crashed very quickly -- no crash reporter, just the macOS system crash dialog.

Here is the OS crash log

Product Version: UE 4.15 Preview
Tags:
macos-crashlog.txt (112.6 kB)
more ▼

asked Jan 18 '17 at 07:46 PM in Bug Reports

avatar image

CleanCut
2.1k 66 84 77

avatar image CleanCut Jan 18 '17 at 07:54 PM

I tried manually making a copy of the project and then doing "Convert In-Place" while opening it with 4.15.0preview1. This also resulted in a crash, but this time I got the UE4 Crash Reporter:

Crash Logs

avatar image Steve Hardister ♦♦ STAFF Jan 18 '17 at 10:19 PM

Hi CleanCut,

I'm having difficulty tracking your crash in our track reporter database? When the Crash Reporter was present did you hit the send button?

Also, are you able to reproduce this crash or did this just happen once while trying to convert your project in place?

Please respond with this information and we will continue to investigate.

Thanks,

Steve H.

avatar image CleanCut Jan 18 '17 at 11:02 PM

Steve,

Yes, I hit the send button on the crash reporter. ("Send and Close", specifically).

I tried converting it again. It appeared to get the exact same error. This time I typed in a message, took a screenshot, and pressed "Send and Restart". Here's the screenshot:

alt text

Immediately after the dialog closed it tried to restart and crashed again with the same error. Very reproducible...for me.

avatar image Steve Hardister ♦♦ STAFF Jan 19 '17 at 06:41 PM

I was able to locate your crash information this morning and have found the bug you are experiencing has a bug report already open: UE-40781. However, in order to pinpoint the cause we need to be able to reproduce this in house.

To that end, would you be willing to provide us with a copy of your project so that I can try to open it and reproduce the results on one of our Macs? If so, please provide a link to your file zipped and uploaded to Dropbox, Google drive, etc. sent to me in a Private Message on our Forums.

I'll also need your Mac's specs in order to test on a similar machine and in the correct OS.

avatar image Pirate Tony Jan 20 '17 at 05:49 AM

1 day ago my issue was closed, but in my case i just run UEditor from launcher (without any project) and then it crashes:

https://answers.unrealengine.com/questions/550557/415-p1-crash-on-start-macos.html

i sent yesterday 6-8 reports from macbook air and iMac as well. problem still

avatar image Steve Hardister ♦♦ STAFF Jan 20 '17 at 06:17 PM

Hi PirateTony,

Your issue was closed because you are experiencing the same crash we are investigating as UE-40781 on this post.

In order to help identify the issue, please provide your system specs. Also, since this is not crashing on a specific project, please try to open the editor by navigating to UnrealEngine>4.15>Engine>Binaries>Mac>UE4Editor and right click, select "Open" to try and open without the Launcher.

Try after restarting your computer to make sure you are starting "fresh."

Thanks,

Steve H.

avatar image CleanCut Jan 20 '17 at 06:50 PM

Steve, my system specs are below. I will PM you a link to the project to download through the forum.

alt text alt text alt text

avatar image CleanCut Jan 20 '17 at 06:55 PM

Steve, I can't find you on the forums. What is your username?

avatar image Steve Hardister ♦♦ STAFF Jan 20 '17 at 07:51 PM
avatar image CleanCut Jan 20 '17 at 07:56 PM

Ah, the substandard webapps rear their ugly heads again. You don't come up in a search for "steve" or "hardister", because the forum search is case-sensitive. :-P

avatar image Steve Hardister ♦♦ STAFF Jan 20 '17 at 09:33 PM

Quick update, in case you did not receive my reply to your PM, I was able to download your project. I'll update here whether or not we could reproduce the issue. Thanks again for your cooperation in helping to identify the source of the bug.

avatar image CleanCut Jan 21 '17 at 09:53 PM

I replicated the same crash on my Mac Pro (different set of hardware)

alt text alt text alt text alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Cleancut,

Thanks for supplying a sample project -it was a great help in isolating the issue quickly. The bug has been resolved and the fix scheduled for the next engine preview.

-Steve H

more ▼

answered Jan 23 '17 at 09:44 PM

avatar image CleanCut Jan 23 '17 at 09:51 PM

@Steve Hardister Glad to hear you were able to isolate the issue and fix it! Don't you love it when a plan comes together?

avatar image CleanCut Feb 06 '17 at 11:02 PM

Confirmed fixed in 4.15.0preview3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question