x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Black screen on android project, but not Tappy Chicken

Well, the title says most of my question.

Deploying Tappy Chicken or Swing Ninja works perfectly, but if I try and deploy one of my own projects, they crash on start. Also, I thought it might be some setting specific to new projects, so I opened Tappy Chicken and placed more assets around and then deployed - worked fine, I then removed all assets in the 3d space and built a bsp cube with a light above it ( and the player start ) and tried to deploy this, and the app launches and just sits on a black screen, no sound or input. ( but doesn't crash )

I know there are a notable amount of questions already asked about this black screen issue, but I could not get any information out of the other threads that fit me, they seem to have the black screen issue, as I do; but for me not all of the games give a black screen, ONLY projects I start myself, anything from Epic works fine - which is what leads me to believe it is something on my end that I am not doing.

any information relevant to my issue would be appreciated!

Product Version: Not Selected
Tags:
more ▼

asked Jun 11 '14 at 03:27 PM in Packaging & Deployment

avatar image

catfishermen
6 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Howdy Xaser3D,

I have been able to reproduce this issue internally using Sun Temple and a Mali device. I has also found out that there is JIRA report, UE-3632, for this issue and the issue has yet to be resolved. I have also tested this issue on our latest internal build and the issue is still occurring. I will be sure to update you when I hear more about this report.

Thanks and have a great day!

more ▼

answered Dec 29 '14 at 05:43 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.

Thanks!

more ▼

answered Nov 25 '14 at 04:59 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

avatar image Kronos623 Dec 02 '14 at 09:03 PM

I am still having this issues on 4.5. Can you help us? Have you just made a random project and got it to work on your phone Sean?

avatar image [Epic] Gribbs ♦♦ STAFF Dec 02 '14 at 09:37 PM

Howdy Kronos,

What phone are you using to deploy your project too? Also, are you using the Binary or Source version of UE4?

Any additional information would be greatly appreciated.

Thanks and have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I get a similar problem. On Mali 400 tablet

more ▼

answered Dec 09 '14 at 09:02 PM

avatar image

Xaser3D
91 2 7 8

avatar image [Epic] Gribbs ♦♦ STAFF Dec 09 '14 at 09:05 PM

Hey Xaser3D,

I am going to need a bit more information from you before I begin looking into this issue. What version of UE4 are you currently using and is that version a Source build or from Binary?

Any additional information would be greatly appreciated.

Thanks!

avatar image Xaser3D Dec 09 '14 at 09:23 PM

I using unreal engine 4.5.1 binary. I tested my project on all available for download version and everytime get black screen. Tappy Chicken works and compiled perfect.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 10 '14 at 02:58 PM

Howdy Xaser3D,

So i just tested the 4.5.1 version of Tappy Chicken and had no issue when deployed to a Mali 400 device. If you deploy a blank template project, are you able to see the project or are you seeing a black screen as well?

What is the exact device that you are currently using?

Thanks!

avatar image Xaser3D Dec 10 '14 at 05:06 PM

I also successfully deploy Tappy Chicken on mali 400-450 tablets. I get the problem when I deploy empty project configured for mobile platform. I turn off hdri and other unsupported staff. When I deploy a blank template the project start with black screen. My own project start black, widget menu also start black.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 10 '14 at 07:27 PM

Hey Xaser3D,

Thank you again for reporting this issue. I was able to see the black screen error occur with the appropriate device. I have entered Jira Ticket UE-6536 into our database so that it may be resolved in a future release.

Thanks again and have a great day!

avatar image Xaser3D Dec 25 '14 at 02:01 PM

Running my project on mali 400 I get a lot of artifacts. I have problem with shaders and scene light. How can I resolve this issue? Previously UDK 3 Epic Citadel has no problem on mali 400 and runs vary good without artifacts.
Link: https://vimeo.com/115386797

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question