x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SceneCapture2D not working on mobile

Hey, my SceneCapture2D works fine on PC but it is coming up black on my mobile Android Phones. Sometimes, if I change the size of the Canvas or the Texture I am able to get very glitchy random pattern/colored squares (instead of only black), but never do I get anything even closely resembling the correct image.

Is there any easy solution to this? I am willing to change engine code if anyone has super clear instructions.

Product Version: UE 4.14
Tags:
more ▼

asked Jan 20 '17 at 06:38 PM in Bug Reports

avatar image

NAbreuM
21 1 2 3

avatar image CleanCut Jan 20 '17 at 08:14 PM

Can you show your code/blueprints/screenshots?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I never got a response to this. Replying to get communication back on.

more ▼

answered Feb 08 '17 at 09:27 PM

avatar image

NAbreuM
21 1 2 3

avatar image AllanBentham STAFF Feb 09 '17 at 02:19 PM

Hi,

Does this occur when not in GearVR mode?

avatar image econty Feb 18 '17 at 01:24 AM

I'm not the original requester, but yes, it occurs on my S6 even when not rendering in GearVR mode. SceneCapture2D works fine on PC, but on Android I end up with a black screen or garbage.

avatar image AllanBentham STAFF Feb 20 '17 at 06:20 PM

I can repro on GearVR too, i'll look into it. Thanks.

avatar image NAbreuM Feb 20 '17 at 07:13 PM

Yes, this occurs even when I am not in GearVR mode. Anything on the PC looks perfect (even when in "device test" mode), anything on the actual device is either fully black or just complete nonsense.

avatar image JackP STAFF Feb 21 '17 at 04:06 AM

I've entered ticket UE-42191 to track this.

avatar image nesrak1 Feb 21 '17 at 10:43 PM

I too am having this problem. Is there anyway to vote on this issue or anything?

avatar image JackP STAFF Feb 22 '17 at 09:11 AM

Hi, we're actively working on a fix for this now. I've just upped the priority and requested that the ticket UE-42191 be made public. When it is you can follow the progress there.

Thanks

avatar image nesrak1 Feb 23 '17 at 10:18 PM

Then I guess it's fixed. Going to compile the source and see if it works.

avatar image cleolivia98 6 days ago

Did this ever get fixed? It's still black on my engine. I tried following what the ticket says to do and it's utterly useless. This sucks

avatar image NAbreuM Feb 24 '17 at 03:18 PM

Yea, I see fixed on the ticket. Will this fix roll out on 4.16 or earlier?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

Is Mobile HDR enabled or disabled in your project settings? What is your SceneCapture's Capture Source set to? Finally what Android device(s) are you seeing this on?

That can help us narrow down what is going wrong.

Thanks Jack

more ▼

answered Jan 23 '17 at 01:25 PM

avatar image

JackP STAFF
515 16 6 19

avatar image NAbreuM Jan 23 '17 at 07:37 PM

Mobile HDR is off. I've tried SceneCapture Capture Source with a Dynamic Material instanced from a Surface Material with a blank texture and changing the texture value of the Dynamic Material. I have also tried doing it by instancing a Canvas Render 2D Target and setting the Scene Capture's Canvas Render Target to that instance.

Both of those methods work on PC but don't seem to work on Android.

Currently I am testing on an S7. The game is a VR game for Samsung Gear VR which is only for specific devices. Like 2 months ago I had tested the same exact code on an S6 and it was working, but I do not currently have the S6 with me to test it again. I have not changed any of the code in the past 2 months though, aside from upgrading from 4.12 to 4.14.

Back in 4.12, this same error would happen on a Samsung Note 5, I wrote another ticket and I was told it was a rendering issue that was fixed in 4.13, after upgrading and seeing it still not working on the S7 I am curious if it has something to do with newer phones, since the S6 was working and it was the oldest of the phones.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same problem, RenderTarget2D doesn't output the texture on GearVR Android UE4.18 today is 15-Jan-2018, and this bug still exists and I have to work around. Anyone knows either: 1) How to override FOV on GearVR, regular way of setting FOV for the Camera doesn't do it because of VR. 2) How to do RenderTarget2D work, I was going to use it as a workaround of 1) but it has another bug. Black-Screen and nothing else.

Please help. It's been a year of this thread, and maybe someone fixed it. Some bugs don't get fixes for years. I hope there is some workaround.

more ▼

answered Jan 15 '18 at 08:38 PM

avatar image

smbv1
21 5 6

avatar image cleolivia98 6 days ago

Has been still another year. I'm trying to develop on the recently revealed Quest and it is not working :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question