x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PIE crashing editor and launch fataly exits

When I click PIE, the editor crashes, even if all I've done is open the project and click Play. Attempting some debugging, I click launch, wait for it to build and start running but the game window crashes before showing anything. Everything builds fine in both VS and Unreal, the only problem is when I try to run the code. I'd be fine if it errored on clicking Play and gave me something useful to work off of, but the whole editor crashes! Launch works as expected and just the game window crashes (though the error is in an engine file, nothing I modified).

I'm doing some pretty simple C++ and blueprint work to get some random generation stuff working but I wouldn't expect to crash the entire editor! I should probably also mention that the editor has been somewhat unstable for a bit now. Often times, building (in VS or via the editor) causes the editor to crash and I've had to send probably, 10 crash reports.

I have no doubt that the crashing is due to my C++ code as without it in the level there's no crashing. I just feel like the entire editor shouldn't crash and burn every time I try to run my code.

This is a link to the log when I click Launch.

This is a link to the log when I click Play.

Product Version: UE 4.14
Tags:
more ▼

asked Jan 20 '17 at 10:11 PM in Bug Reports

avatar image

dlkulp
3 1 1 4

avatar image Tim C ♦♦ STAFF Feb 06 '17 at 08:42 PM

Hi dlkulp,

We have not heard back from you for a while. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post if you need any additional help.

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Well, the error says:

 FObjectInitializer::Get() can only be used inside of UObject-derived class constructor

So...what does your code look like? Are you explicitly calling Get() somewhere? Did you forget UCLASS() or GENERATED_BODY() or inheriting from a class somewhere?

Just some shots in the dark without seeing your code.

more ▼

answered Jan 20 '17 at 10:30 PM

avatar image

CleanCut
2.1k 67 84 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question