x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint Bug - Date Time value resets when sent to/from server

When sending a date time either FROM/TO the CLIENT/SERVER the value is reset to a default value.

alt text

alt text

Product Version: UE 4.14
Tags:
more ▼

asked Jan 23 '17 at 02:56 AM in Bug Reports

avatar image

elitereloaded
694 24 24 55

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey elitereloaded,

I've come across an issue in our database that seems to be relevant to what you're experiencing:

https://issues.unrealengine.com/issue/UE-22533

Take a look and let me know if that is the same thing you're seeing.

Have a great day

more ▼

answered Jan 23 '17 at 07:41 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image elitereloaded Jan 23 '17 at 08:50 PM

Sorry about the duplicate posts, I don't know how I managed to post 3 of the same topic.

I'm aware of the bug you linked to because I created this topic last year https://answers.unrealengine.com/questions/431010/gamestate-datetime-variable-not-replicating-to-cli.html

They might be caused by the same code bug, but they are different scenarios which is why I posted this question.

The first scenario is if you set a class variable to replicate and it's type is DateTime when it replicates to the client it's value is reset.

The second scenario is if you call a replicated event and you send along with it a DateTime struct the value is reset when it arrives at the remote system. It doesn't matter if the DateTime is nested within a custom struct or if it's passed in as a parameter to the replicated event -- it's always reseting.

So they are probably caused by the same code bug, but they are two different scenarios which is why I created this topic -- just in case there are two different bugs in the code causing this.

avatar image Sean L ♦♦ STAFF Jan 24 '17 at 04:11 PM

No problem, sometimes things just get duplicated.

It's great that you've discovered another repro for this issue. I am also thinking that it's related to the original bug. As a result, I'll update the ticket with the information you've provided, and if it does turn out to be something different I'll be sure to create a new one.

Thanks for your report.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question