x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Issue with "Online" Plugins missing (Steam Integration)

Up until a few days ago, it appears my Steam (OnlineSubsystem) for my Unreal Engine have stopped working all together. Nothing with steam (the overlay, etc) would show. I thought maybe I broke something within the Project, so I went and did a download of the MP Project provided by Epic Games from a YouTube channel where they did a complete Steam Integration, and I also downloaded another Steam MP Project from a guy on youtube who did a 2 hr + tutorial.

Steam Overlay works for none of these projects.

I tried doing a complete uninstall and reinstall of steam + 4.12.5 and 4.11 (the versions that the projects are compatible with, and it still doesn't work.

I went into my "Plugins" section and it appears that I am missing the entire "Online" category. Any ideas? This has really put me behind.

Regards

Product Version: UE 4.12
Tags:
more ▼

asked Jan 21 '17 at 10:26 PM in Packaging & Deployment

avatar image

IAMRichardT
3 1 3 5

avatar image IAMRichardT Jan 21 '17 at 11:35 PM

After some tinkering around -- it actually ended up being Steam itself. It needed to be closed completely and re-opened. I don't understand why, but it's working now. project.gheist did provide some useful information, so I mark it as solved thanks to him.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Before 4.13, the online subsystem plugins were integrated in the core engine source code (under /Engine/Source/Runtime/Online/OnlineSubsystemSteam). The OnlineSubsystems got turned into plugins in 4.13, hence that you are missing them in your engine version.

To enable SteamWorks in 4.12, and earlier, you need to do bCompileSteamOSS=true; in your build.cs file (only enable for desktop platforms).

Hope that helps. Cheers,

more ▼

answered Jan 21 '17 at 10:40 PM

avatar image

project.gheist
1.6k 22 10 49

avatar image IAMRichardT Jan 21 '17 at 10:44 PM

Thanks, #1) I don't do a lot in the back-end yet as far as C++, so where would I locate that file? #2) Would you have any idea as to why just now it just stops working all together? It worked fine for about 2 weeks into the project, and then one day, just stopped.

avatar image IAMRichardT Jan 21 '17 at 10:49 PM

I read up a little, and it tells me that is only for a C++ project, whereas mine is completely blueprint at this point. So my steps for enabling steam was just to edit the DefaultEngine.ini file and place the proper information in there. Quite confused about this.

avatar image project.gheist Jan 21 '17 at 11:03 PM

Some things to keep in mind/test:

  1. You need to have steam logged in before starting the game or editor

  2. Have you tried to bring up the overlay in standalone? People have had issues with the online subsystems in PIE

  3. bCompileSteamOSS should be true by default if it detects that the correct SteamWorks folder in your {thirdparty source directory}/Steamworks/{SteamVersion}. Check /Engine/Source/Programs/UnrealBuildTool/Configuration/UEBuildConfiguration.cs for which version your engine requires (I believe for 4.11/12 it is Steamv132)

avatar image IAMRichardT Jan 21 '17 at 11:07 PM

Thanks for the replies. 1) I always keep Steam online when I try to test. 2) Yes, that's the only thing I use is Stand-alone mode. I heard that using PIE caused a lot of issues so I avoid it. 3) I'll run through those folders. The only thing I find interesting, is when it worked. I use to go into Unreal Engine and goto the Plugins section and see an "Online" category. Which had the subsystem stuff in it. Now all of a sudden (after the reinstall) I don't have that anymore. Nothing related to Steam is in the plugin list (except for controller and VR plugins). It's very odd because even after loading the Multiplayer tutorial made by Epic, Steam doesn't work in there either, so it's making me wonder if it's something on my computer causing the issue.

avatar image IAMRichardT Jan 21 '17 at 11:11 PM

It appears I'm missing the folder UnrealBuildTool all together. Should that be?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question