x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.12.5 Using Console Commands Freezes Engine?

I just downloaded 4.12.5 today because it's the version we're using for one of my classes and I went to type "HighResShot" in the console and the application completely froze? I tried it a couple more times to the same result, tried typing in other commands and found out if I type anything in the console it freezes the entire engine and I have to reload my session. I even tried opening a new project and the problem persisted. Anyone else having this problem? Or is there anyone who has a solution to this? Thanks!

Product Version: UE 4.12
Tags:
more ▼

asked Jan 24 '17 at 05:39 AM in Bug Reports

avatar image

FoxyHipHop
1 1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey FoxyHipHop,

I'm thinking that the reason your PC is freezing is likely due to the machine's specs. High Res Shot is a very powerful tool and requires a fairly beefy system in order to be utilized properly, as stated in the documentation linked below:

https://docs.unrealengine.com/latest/INT/Engine/Basics/Screenshots/#highresolutionscreenshottool

Unfortunately, if your PC is on the slower side, there is a definite possibility that this command could freeze the editor.

Let me know if you have any further questions, and I'll be glad to help.

Have a great day

more ▼

answered Jan 24 '17 at 02:22 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

avatar image FoxyHipHop Jan 24 '17 at 04:13 PM

Hey Sean, it's not even just the HighResShot command though, it's the entire console command bar that will freeze the editor if i type anything into it, even random letters. I do have a lower end PC but I'm still able to use HighResShot effectively in 4.10. Also it's not freezing my entire computer, just Unreal.

avatar image Sean L ♦♦ STAFF Jan 24 '17 at 04:44 PM

Interesting, thanks for the information.

Could you provide your dxdiag so I can take a look at your system specs? I'm not able to reproduce this freeze on my end.

Also, if you could test in 4.14 to see if you experience the same freeze, that would be great. It's possible it was related to something that has already been fixed, although I couldn't find a ticket for it.

avatar image FoxyHipHop Jan 25 '17 at 03:36 AM

Sure thing! Thanks for your help so far, it'll definitely save me time down the linelink text

dxdiag.txt (116.6 kB)
avatar image Sean L ♦♦ STAFF Jan 25 '17 at 02:49 PM

After looking at your dxdiag, there are a couple of things I recommend:

  • Testing the issue in 4.14 to see if a later version resolves the issue.

  • This step is what I truly recommend: ensure that your graphics card drivers are fully up-to-date. Please check this and update them if they are not.

  • Another thing to keep in mind is that if you're using integrated graphics, you'll definitely want to have a higher amount of available RAM. I'd recommend at least 16gb, which it currently looks like you are below based on what I saw in the dxdiag.

Let me know if updating your drivers or testing in 4.14 helps.

avatar image FoxyHipHop Jan 25 '17 at 09:13 PM

Yes!! Updating the drivers worked, thought I had updated recently but wasn't the case, thanks for your help!!!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question