x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

The same obscure thing keeps crashing lighting builds

Main problem:

The same obscure thing (v1.58E06AB8B4CC07117C2393116B3F127BA9D5F0AE.mtrlgz) keeps crshing lighting builds.

Steps tried:

  • I have purged duplicate material names and duplicate mesh names.

  • I have cleared the SwarmCache.

  • I have deleted the DerivedDataCache.

  • I have made sure SwarmAgent isn't already running before initiating a lighting build from within the Editor.

  • I have tried both the Launcher-based 4.14.3 Editor and the Editor compiled from the Release source (yesterday).

  • I have copied all of the assets into a new Blank Level without lighting.

  • I have added a bit of basic lighting.

  • I have had the Reflection Capture re-capture the scene.

  • I have copied the project to another drive, and done all of the above on it.

    Lamentation:

Nothing has worked, and it fails on that GUID every time (yes, even after clearing cache, deleting cache contents, copying whole project to another internal drive, running under different Editors.)

SwarmAgent log:

11:40:32 PM: ... initialization successful, SwarmAgent now running 11:40:32 PM: [Interface:TryOpenConnection] Local connection established 11:40:32 PM: [Job] Accepted Job 7952B2BB-44ADF6B9-C78A4E93-3CDFE5EF 11:40:48 PM: [Interface:OpenChannel] Error: System.IO.IOException: The process cannot access the file 'C:\Git\UnrealEngine\Engine\Saved\Swarm\SwarmCache\AgentStagingArea*v1.58E06AB8B4CC07117C2393116B3F127BA9D5F0AE.mtrlgz*' because it is being used by another process. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) at NSwarm.FSwarmInterface.OpenChannel(String ChannelName, EChannelFlags ChannelFlags)

Pleading:

  • Lightmass building with SwarmAgent starts on a different computer, but that computer never finishes, takes too long or runs out of virtual memory.

  • What more can I try?

Product Version: UE 4.14
Tags:
more ▼

asked Jan 26 '17 at 07:05 AM in Bug Reports

avatar image

jinngonqui
1 2 3

avatar image jinngonqui Jan 31 '17 at 04:06 PM

I have also made sure that none of the objects have a scale of 0,0,0.

avatar image jinngonqui Jan 31 '17 at 04:07 PM

I have also uninstalled all versions of UE4, including the Launcher; then, reinstalled the latest Launcher from Epic, and only the latest Engine (which is the version I have been working in).

avatar image jinngonqui Feb 01 '17 at 05:54 AM

I have tried updating the C++ redistributables and the VS redistributables (which would not install, because a newer version is already installed.)

avatar image jinngonqui Feb 01 '17 at 06:40 AM

Oh, yeah, and I also tried Verifying the Engine instance via the Launcher ... both on the installation that existed before the problem, and also on the re-installed version.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey jinngonqui,

Have you been able to reproduce this is a new blank project, or are you testing the same project? This does not mean a new level or new project with the content migrated over. I mean a completely new blank blueprint or C++ project.

Just in case there are things you haven't tried yet, take a look at the guide below.

Swarm Agent Troubleshooting Guide https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting

Can you provide me with your 'dxdiag' so I can take a look at your machines specs?

Make sure your firewall is disabled for Swarm Agent as this can prevent your lighting from building as well.

Thanks,

Andrew Hurley

more ▼

answered Feb 15 '17 at 05:14 PM

avatar image jinngonqui Feb 15 '17 at 05:21 PM

Hi Andrew,

I have tried it on the same project, in a fresh .umpa scene, with just a few BSD's, and starter-content materials. Works great. I have been able to delete all of the migrated assets from the troubled .umap, and it works. So it seems clearly an asset in the Content folder, which only bugs things up when it's in a .umap. I am going to try divide and conquer on bringing back in the migrated assets. I'll try the dxdiag before I do that: one on the old .umap that has all of the migrated assets, and is failing; and one on the new .umap devoid of them migrated assets.

Thanks!

avatar image Ironbelly Jun 10 '17 at 09:15 PM

ran into to this again today(feels like this is a monthly occurence). Went through all of my streaming levels, turning them off one at a time, until it baked properly to find which level contained the issues. After that I deleted 1/2 of the assets, which allowed it to bake properly.. So I undid that and deleted half of those assets, until I could narrow it down to one asset that was causing this issue. I deleted that, and went on with my day

Funny(and by that I mean infuriating) enough when I reloaded the level in again with that bad asset after successfully building lights it worked fine.. no idea why but yet another reason I have no hair after using this engine for 3 years

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question