x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Migration fails from 4.12.5 to 4.14.3

Recently we attempted to migrate from 4.12.4 to 4.14.3.. Instead of migrating smoothly, as we have every other time, I was directed to Visual Studio. We do have a segment of custom C++ to allow for custom Player Bindings but the error I'm getting when the migration fails is

"Running C:/Program Files/Epic Games/4.14/Engine/Binaries/DotNET/UnrealBuildTool.exe TempestEE Development Win64 -project="D:/My Projects/Extinction Event/TempestEE 4.14 - 2/TempestEE.uproject" -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE @progress push 5% Parsing headers for TempestEEEditor Running UnrealHeaderTool "D:\My Projects\Extinction Event\TempestEE 4.14 - 2\TempestEE.uproject" "D:\My Projects\Extinction Event\TempestEE 4.14 - 2\Intermediate\Build\Win64\TempestEEEditor\Development\TempestEEEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed LogPluginManager:Error: This project requires the 'FixItNotePlugin' plugin. Install it and try again, or remove it from the project's required plugin list. LogCompile:Error: Failed to initialize the engine (PreInit failed). Error: UnrealHeaderTool failed for target 'TempestEEEditor' (platform: Win64, module info: D:\My Projects\Extinction Event\TempestEE 4.14 - 2\Intermediate\Build\Win64\TempestEEEditor\Development\TempestEEEditor.uhtmanifest, exit code: CrashOrAssert (3))."

Knowing that the Fixit is not supporting 4.1.4.3 yet, I removed it from 4.12.5 prior to the migration attempt. After it had failed I also tried migrating to 4.13 with the same result.

We're really in a bind. Any help is appreciated.

Product Version: UE 4.12
Tags:
more ▼

asked Jan 27 '17 at 05:35 AM in Using UE4

avatar image

Wranglerltg
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Install fixitnote in 4.12, see if there are still notes etc placed in your levels/etc. delete them all. clear any ue4 related cache. (often located at: C:\Users\XXX\AppData\Local\UnrealEngine) see if there is still a reference to it in the Uprojectfile (open it in a text editor) and clear it if so.

clean up any references.

only then uninstall fixitnote. Migrate.

should work. good luck!

more ▼

answered Jan 27 '17 at 11:31 AM

avatar image

Luos
9.3k 286 64 330

avatar image Wranglerltg Jan 27 '17 at 04:59 PM

@Luos I asked my team but you're right I should check manually. I'll check the cache and the uprojectfile.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question