x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint Events not firing in packaged game

Hi,

we are using a bunch of custom events for our project. We declare them as BlueprintNativeEvent in C++, and then use the blueprinted version for gameplay logic. While PIE, everything works perfectly fine. But after packaging the project, the blueprint-versions of those events never fire. The native implementation works, but the blueprint version doesn't. Is there anything we can do?

Item.h:

UFUNCTION(BlueprintNativeEvent, Category = "Item")
void OnBeginFocus();

Item.cpp:

 void AItem::OnBeginFocus_Implementation()
 {
     // Render outline
     if (Mesh && bAllowFocus)
         Mesh->SetRenderCustomDepth(true);
 
     // Change the crosshair image according to this item's interaction mode
     HUD->ReportNewFocus(InteractionMode);
 }

The C++ implementation works fine in the packaged project, but the blueprint version never fires...we even tried putting ALL the logic into the blueprinted version. Didn't work either.

Product Version: UE 4.14
Tags:
more ▼

asked Jan 27 '17 at 01:15 PM in Packaging & Deployment

avatar image

ShawnBaxe
1 1 2

avatar image Sean L ♦♦ STAFF Jan 30 '17 at 03:26 PM

Hey ShawnBaxe,

Could you do me a favor and add a debug message or log a message that you can check in your log file?

I'm curious if the event is not firing, or if the actual functionality is what isn't working in a packaged game.

Let me know if you see the event firing after printing the message for debug purposes.

Thanks

avatar image ShawnBaxe Jan 30 '17 at 04:50 PM

The event is not firing. I've added a debug message to both - the C++ implementation and the blueprint version. The C++ version is firing. The BP one is not. I've even tried to leave the C++ version empty. Still...the BP version is not firing after packaging. Double-checked things by also trying it in the editor - and there it is firing as expected.

avatar image Sean L ♦♦ STAFF Jan 31 '17 at 03:48 PM

Thanks for the information. Unfortunately, after attempting to reproduce the issue on my end, I'm not seeing the same behavior. Would you mind creating a simple test project, zipping it up, and providing it via Dropbox or Google Drive?

I'd like to have a closer look at your setup to see if I'm missing a step somewhere.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Feb 07 '17 at 05:52 PM

avatar image

Sean L ♦♦ STAFF
44.2k 485 149 436

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question