x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Standalone is broken - different results vs PIE

Hello.

When i play game in PIE, everything seems to be correct, however when i try to play game in Standalone, there are some bugs.

  1. i can't see some basic UE4 skel. meshes (strange is that only in few actors)

  2. mesh of some skeletal meshes is rotated wrongly

Strange is when i try to change this robot mesh to another robot, its rotated correctly... Where might be the problem? I dont rotating mesh anywhere nor hiding... Picture shows everything:

http://i.imgur.com/OBHlLKo.jpg

Product Version: UE 4.14
Tags:
more ▼

asked Jan 29 '17 at 09:48 PM in Bug Reports

avatar image

Name368
118 7 15 20

avatar image Matthew J Jan 30 '17 at 03:11 PM

Hello Name368,

Can you give some context on this assets that are having this issue? What kind of blueprints are these assets? Are their skeletal meshes being set at runtime or in the construction script? Is the robot being rotated by anything in the blueprint that could be causing this? Have you tried packaging the game to see if it works in that case?

avatar image Name368 Jan 30 '17 at 06:54 PM

Hello, These BPs are characters. Skeletal mesh is set as default mesh, no runtime or CS settings. Robots arent rotated by anything, only camera rotating whole character (use controller rotation..) but not mesh. I wanted to package game however its 7GB sized so i gave it up after 1 hour when i read somewhere that one guy packaging 500mb project 45 mins... so this can took whole day... i can send you these robot assets if you want...

avatar image Name368 Jan 30 '17 at 07:30 PM

oh god this is crazy...

i " solved " this...

  1. Black disappeared mesh - strange is that when i ctrl+c ctrl+v that actor, it worked, he was not hidden anymore in standalone play...

  2. Wrongly rotated robot in standalone - now i "solved" it with rotating back mesh to 0°, i launched standalone and it was rotated as in pie, so i rotated him back to desired rotation (-90°) and magically now its rotated correctly in both, pie and standalone...

so what was bad? something like cache in pie? now it will be very hard to reproduce this bug again but i want to help to repair this (engine bug?) so if you want any informations or assets from me, feel free to ask me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Can you try reproducing this issue in a clean project? I would also suggest trying the "Cook Content for Windows" option under the File menu in the editor. This could be an issue with the content not being loaded correctly which may be remedied by that.

As far as the packaging times, I would suggest making sure that there are no unnecessary assets in your maps and then navigating to Edit > Project Settings > Packaging > List of maps to include in a packaged build (the settings need to be expanded at the bottom to see this). Add elements to this equal to how many of your maps you would like to include in your packaged game and then fill the maps in there. This should cut down on any unused assets that may be in your project.

more ▼

answered Jan 30 '17 at 07:24 PM

avatar image Name368 Jan 30 '17 at 07:33 PM

I think you're right, probably not loaded contend, so you can make this as resolved :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question