x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light build stops at .10% or 9.96% or crashes editor.

Light build stops at .10% or crashes editor. I am using 3 networked computers on swarm to do it... Not sure whats happening but i cant complete a build.

I have attached the log from swarm....

link text

  • Update.. This time it made it to 9.96%.... but it simply had stopped there... editor is back without any build process going... u can move around in it but the objects in the level are not culling properly.. invisible most of the time.. so its a broken build yet again.... Build simply wont work!!! help!

*Update 2.. After trying to narrow it down by building only sub levels 1 at a time....It seems to only happen with one of the sub levels. What I remember about this sublevel is that when i added it to the main level as one of hte sublevels it was originally in a different directory. Since then I have manually moved that sublevel to a different directory and fixed redirectors. At first fixed redirectors wouldnt work on that sublevels build data file, but after a build and save all it seemed like all was well..

Thats the only thing i can really figure out is wrong with this sublevel if there was a problem... So what is happening here???

Product Version: UE 4.14
Tags:
log.txt (10.3 kB)
more ▼

asked Jan 31 '17 at 02:05 AM in Bug Reports

avatar image

kurylo3d
464 46 80 105

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Kurylo3d,

I don't see any crash reports submitted in our CrashReporter system. Is this crash not opening the Crash Reporter window?

The Swarm Log didn't really have anything useful. Can you set it to super verbose logging and re-try getting the crash. Also, I know you have a couple of machines, which machine are you using for this one? Mostly curious about RAM amount since this is the largest factor in Lightmass Crashes that happen.

If the sub-level was the only thing keeping it from completing the build I can try and see if I get the same results. Anytime a level is moved you should either delete or move the builddata asset with it and fix up redirectors. I'll see if I can reproduce that part.

Thanks!

Tim

more ▼

answered Jan 31 '17 at 04:44 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 877

avatar image kurylo3d Jan 31 '17 at 06:26 PM

Hey Tim,

The one crash i did get a crash reporter window but did not send it in. So far no repeat of the crash, just tried like 7 or 8 times. I tried

In terms of memory.. the main computer with the swarm connection is 16 gb... though i will say everytime i try to bake lighting and close out unreal.. my machines total memory gets lower and lower.. liek its still 16gb, but the memory is taken up.. though no task is showing it... so eventually it shows 90% memory taken at only like 1 gb used from all the applications. That perhaps may have been the thing that triggered the crash after several attempts... That being said even when i rendered the one level out seperately which was not a large sublevel... it still has the bug.

In terms of that sublevel.. the first time moved it i moved the level -> fixed up redirectors -> moved the build data ->fixed up redirectors again... BUT!!! the fix up redirectors would never work for the build data.. like i can do it over and over and fix redirectors would keep trying.. with a quick progress bar. Even relaunching the editor and doing fix redirectors would still not allow a permanent fix of the redirectors.. it simply wasnt fixing it i guess. But after that I built the lighting and everything (I think seemed to work fine after the build and save all).. but fix redirectors and save alone was not working before that build...

Now that level is the level causing the issue.. I have tried creating an entirely new level and selecting all actors in the first problem level and moving them all to the new level... did save all ... tried removing the problem level from the level window.... and relaunching unreal.. The level would keep reappearing in the levels window.... After i delete in windows level and save all... id try to delete the level but it would say the level is being referenced in the main level.

avatar image kurylo3d Jan 31 '17 at 06:26 PM

So I finally did a build after removing that level from the level window.. did save all... Build was still broken.. ending at like 9.96 %... but i did save all anyway since i have a back up of the project. Now the old level isnt referenced with it anymore so thats a bonus... ive kicked off another build at home to see if it goes through this time... but its doubtful.. We will see.

avatar image kurylo3d Jan 31 '17 at 06:29 PM

I will also try superverbose next time.

Also anotehr mention the other 2 computers .. 1 has 6gb and 1 has like 32 gb... the 6gb is on the swarm and not the main computer.. dont know if that could ever effect anything, but again ive built it with 1 level alone and that still didnt work with the problem sub level.

avatar image kurylo3d Feb 01 '17 at 12:59 PM

Good news! I found the problem and it seems like the last build worked.

As i mentioned i had the problem level causing issues and it was a level originally transferred form another directory and all that...

so.. i selected all teh assets in that level transfereed that to anotehr level and did save all.. Now deleting the problem level from the level window... was a problem... id delete it.. it wouldnt be there but it was still referenced in that level no matter what. Rebuilding it after deleting it didnt go through and was still messed up, but doing save all after rebuilding it with it deleted made it so that problem level was no longer referenced in the main level or level window ever again...

So a final build with it no longer referenced actually made it to 100%... lets hope i dont encounter it again.

*UPDATE...

the build is oddly screwed up now... i get like 5 fps.... and stat scenerendering says i have 25,000 draw calls which makes no sense.... LIke all culling just isnt working after this build...wtf...?

  • Update again... nevermind... all is well i think. May have just screwed up when transferring the map from one computer to another... But the main comp seems to have draw calls running fine.

avatar image kurylo3d Feb 06 '17 at 12:02 PM

Ok.... problem is back again... none of the original levels are even the original levels anymore.. I have moved their assets into entirely newly created levels....

so yea... it crashed on me around 13% yesterday... So i reset the main computer just to be sure memory isnt an issue. I tried again and it didnt crash but simply stopped at 13.9%....

I didnt do the super verbose thing... Will try that today to see what errors popup... The only error i got was it telling me it failed in red text in swarm.

avatar image kurylo3d Feb 06 '17 at 09:21 PM

Update*

The build worked with out my third computer (my laptop) on the swarm. Why would that be? My laptop has the most memory out of all 3 computers. Why would it be causing problems(If that in fact is the reason.) I will try a build tonight with it with the super verbose setting

avatar image kurylo3d Feb 07 '17 at 09:15 AM

Well... it made it to 100% again.. so it worked with all 3 computers doing a build. So I have no idea why sometimes it doesnt work and sometimes it does work. It all seems very inconsistent. I cant narrow down why... I suppse ill keep the super verbose on just in case it ever does fail again.

avatar image kurylo3d Feb 26 '17 at 04:09 AM

Looks like hte problem is back in 4.15... i used super verbose and have attached the log this time for that... The following link is the location.

https://answers.unrealengine.com/questions/568534/light-build-stops-at-005.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question